Plex from iPhone X (iOS 11) via AirPlay won't play on AppleTV3

apple-tv

#1

Hello.

I just setup my old AppleTV 3 in the bedroom but for some reason I can't get it to play my movies and tv shows from Plex. I'm using my iPhone X with iOS 11 to stream from via AirPlay. When I choose the AppleTV 3 the screen goes dark 2 times and then it just stays on the app screen on the AppleTV 3. The iPhone app looks like it is still trying to play the movie via the AppleTV 3 but it never does. I have also tried from my girlfriends iPhone 7 and from our sons iPad, but nothing seems to work?


#2

Same issue here, too. I have an iPhone 6s and my wife has the 7. Neither will stream to the appletv via airplay. Same thing above happens to us - screen blinks twice then spinny wheel.


#3

same here... this is going for at least three weeks for me


#4

Seems like a bug. Got the same problem as you guys, tried multiple iOS devices. Hope there is a fix soon for the AppleTV3 users. :smile:


#5

Thanks for your replys, I can see on my iPhone today that Plex has pushed an update for the iOS app that regards the AppleTV 3, so I hope the problem has been fixed.


#6

Hi I have the same problem from Ipad 3 on Apple TV 3 the monitor turns on and off twice and it does not work, has anyone fixed the problem?


#7

It seems to be back up and running now. Thank you.


#8

Still isn’t working for me… but found a workaround: mirroring iPad to Apple TV3 before launching the video. Works, but with buffer pauses…