Plex is always using Direct Play in violation of the preferences

server-dlna

#1

In my DLNA client (an Oppo BDP-103), h264 videos play OK but h265 is not supported. In the "Preferences" folder, "Direct Play" and "Direct Stream" are set to Disabled. But when I play any video the "Now Playing" tab on PMS shows "Direct Play", even though I turned it off.

This looks like a bug, right?

Plex Media Server Version 1.5.7.4016 on FreeBSD 11.0


#2

All preferences under 'Web' are not valid globally. They are just relevant to the Plex Web app in this particular browser.

When Plex has not a fitting 'Hardware profile' for a DLNA device, all it can do is Direct Play.
If you want Plex to transcode, you need to tell it to which file format, which codecs etc. All of this is done with hardware profiles.

You can search in this particular subforum if someone already wrote such a profile for your hardware.
Writing it yourself requires a lot of insight in the inner workings of Plex and digital media in general.
It can be very frustrating. Trust me, I've tried.


#3

I'm not referring to the preferences under "Web". I changed the settings in the DLNA folder that is presented to the device. These settings should apply directly to that device, but they seem to be ignored.


#4

@DavidXGA said:
I'm not referring to the preferences under "Web". I changed the settings in the DLNA folder that is presented to the device. These settings should apply directly to that device, but they seem to be ignored.

Even the settings there are bound by the restrictions of the hardware profile.
If there is no hardware profile, Plex doesn't know into which format it shall transcode. Therefore it doesn't transcode at all.