Plex is transcoding what seems to be a compatibile file, What do I need to change?

roku

#1

I'm in the process of converting my DVD library to digital. I used MakeMkv to rip them and Handbrake to encode them in H264 format. After that I convert the audio to AAC Stereo and normalize the audio to 89 DB. This is done using Xmedia Recode

I went with an MP4 container with the m4v extension for backwards compatibility.

As far as I know that should be compatible with Roku Plex.

However, Plex is still transcoding it for some reason. It says the file is not able to be direct played.

Is there something I'm missing?

I can provide more information if need.


#2

Provide an example paste of the ‘get info’ Media Info screen within an forum attached text file, or within “code” format tags.


#3

@JamminR said:
Provide an example paste of the ‘get info’ Media Info screen within an forum attached text file, or within “code” format tags.

Here is an example

Media

Video Resolution 480p
Duration 41:51
Bitrate 2685 kbps
Width 710
Height 480
Aspect Ratio 1.78
Container MP4
Video Frame Rate 24p
Web Optimized No
Audio Profile lc
Video Profile high

Part

Duration 41:51
File NCIS Los Angeles - S01E02 - The Only Easy Day.m4v
Size 803.69 MB
Audio Profile lc
Container MP4
Indexes sd
Web Optimized No
Video Profile high

Codec H264
Bitrate 2251 kbps
Anamorphic true
Bit Depth 8
Chroma Location left
Chroma Subsampling 4:2:0
Color Primaries smpte170m
Color Range tv
Color Space smpte170m
Color Trc bt709
Frame Rate 23.976 fps
Height 480
Level 3.1
Pixel Aspect Ratio 32:27
Profile high
Ref Frames 5
Stream Identifier 1
Width 710

Codec AAC
Channels Stereo
Bitrate 425 kbps
Language English
Audio Channel Layout stereo
Profile lc
Sampling Rate 48000 Hz
Stream Identifier 2

Codec VOBSUB
Bitrate 8 kbps
Language English
Stream Identifier 3

Let me know if there is anything else that would be helpful in diagnosing this.


#4

Well, I’m not sure I can be of any help.
Are you using subtitles? Plex will often place text into the stream which requires transcoding.
Unless you have your Roku set to <2mbps playback, it looks very similar to my encodes.
Exceptions;

  • My Media-Video Frame Rate = NTSC (unsure what that means, other than next line)
  • My Part - Frame Rate - 29.97 (yours is 23.976)
  • My Web Optimized - Yes (this moves a info header called an ‘atom’ to the beginning of the file)
  • My Width - 720 (yours is 710, as though you’re losing 10 pixels somewhere - I’d expect this of height due to widescreen, but not width.

Edit - Your audio bitrate for AAC is too high. Roku SDK for compatibility limits to 256k

I use MakeMKV, then Handbrake using rokoding.com settings for Roku (which overall, are compatible with most devices in the past 5 years - though I do add an additional AC3 surround track for my home theater, the first is stereo for compatibility)
The rokoding.com does have gain and DRC recommendations, so I don’t normalize.

Media

    Video Resolution SD
    Duration 1:58:29
    Bitrate 1878 kbps
    Width 720
    Height 364
    Aspect Ratio 2.35
    Container MP4
    Video Frame Rate NTSC
    Web Optimized Yes
    Video Profile high

Part

    Duration 1:58:29
    File My_movie_DVDRip_x264_AC3.mp4
    Size 1.55 GB
    Container MP4
    Indexes sd
    Web Optimized Yes
    Video Profile high

    Codec H264
    Bitrate 1263 kbps
    Anamorphic true
    Bit Depth 8
    Chroma Location left
    Chroma Subsampling 4:2:0
    Color Primaries smpte170m
    Color Range tv
    Color Space smpte170m
    Color Trc bt709
    Frame Rate 29.97 fps
    Height 364
    Level 3.1
    Pixel Aspect Ratio 32:27
    Profile high
    Ref Frames 5
    Stream Identifier 1
    Width 720

    Codec AAC
    Channels Stereo
    Bitrate 167 kbps
    Language English
    Audio Channel Layout stereo
    Profile lc
    Sampling Rate 48000 Hz
    Stream Identifier 2

    Codec AC3
    Channels 5.1
    Bitrate 448 kbps
    Language English
    Audio Channel Layout 5.1(side)
    Sampling Rate 48000 Hz
    Stream Identifier 3

#5

As soon as you activate those vobsub subtitles, you will get transcoding.

I don’t think that a stereo AAC stream with over 320kbps is compatible with many embedded devices. I could be wrong though.


#6

@Ottokerner - I was thinking same, checked last night and though ‘no that’s ok’, and now that I doublecheck, realized I was wrong yesterday and mis-read.
Roku SDK for audio states 256 is highest.
https://sdkdocs.roku.com/display/sdkdoc/Audio+and+Video+Support#AudioandVideoSupport-SupportedAudioFormats

I’ve edited my original post.


#7

Thank you both for responding.

I test played a few files and Ottokerner was correct. It starts transcoding as soon as I activate subtitles. I’m guessing there is no way to stop this short of burning them in which I would rather not do.

I also checked the audio bit rates of some of my other files. They must have increeased the maximum bit rate, because I have files with bit rates higher than 256 that aren’t transcoding.

Thankfully, the hit on the processor is light so its not a huge deal.

At least that clears of the mystery of why Plex was transcoding.

I do have an unrelated question.

When I load up files in Handbrake (latest version) sometimes automatically detects a size smaller than the source file.

For example, if the source file is 720 x 480, Handbrake selects 710 x 480. The difference is not consistent.

I used to manually adjust it but I noticed something odd on an encode of one of my movies. Manually adjusting the parameters seemed to move the sub titles up a bit.

I haven’t done a side by side comparison so it could have been my imagination.

Should I be manually adjust the size or is there not harm in leaving it as is?

EDIT: I’m using a Roku Premiere +.


#8

Handbrake tries to detect and crop black borders around the image. The resulting image size is of course smaller then. Plex likes it that way. It will adapt.

You can see how much Handbrake wants to crop on the ‘picture’ tab. Use the Preview feature to verify the decision.


#9

@OttoKerner said:
Handbrake tries to detect and crop black borders around the image. The resulting image size is of course smaller then. Plex likes it that way. It will adapt.

You can see how much Handbrake wants to crop on the ‘picture’ tab. Use the Preview feature to verify the decision.

Good to know. Thanks again.