# Plex-Issued Server Certificate Error

**URL:** <https://forums.plex.tv/t/plex-issued-server-certificate-error/719756>\
**Category:** Plex Media Server\
**Tags:** server-windows\
**Created:** [June 1, 2021, 3:17pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756 "2021-06-01T15:17:13Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Radioman01](https://avatars.discourse-cdn.com/v4/letter/r/dc4da7/32.png) [@Radioman01](https://forums.plex.tv/u/Radioman01)\
**Post date:** [June 1, 2021, 3:17pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/1 "2021-06-01T15:17:13Z")

</div>

Server Version#:1.23.2.4600  
Player Version#:n/a  
  
Server has been running for a long time since reboot (~30 days). After restarting, I am now seeing the following in the logs. I have 2 servers configured the same way and they both did the exact same thing when restarted:  
Jun 01, 2021 10:14:00.901 [4940] ERROR - [CERT] PKCS12\_parse failed: error:23076071:PKCS12 routines:PKCS12\_parse:mac verify failure  
Jun 01, 2021 10:14:00.902 [4940] ERROR - [CERT] Found a certificate, but couldn’t install it.

Note i am NOT using custom certificates, this is the Plex-issued one since day 1. I now have 2 servers that will start, but are not connectable because of the above error. If i rename the “Plex Media Server\cache\certificate.p12” file to something else, the error goes away but the server is still unreachable.

Any help would be greatly appreciated as I now have 2 systems down for the count.

---

<div class="post-metadata">

**Author:** ![robin\_bockman](https://avatars.discourse-cdn.com/v4/letter/r/e95f7d/32.png) [@robin\_bockman](https://forums.plex.tv/u/robin_bockman)\
**Post date:** [June 3, 2021, 8:34pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/2 "2021-06-03T20:34:11Z")

</div>

Same problem here on 1.23.2.4625

---

<div class="post-metadata">

**Author:** ![BigWheel](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/bigwheel/32/78783_2.png) [@BigWheel](https://forums.plex.tv/u/BigWheel)\
**Post date:** [June 4, 2021, 1:41am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/3 "2021-06-04T01:41:07Z")

</div>

would either of you mind sending me your [server logs.](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) ( click on my username/avatar to message)

---

<div class="post-metadata">

**Author:** ![Radioman01](https://avatars.discourse-cdn.com/v4/letter/r/dc4da7/32.png) [@Radioman01](https://forums.plex.tv/u/Radioman01)\
**Post date:** [June 4, 2021, 4:21am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/4 "2021-06-04T04:21:51Z")

</div>

Unfortunately, it’s been far too long and the logs have rolled over already. I will check backups to see if they have been captured there. For what its worth, the log snippet I provided up top is basically it, the rest is completely normal log entries.

Some additional information, the server is unreachable while in this state, but it will respond in HTTP mode. If you try to browse the server from localhost:32400 it will start the setup wizard.

Here is where things got resolved, but in a very annoying way. So if you keep going with the setup wizard, it will reset your server UID and trash all the shares to friends you had configured (the users will still be there, but with nothing shared), all settings will be reset to default but the libraries and associated database remain intact. After completing the wizard, the server was still not reachable but i was then able to get to the configuration screen at least. From there I went to the Remote Access section and remote access was disabled, when I checked the box a new certificate was issued (this time it was NOT certificate.p12 but cert-v2.p12) and after a bounce of the Plex Media Server service, it came up normally and was accessible again.

I then had to reconfigure the entire server and re-set all the shared libraries I had set up which was annoying to say the least.

This issue appears to be around the switch from the certificate.p12 to cert-v2.p12 and when i restarted the service, the issue reared its head. For what its worth, the server had been running since May 12th after I had done Windows patching. So whatever change happened, it broke between the 12th and the 1st of June. On the 1st I had shut down the server to take a snapshot in VMware before patching it, and it never came back after that shutdown, before I even had a chance to patch.

So my issue is technically resolved but I would REALLY love to know what that was all about. If you would like to do some testing I can restore my server from a backup and do some tests…

Thanks

---

<div class="post-metadata">

**Author:** ![seb\_cocob](https://avatars.discourse-cdn.com/v4/letter/s/b5ac83/32.png) [@seb\_cocob](https://forums.plex.tv/u/seb_cocob)\
**Post date:** [June 5, 2021, 4:36pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/5 "2021-06-05T16:36:36Z")

</div>

Hi,  
encounter the same issue but after the latest plex update.  
See the following error logs in loop :

Jun 05, 2021 18:30:27.220 [2508] Erreur — [CERT] PKCS12\_parse failed: error:23076071:PKCS12 routines:PKCS12\_parse:mac verify failure  
Jun 05, 2021 18:30:27.220 [2508] Erreur — [CERT] Found a certificate, but couldn’t install it.  
Jun 05, 2021 18:30:27.224 [2508] Erreur — [CERT] PKCS12\_parse failed: error:23076071:PKCS12 routines:PKCS12\_parse:mac verify failure  
Jun 05, 2021 18:30:28.479 [2508] Erreur — [CERT] CERT: Error acquiring new certificate: Failed to upload CSR: 429, \<?xml version="1.0" encoding="UTF-8"?\>

How to resolve this point ?

Regards

---

<div class="post-metadata">

**Author:** ![BigWheel](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/bigwheel/32/78783_2.png) [@BigWheel](https://forums.plex.tv/u/BigWheel)\
**Post date:** [June 5, 2021, 4:55pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/6 "2021-06-05T16:55:43Z")

</div>

@seb_cocob I reset it for you.

---

<div class="post-metadata">

**Author:** ![mhunthsd](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@mhunthsd](https://forums.plex.tv/u/mhunthsd)\
**Post date:** [June 21, 2021, 2:39am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/7 "2021-06-21T02:39:47Z")

</div>

I am having the exact same issue, except with the latest CentOS build. Anyway to get mine reset too? My server is registered to the same email in my user profile.

Thanks!

---

<div class="post-metadata">

**Author:** ![BigWheel](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/bigwheel/32/78783_2.png) [@BigWheel](https://forums.plex.tv/u/BigWheel)\
**Post date:** [June 21, 2021, 6:24pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/8 "2021-06-21T18:24:03Z")

</div>

@mhunthsd Reset it for you. I can’t tell if your server is running at the moment so you might need to restart it. if you can message me your [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) it would be appreciated.

---

<div class="post-metadata">

**Author:** ![mhunthsd](https://avatars.discourse-cdn.com/v4/letter/m/e99b99/32.png) [@mhunthsd](https://forums.plex.tv/u/mhunthsd)\
**Post date:** [June 22, 2021, 4:48am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/9 "2021-06-22T04:48:40Z")

</div>

Thanks! Had to restart and reclaim the server but it’s working now.

Thanks again!

---

<div class="post-metadata">

**Author:** ![Rankoh](https://avatars.discourse-cdn.com/v4/letter/r/278dde/32.png) [@Rankoh](https://forums.plex.tv/u/Rankoh)\
**Post date:** [July 5, 2021, 7:44pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/10 "2021-07-05T19:44:59Z")

</div>

Hi,

I am also having problems with errors:  
CERT: Error acquiring new certificate: Failed to upload CSR

My Plex version is 1.23.4.4712 - Synology Package.

Remote Access no longer works I have attached the logs.

Could you please reset whatever it is that needs resetting?

[Plex Media Server Logs\_2021-07-05\_20-39-55.zip](https://forums.plex.tv/uploads/short-url/sv8OcX7lA180B1607zhqvRbgPzt.zip) (4.5 MB)

Thanks,

---

<div class="post-metadata">

**Author:** ![nickhnt](https://avatars.discourse-cdn.com/v4/letter/n/f04885/32.png) [@nickhnt](https://forums.plex.tv/u/nickhnt)\
**Post date:** [July 18, 2021, 11:09pm UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/11 "2021-07-18T23:09:49Z")

</div>

Hi, I’m having the same issue. I will message you my full [Server Logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) as well. Can you please reset my certificate as well?

Jul 18, 2021 15:18:11.103 [3896] DEBUG - HTTP/1.1 (0.1s) 429 response from PUT [https://plex.tv/api/v2/devices/8ad5d722bea99aacafa383fcb2840b83b1d4e155/certificate/csr?reason=missing&invalidIn=0](https://plex.tv/api/v2/devices/8ad5d722bea99aacafa383fcb2840b83b1d4e155/certificate/csr?reason=missing&invalidIn=0) (reused)  
Jul 18, 2021 15:18:11.103 [3896] ERROR - CERT: Error acquiring new certificate: Failed to upload CSR: 429, \<?xml version="1.0" encoding="UTF-8"?\>

---

<div class="post-metadata">

**Author:** ![ckraushaar](https://avatars.discourse-cdn.com/v4/letter/c/8baadc/32.png) [@ckraushaar](https://forums.plex.tv/u/ckraushaar)\
**Post date:** [August 2, 2021, 3:16am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/12 "2021-08-02T03:16:48Z")

</div>

Having the same issue today as well. Using CentOS as well. I wrap my own domain cert from Let’s Encrypt, so not sure if you can reset it, or what the issue is.

[Logs.zip](https://forums.plex.tv/uploads/short-url/xVqSHo4LzsYn1jY3B9zKso4708P.zip) (4.5 MB)

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [October 31, 2021, 3:17am UTC](https://forums.plex.tv/t/plex-issued-server-certificate-error/719756/13 "2021-10-31T03:17:30Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
