Plex Mac Media Server > Update Problem > Unable to create symlink

server-mac

#1

Hi

When trying to install Media Server update on my MacMini running MacOs 10.11.5 from version 0.9.11.1 to latest version 1.0.0.226 I get an Update Problem.

There was a problem installing the update.

Unable to create symlink /var/folders/4h/wd98khmn76lb1n433n1hsc100000gn/T/plexUpdater.QVEBzb/Plex Media Server.app/Contents/Frameworks/Growl.framework/Resources to Versions/Current/Resources details: File exists

What to do?

Any input will be greatly appreciated.

Best regards

Biblings


#2

I'm in the same boat!


#3

Same issue here.. the var folder name and file is different but same issue. Perhaps solution is to uninstall and reinstall clean version? Will see what happens I guess


#4

Same error message here. Trying to get my PS4 to find my PMS. No luck yet, anxious for a fix.


#5

I have the same issue!

Have anyone heard anything from PLEX? they are supposed to have really good support i have heard!

/var/folders/js/nr5lyxy53_qdny6xcjq7nzpm0000gn/T/plexUpdater.TXGPZz/Plex Media Server.app/Contents/Frameworks/Growl.framework/Resources to Versions/Current/Resources details: File exists


#6

I too have the same problem....
same message as stenos...


#7

Hi,

I too have just received this message. Any fixes yet?


#8

same here.


#9

I've read somewhere that Plex had issues with symlink when installed in a pool of hard drives. The recommendation was to install on a single hard drive and not on a partition built of many disks.

My install was on windows at the time.


#10

@stenos said:
Have anyone heard anything from PLEX? they are supposed to have really good support i have heard!

They do, but this is a forum here, not a Support Ticket System. ;)

The community exchanges here and sometime a thread catches their attention.


#11

I have this same problem, any word on a fix, or is this a new feature?


#12

I was able to mitigate this bug by downloading a new copy of the server app, exiting the current server, then copying the new server into the application folder. When I started the server up again, it was up to date. Now I'll have to see if the next update can occur as designed instead of this manual kluge.


#13

The upgrade worked for me after I deleted the problematic symlinks so that the installer can recreate them:

cd /Applications/Plex\ Media\ Server.app.new/Contents/Frameworks/Growl.framework
rm -f Growl Headers Resources Versions/Current


#14

Same problem with the December 2017 server update. This time I downloaded from techworld.com, erased my local server, then copied the new server into Applications. The error was a little different this time, something about a growl file that already existed. I believe trashing the old server and copying a new server too less of my time, so I'm ok with that. However, it would be nice to be able to go back to the days when I could just click on the "Install Updates" button on the settings menu. When you hire developers off the street, the user experience tends to drop through the floor.