Plex Media Player not responding to Alexa to play content



I have Plex linked to Alexa to control playback on my Plex Media Player. I run the latest embedded version of the Plex Media Player on Raspberry and the latest version of Plex media server. Plex is responding fine to Alexa voice commands, however when I ask to play content ("Alexa ask Plex to play Supergirl") Alexa responds with "enjoy watching Supergirl" but Plex does not actually start playback. How to solve this?


I am also experiencing this same issue with PMP on my Mac Mini. Alexa will however send content to my Roku without issue.


I couldn't get it to work properly with Plex Media Player until I changed the setting "Allow Fallback to Insecure Connections" from "Never" to "On same network as server" (changing it to "Always" would also work but this would obviously be less secure).


Tried to change the insecure connections settings, but it did not solve the playback command problem


I have this issue too. Alex understands the Plex command but the Apple tv player responds with "can't continue playback because the connection with your server was lost".

Tried the different network settings as suggested, but same error message.

Some help in resolving this issue would be greatly appreciated. Just got the Echo and I'm anxious to get this great new feature up and running.


Same issue here.


Same issue here


same here ... any news ?


... and me too :-(

Ubuntu PlexPass Media Server on LAN, Fire TV and Echo Dot on WiFi
All on the same IPv4 subnet.

Secure connections is set to preferred

All devices are inside the "LAN Networks" and "List of IP addresses and networks that are allowed without auth"

From either device "Ask Plex to play xyz" results in the "Now playing xyz" ... but nothing actually plays.

From dot "ask Plex to pause/resume" works as expected on whatever's playing on the FireTV, so definitely some connectivity there.

However Pause followed by a long enough wait for FireTV to drop to screen saver and the player appears to resume the film but leave the screensaver up. So we can hear it but not see it. Pressing a suitable button on the FireTV remote and the screensaver vanishes revealing the film behind.

Have run out of things to test. Any suggestions?



Add me to this list. When I first connected my Echo to Plex it would play the content I asked for: "Alexa play Movie" and the movie played. This also worked for a few songs. After about 10 minutes of playing around, enjoying the cool factor, it stopped functioning. Now Alexa says that it is playing what was requested but does nothing. It will play/pause/stop media that I got going using my remote, but not play media that is requested via Alexa. It will also tell me what is on deck, new content added, etc... but will not play it via Alexa. Alexa finds the content, says it will play it, then nothing. I'm hosting Plex in the container on Ubuntu server, client is Nvidia Shield. Any news from the Plex people?


"Allow Fallback to Insecure Connections" from "Never" to "On same network as server"
Did not help


Do Plex developers monitor these forums? Or is it just users helping each other out?


Is there another way to elicit help for this? Forum doesn't seem to be all that useful thus far.


I’m testing the features before I get my Plex Pass to make sure it will do what’s advertised. Of course I would hit on the same issue as everyone else in this thread :frowning: I’m running PMS on Windows 10, Fire TV, Echo Dot. Looking over the Fire TV log, I’m noticing that it’s going after a 10.x.x.x address to connect with my PMS. When I change to fallback on insecure connections for devices on my network, it logs a list of 3 addresses for my PMS (my network IP, the 10.x.x.x and a 24.x.x.x IP), but continues to use the 10.x.x.x address. When I play the Plex movie using the Fire TV controller buttons to select the movie, it runs fine (and the logs show the local network IP being used). Using either the Echo Dot or the voice commands on the Fire TV controller gets the same results as those stated in earlier posts (and uses the 10.x.x.x IP address in the Fire TV log).

Since this is one of the main reasons for me to use Plex, it’s kind of a show stopper in getting the Plex Pass so hoping someone can find a cure!


Forgot to mention that using Echo Dot, I can voice instruct Plex to play movies on my other devices (iPad and iPhone) just fine.


Just setup Alexa Plex integration and it’s working like a charm on a Firefox browser and my iPads.

However, it will not work when I try it on my Fite TV stick. Fire TV stick can play back anything from my server as expected but via Alexa nothing works.

It says “enjoy watching robocop” but it never actually starts playing. The screen jus5 stays as it was.

It also doesn’t recognise the PLEX app on my Samsung smart TVs but I’m assum8ng they need to be of a certain relatively new age.

not sure it makes any difference but I hav3 a lifetime apples Pass


OK so just to clarify some points ( I was doing this test in bed last night much to the wife’s annoyance.

So I can play all of my media from my Plex Server on my Plex Apps on my pre-2016 Samsung Smart TVs, computer browsers on both PC and Mac, on my iPads with the Plex app AND on my Firestick (Gen 1 I think)…playback is fine and Im very happy with this.

Since I discovered yesterday that I can playback Plex using Alexa, I have this particular function and it is working fine on browsers on Mac and PC, and on my iPads/Phones. From the Alexa/Plex info, I assume that it WONT work on any pre-2016 TVs which is fine and understandable but it does say that it will work with Amazon Firesticks…

When I set things up, I can select the Firestick as the playback device and when I select the film (which plays back fine on the stick when used in the conventional method with the remote), Alexa says that it will play the requested file but then nothing happens. I have tried this multiple times all with the same result.

I have tried the same film with the remote which works fine and using Alexa via Browsers and on iOS devices and again Alexa has played this same file fine, it just seems to have issues playing back over a Firestick…

I’ve also now tried this on an Android TV box with Plex installed…This unit is hardwired…again it will playback files from the plex server fine without issue. I can select the android box as the current player but when I ask for a movie or tv episode to be played it says “enjoy watching…” but neve plays. This box is quite new.

really hope this is just a bug that will be ironed out as I’ll happily buy more firesticks to use around the house for this very feature

I hope someone can shed some light on this for me


So you’re trying to start playback on a Fire TV with Alexa but it’s not working? Is the Plex app open when you try this?


Yes, the plex app is open. Alexa displays a message stating “Enjoy the movie” but nothing actually plays.


I am having the same issue. When I enable logging i keep seeing this error message

11-27 20:46:16.693 i: [Remote Control] Waking up device
11-27 20:46:16.695 i: [conn] Updating reachability for ChristianFlix with 1 connections.
11-27 20:46:16.696 i: [conn] Testing connection for ChristianFlix: https://{ip address here}(Active Pool: 0)
11-27 20:46:16.749 i: Fetching [method:GET] https://{ip address here}/?X-Plex-Token=…j3Z3
11-27 20:46:16.896 i: [conn] Device ChristianFlix response time is Infinity ms
11-27 20:46:16.898 i: [conn] Connection FAILURE ChristianFlix ~ Connection: https://{ip address here} token used: true types: [discovered] state: Unreachable
11-27 20:46:16.901 i: [conn] Connectivity test to ChristianFlix completed in 0.2 SECONDS -> FAILED
11-27 20:46:16.903 i: Fetching [method:GET] https://{ip address here}/library/metadata/1016964?X-Plex-Token=…j3Z3
11-27 20:46:16.904 i: [PubSubCompanion] Requested command: success? true
11-27 20:46:17.052 e: An exception occurred: java.lang.ArrayIndexOutOfBoundsException: length=0; index=0
11-27 20:46:17.054 e: Stacktrace: java.lang.ArrayIndexOutOfBoundsException: length=0; index=0
at java.util.Vector.arrayIndexOutOfBoundsException(
at java.util.Vector.elementAt(
at java.util.Vector.get(
at com.plexapp.plex.c.t.a(SourceFile:102)
at com.plexapp.plex.c.t.doInBackground(SourceFile:42)
at android.os.AsyncTask$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$