Plex Media Player reinstall/launch failure



Hey folks,
So we've had the media player installed for ages with no problems. Recent update brought about the ghosting/colour weirdness on movies issue. Did the suggested fix of installing the test version but didn't fix the problem. Lived with it for a while and then saw that someone had posted a new 1.3 version that apparently fixed the problem.

Here's where the issue started. So I installed the 1.3 version as linked in another thread but when I went to run PMP it was still the 2.0 test version. Thought that was odd so uninstalled plex altogether and then installed the 1.3 version. Ran PMP and whoa, still the 2.0 version. Baffled now. Uninstalled Plex again. On a whim I ran the PMP shortcut and it STILL opened the 2.0 version even though i'd apparently uninstalled it. Ok, head to program files, delete the Plex directory. Done, no PMP left.

Install 1.3 version. Installs ok, has the screen with a Launch and Close button. Click Launch and nothing happens. Spam Launch and nothing happens. Click close and it closes. Hmm. Search for Plex, has shortcut to PMP, hit it and it brings up the installer again with repair/uninstall. Do a repair, hit Launch....nothing. Screen sits there. So I check the program folder and there's no plex anywhere. It shows up in the windows apps and in iobit uninstaller but it's not actually installing anything. Uninstall and reinstall the 2.0 version but now that's doing the same thing.

Tried changing the directory to an empty folder and installing, it goes through the process and says it's fine but when I check the folder there's nothing in it. Still empty.

Totally per-plexed. Would love some help!!


Update : copied the plex folder from another PC to the broken one and pmp runs (same version as the PC I copied it from). Movie colours still broken though. And no idea what to do from here as far as future updates etc.


The 1.3 and 2.0 versions are released at the same time (non-Plex Pass and Plex Pass AFAIK), so 2.0 is not necessarily newer than 1.3. We recently noticed that the 1.3 release didn’t actually contain the fix for the colors issue and released a new one. The old TV UI will be phased out.

Not sure what to say about your installation troubles. Sounds like the installer pretends everything is fine, but does not actually install anything?


Yep that’s exactly it. It just doesn’t install any files for PMP, it’s bizarre. At some point i’ll try installing a new version and see if it updates the current one, just scared of breaking it again :frowning: