plex media server on OPENMEDIAVAULT

server-linux

#1

Hi,
I have a OMV server (Debian based) running on my old computer. I´m able without any problem install plexmedia server (via command line or WEBUI). After that I´m able to start it, I can find PLEX in my network on TV or smartphone. But when I try to connect to to server via WEB BROWSER port 32400 from my notebook (let say OMV server is running 192.168.1.5:32400, server and laptop are on the same network), I get the first screen normal, but on the left side is still message “LOOKING FOR THE SERVERS” and no server is found, so I am not able to setup the server nor media nor share folders.
answer please to hudec.michal@gmail.com


#2

For the benefit of all users, support is given here in the forums.

When you first installed PMS, you must always run the first start- setup wizard. For this to work correctly, both your server and laptop must be on the same subnet (e.g. 192.168.1.x) . If they are not, there is another way to do this via a ssh tunnel procedure which is easily done in Linux.

Have you performed this step?


#3

Thanks for the answer, both machines are on the same subnet. How to run first start- setup wizard? OMV server (Debian based) has no desktop environment, I'm able to use only command line of the server or to connect via ssh of my computer. How to perform wizard via command line? Thanks


#4

to do the headless setup:

  1. enable ssh on the headless machine running PMS
  2. from anywhere else ssh -l valid_username_here 8888:localhost:32400 ip.addr.of.machine
  3. log in and get the console prompt.
  4. let this sit idle
  5. Open http://127.0.0.1:8888/web in your local browser.. the tunnel will redirect it to 32400 on the headless
  6. Wave fingers over keyboard and observe magic :)

#5

Hi i have problems with the steps
Using putty i fill in the ssh remote command as listed in step 2 (using my plex user name as valid_user_name_here and my OMV server ip as ip.addr.of.machine
i then connect to my OMV/PMS server with its ip.addr
when i login with my credentials the putty window closes
and step 4 returns unable to connect
What now ?


#6

Hello, I'm also having trouble doing the headless setup posted by ChuckPA.

The headless machine's accepting ssh connections. I tested it with ssh -l root 192.168.1.162, entered the password, and was logged in.

However, ssh -l root 8888.localhost:32400 192.168.1.162 gave me the error "ssh: Could not resolve hostname 8888:localhost:32400: Name or service not known".

Can anyone help? Thanks!


#7

change localhost to 127.0.0.1 Take the name resolution out of the equation until you can add localhost in your /etc/hosts. localhost is standard on all linux distros I've seen.