Plex not playing on Hisense TV

smart-tv

#1

Hi, I'm unable to play any Plex media on My Hisense TV (Plex 3.8.0). Able to login and browse media, just won't play anything (just get a timeout, fail msg).
I believe this has happened since upgrading to Plex server Version 1.5.7.4016

Anyone else having this problem?
So far I've restarted Plex server, restarted entire network, reset TV to factory defaults and tested on a 2nd Hisense TV (not reset), all with the same result, media won't play.


#2

There a few discussions on the same problem already. Just Search the forums with “Hisense”


#3

Join the "Our Hisense TVs can't play Plex any more" crew!

(Only fix I can see is to Optimise all files before playing, which is a ludicrous situation as the very same non-optimised files played just last week.)


#4

Some info from a Plex post on Facebook:

"To be very clear, we don't actually officially support HiSense television sets currently. HiSense made our app available on their sets via the Smart TV Alliance, but hasn't provided us any sets to be able to test anything on, unfortunately."


#5

My recent experiences with the Hisense Plex app and the success with playing mp4 and optimised-to-mp4 files, and inability to play mkv files: https://forums.plex.tv/discussion/comment/1469746#Comment_1469746


#6

It has been confirmed by several forum members if you change your TV app settings for H.264 to"NONE" Mkv files will play. Direct play and Direct stream enabled.


#7

Okay, I have access to mkv files again!
Used these setting from forum member karepa:
Audio: DTS (DCA) and DTS (DCA) ticked / Volume Boost not ticked

Video: Local, Remote, Online Quality : Original, Subtitles Size: Normal, Allow Direct Play and Stream: Ticked, maximum H.264 Level: None.

I've already optimised a few problem files so I can't go back and check if this would have made a difference to them. But for now, fingers crossed that the fix persists!


#8

Confirmed, H.264 to "NONE" worked for me. Didn't need to do any optimise any files (so far). Thanks!


#9

@Dnaml said:
Confirmed, H.264 to "NONE" worked for me. Didn't need to do any optimise any files (so far). Thanks!

I'm glad it works for you but it's perplexing why it is that it needs to be set to "none". Does it mean the setting is pretty useless, it has been found aTitle with H.264 level of 5.0 will not play.


#10

So a noob smart tv question here, how do I change the settings on my tv app? I didn't even download it, it just showed up. I was using it but had issues with it showing incorrect aspect ratio on all things I played. Then stopped working altogether. So would like to try the above fix if I could figure out how to.
Thanks :)


#11

@DLFlix said:
So a noob smart tv question here, how do I change the settings on my tv app? I didn't even download it, it just showed up. I was using it but had issues with it showing incorrect aspect ratio on all things I played. Then stopped working altogether. So would like to try the above fix if I could figure out how to.
Thanks :)

Top of Plex main screen, far right there is a avatar of your plex Server name "DLFlix" I would Guess. You navigate with arrows on remote. Press enter and scroll down to video. There you will see "Level", enter on the value showing and change / select to "None". Whilst there make sure Direct play and Direct Stream are ticked/enabled.

I hope that's Simple/Noob enough to work out. If not message me and I will send some Screen shots.


#12

Hi. Thank you. I changed that and I can play things again now. Thank you. Unfortunately I still have the aspect ratio issue with some things. I've looked but seems to be no fix for this.


#13

@DLFlix said:
Hi. Thank you. I changed that and I can play things again now. Thank you. Unfortunately I still have the aspect ratio issue with some things. I've looked but seems to be no fix for this.

Yah, ive heard this but i believe it has something to do with the file. I have not seen it happen