Plex on Kindle Fire Freetime cannot access SD Card

android-mobile

#1

I have read a bunch of discussions on this that seem to have stopped last Fall. Presumably due to a solution that I cannot find. I have Plex on my son's Kindle Fire and put in an SD Card to sync movies with Plex. When I run Plex on the Fire directly I can set the external storage for sync but when inside Freetime I can only select internal storage which is so insufficient I cannot sync even one movie. I need to use Freetime for my younger son.

I tried moving Plex to external storage hoping that would allow it to sync to the storage it is on but it still only shows internal storage as a sync option.

Is there a solution to use Plex to sync to external storage on a Kindle Fire when running in Freetime?

I am a lifetime Plex Pass subscriber if that matters at all.


#2

From the last time that I investigated this issue there is not a solution to this and it has to do with how Amazon limits access to the SD card any free time setup.

I tired of this issue myself too and instead sideload Cyanogen on to the device and use the other applications to limit what the user could do.


#3

That is what I expected to hear. I was just hoping there was something I didn't find that makes this easy.

I don't want to run an alternate ROM on this device so I will likely root it and use symbolic links. I don't mind downloading the cached media from the non-Freetime account to get by the storage size check. I wonder if there are any issues with rooting the Kindle Fire.