Plex on NowTv one



Hi, I have been using a plex on a Nowtv one for over a year and all has been great but recently it has stopped working? i have the plex classic installed and when i ask it to discover Plex servers it finds my server with no issues.

But when i go back to library section nothing is showing? the same Plex server works fie with the Plex Iphone app and Plex Xbox one app, but will not work with the nowtv app?

Do I need to alter a setting on the Plex server or on the Plex app? or does the app no longer work with the current version of Plex server for windows?

Many Thanks


Try signing in to your Plex account on the NowTV box. Worked for me. It's in the menus of Plex somewhere, forget where now. Sorry.

UPDATE: Also just found out you might not have to log in if you add your NowTVs IP to the Plex IP whitelist (Settings > Server > Network and find the field called "List of IP addresses and networks that are allowed without auth".)


Hi, by adding the I.P addresses to the whitelist my nowtv does now display all the media, however it will not play it, just gives a error message like the server in unavailable? even though the same media works via Plex on Xbox one and Plex app on IOS?

I have restarted the Plex server but still no joy, something is stopping my machine transcoding the files and sending them to the Nowtv box think, as I believe the apps on Xbox and IOS transcode on the device?

I also counldnt find any option to log into plex, only the option to connect plex (pin) but that did the same with the media.

This has worked fine for ages and only stopped with a server update about a month or so ago? maybe I could download a old version oid plex media server?

any help would be great.


Is the server still actually there?


Try the 3.1.9 version


I have another issue were it works fine on one NOW TV box but when i use two or three now tv boxes at the same time all streams stop working, Video unavailable error. Why is this? I can do multiple stream on other device, just not over three NOWTV boxes. I have tried all the different transcoders and i have got it set to universal rather than Legacy, but still getting the same issue. Any ideas?