Plex Opera app will install, but not run on Hisense 50 inch Smart TV (model 50H5C)



The opera app will install and will get so far as linking the TV to the server. However the app then gives an error message, "Unable to connect to server" and gives a reset app option to get a new link code.

The TV and Plex server have the latest upgrade. The Plex app on my Roku connects and works perfectly.


I am experiencing the EXACT same issue with my Sharp (same as Hisense brand in post above) Smart TV that uses Opera app. I get a code, I am inputting the code in my browser and get "Unable to connect to server". My server was just installed last night so I know I have the latest rev, and when I set up my daughter's new Roku TV an hour ago it connected to Plex flawlessly. I tried changing the network settings and moved the TV onto the same wireless network (just as a test) and the results were the same as when it was on ethernet (same router).


I am experiencing the same issue with the Hisense 50H8C model. Firmware updated to latest version. No problem to connect with iPhone 6 so assume issue is on the TV.


I'm having the same issue on my hisense 50h6c... the biggest reason I got a smart TV :((


Ditto on my 55H5C. I did however find that I could use the built in media browser to navigate to my plex content and stream it from there no problem, but this has a long list of disadvantages vs using the plex app.


@mouserat1016 - thanks, that honestly didn't occur to me. While it is certainly not a fix, it is a workaround.


@mouserat1016 - Well, nutz... That didn't work. The sign in page doesn't fully resolve for me. I see the Plex logo and nothing else but gray screen. The sign in page I see in Chrome is complete, but in the Opera browser it's not.


Are these forums moderated at all by the dev team for Plex? They might at least give us some insight because clearly this is a compatibility issue with Opera.


Similar problem. App installs via Opera. Gives the four letter code to link. Server says it is linked. App starts then says "Not available".


@StrattonCE said:
Similar problem. App installs via Opera. Gives the four letter code to link. Server says it is linked. App starts then says "Not available".

That's exactly what's happening on mine.


I had this problem too and after trying a bunch of stuff I managed to get it to work.

Try this and hopefully it works for you too.

  1. Pair your Plex TV App with your Plex Server like normal (4 Digit Code) After it's done pairing this is where the problem starts
  2. Shut down both the Plex Server on your computer and the Plex App on your TV. DO NOT RESET YOUR PLEX APP, SIMPLY GO BACK TO YOUR APP MENU ON YOUR TV.
  3. Now with your Plex Server not running start your Plex APP on your TV. If it worked you will see something about not being able to connect or find your server. This is there you go to your computer and start your Plex server and hopefully your TV picks it up and you can now use the APP.

*This is not a fix for the problem so you have to do steps 2 and 3 every time you want to run plex. Hopefully it gets fixed soon, but for now you can use this workaround if it worked for you. *


Thanks, Jorge, but this workaround isn't working on my 50H8C. I bring the app back up and get the same "Not Available" message as if Plex Media Server was running.


worked for me on my 50H8C. make sure to close/exit the plex media server on your computer and then open the plex app 1st on your hisense tv, then launch plex media server on your computer.


Same issue on my hisense :-( hope they fix it soon.


Same issue here, on a Sharp lc-50n6000u, bu the suggestion portillo above worked, and at least I can go in and see how the app performs on the TV. Problem for me is, I have a lot of .mkv files which will not direct play on the Sharp TV, or any TV I've seen for that matter, does anyone know how to turn on always Transcode on the Opera App? I tried turning off 'Allow Direct Play' and 'Allow Direct Stream' to no avail.


I've got the same issue on an 43H7C2. I've been waiting eagerly for plex to work on this tv and was super excited when I seen the app in the store. Now I'm just waiting on it to work correctly. :)


Same here Hisense 50H6C Opera appstore. Link it to plex and then smart tv "not avalible" then wants me to reset plex. It does link cause I see it under my devices on the server side.


Same issue here - although mine was working perfectly up until a couple of days ago. Exactly the same symptoms as others posting.


I have Hisense 50H6C with the sam issue as everyone else. Once plex opens and connects and I enter my 4 digit pin, I get "not available". Like Nite_fury7, when I access connected devices from my plex server, it shows an opera device connected. I shouldn't have to shut off my plex server and then login from the tv app and then start the server; more importantly any of my family members trying to watch plex from this tv. If anyone has any of possible solutions, please let me know.


I think we'd all like to hear SOMETHING/ANYTHING from the development team on this issue.