# Plex server crashing on Debian

**URL:** <https://forums.plex.tv/t/plex-server-crashing-on-debian/885233>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [August 14, 2024, 3:54am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233 "2024-08-14T03:54:49Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [August 14, 2024, 3:54am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/1 "2024-08-14T03:54:49Z")

</div>

Plex server crashing, seems to coincide with errors in dmesg below. Looks like this is happening during playback.

Server Version#: 1.40.4.8679-424562606  
Player Version#: 1.99.0.210-2d92b948

dmesg:  
| \>\>\> [root@plex ~]$ dmesg  
[4756189.537415] TCP: request\_sock\_TCP: Possible SYN flooding on port 2647. Sending cookies. Check SNMP counters.  
[4804773.780260] PMS GTP[1495643]: segfault at 10 ip 00007f49712947ca sp 00007f495859c918 error 4 in ld-musl-x86\_64.so.1[7f4971284000+53000] likely on CPU 3 (core 3, socket 0)  
[4804773.780290] Code: 14 66 85 d2 74 02 f4 9b 8b 57 f8 81 fa ff ff 00 00 7f 02 f4 9b 83 e1 1f 89 d0 c1 e0 04 48 98 48 29 c7 48 8b 47 f0 48 83 c7 f0 \<48\> 39 78 10 74 02 f4 9b 8b 70 20 83 e6 1f 39 ce 73 02 f4 9b 8b 78  
[4883139.567158] traps: PMS GTP[1517482] general protection fault ip:7fdec9eba7d0 sp:7fdeb2f80918 error:0 in ld-musl-x86\_64.so.1[7fdec9eaa000+53000]  
[4948904.302494] PMS GTP[1537006]: segfault at 10 ip 00007efcb873f7ca sp 00007efca6d5f918 error 4 in ld-musl-x86\_64.so.1[7efcb872f000+53000] likely on CPU 1 (core 1, socket 0)  
[4948904.302502] Code: 14 66 85 d2 74 02 f4 9b 8b 57 f8 81 fa ff ff 00 00 7f 02 f4 9b 83 e1 1f 89 d0 c1 e0 04 48 98 48 29 c7 48 8b 47 f0 48 83 c7 f0 \<48\> 39 78 10 74 02 f4 9b 8b 70 20 83 e6 1f 39 ce 73 02 f4 9b 8b 78  
[4949726.715986] PMS GTP[1537288]: segfault at 10 ip 00007f0413b327ca sp 00007f040a910918 error 4 in ld-musl-x86\_64.so.1[7f0413b22000+53000] likely on CPU 3 (core 3, socket 0)  
[4949726.715994] Code: 14 66 85 d2 74 02 f4 9b 8b 57 f8 81 fa ff ff 00 00 7f 02 f4 9b 83 e1 1f 89 d0 c1 e0 04 48 98 48 29 c7 48 8b 47 f0 48 83 c7 f0 \<48\> 39 78 10 74 02 f4 9b 8b 70 20 83 e6 1f 39 ce 73 02 f4 9b 8b 78  
[5034521.420703] traps: PMS GTP[1561032] general protection fault ip:7fde0212b7dc sp:7fddeefae918 error:0 in ld-musl-x86\_64.so.1[7fde0211b000+53000]  
[5054955.965273] PMS GTP[1566492]: segfault at 10 ip 00007f368ebf57ca sp 00007f3683d91918 error 4 in ld-musl-x86\_64.so.1[7f368ebe5000+53000] likely on CPU 0 (core 0, socket 0)  
[5054955.965315] Code: 14 66 85 d2 74 02 f4 9b 8b 57 f8 81 fa ff ff 00 00 7f 02 f4 9b 83 e1 1f 89 d0 c1 e0 04 48 98 48 29 c7 48 8b 47 f0 48 83 c7 f0 \<48\> 39 78 10 74 02 f4 9b 8b 70 20 83 e6 1f 39 ce 73 02 f4 9b 8b 78  
[5105521.061878] traps: PMS GTP[1584199] general protection fault ip:7f2dc5bb87ca sp:7f2db9435918 error:0 in ld-musl-x86\_64.so.1[7f2dc5ba8000+53000]  
[5157074.793806] systemd-journald[472782]: Oldest entry in /var/log/journal/82bfcabede124a4f93ac72dd1dbd65da/system.journal is older than the configured file retention duration (1month), suggesting rotation.  
[5157074.793809] systemd-journald[472782]: /var/log/journal/82bfcabede124a4f93ac72dd1dbd65da/system.journal: Journal header limits reached or header out-of-date, rotating.  
[5207761.932853] traps: PMS GTP[1614479] general protection fault ip:7f72678147d0 sp:7f7250bca918 error:0 in ld-musl-x86\_64.so.1[7f7267804000+53000]  
[5236705.696870] traps: PMS GTP[1622949] general protection fault ip:7f39f61b87d0 sp:7f39e7d9f918 error:0 in ld-musl-x86\_64.so.1[7f39f61a8000+53000]  
[5237215.996602] traps: PMS GTP[1623040] general protection fault ip:7fa41f7167ca sp:7fa416afd918 error:0 in ld-musl-x86\_64.so.1[7fa41f706000+53000]

| \>\>\> [root@plex ~]$ uname -a  
Linux plex-server 6.1.0-21-amd64 #1 SMP PREEMPT\_DYNAMIC Debian 6.1.90-1 (2024-05-03) x86\_64 GNU/Linux

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [August 14, 2024, 4:15am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/2 "2024-08-14T04:15:21Z")

</div>

Have you considered

> [@Plex Media Server](https://forums.plex.tv/t/plex-media-server/30447/636):
>
> Plex Media Server 1.40.5. 8854 is now available to Plex Pass users in the Beta update channel. NEW: (Log) Reduced the number of log messages generated when starting playback on an NVIDIA device. (PM-1417) (Windows) noautorestart command line parameter added which prevents PMS from restarting after an auto update (PM-1305) FIXES: (Analysis) Preview thumbnail generation would not run on newly added media regardless if the preference was set (PM-1782) (Lyrics) Sidecar lyrics would fail to loa…

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [August 14, 2024, 4:35am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/3 "2024-08-14T04:35:12Z")

</div>

This looks promising thank you!

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 1, 2024, 5:41am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/4 "2024-09-01T05:41:00Z")

</div>

I am still seeing this issue in dmesg occasionally and the plex server will crash,

[6787897.043920] PMS GTP[2097258]: segfault at 7fa400006710 ip 00007fa4641b87ca sp 00007fa443266918 error 4 in ld-musl-x86\_64.so.1[7fa4641a8000+53000] likely on CPU 3 (core 3, socket 0)  
[6787897.043929] Code: 14 66 85 d2 74 02 f4 9b 8b 57 f8 81 fa ff ff 00 00 7f 02 f4 9b 83 e1 1f 89 d0 c1 e0 04 48 98 48 29 c7 48 8b 47 f0 48 83 c7 f0 \<48\> 39 78 10 74 02 f4 9b 8b 70 20 83 e6 1f 39 ce 73 02 f4 9b 8b 78

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 1, 2024, 6:36am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/5 "2024-09-01T06:36:45Z")

</div>

We’re going to need the server DEBUG logs ZIP which coincides with that please.

The problem with these is catching which part of PMS generated the SEGV  
This should be in the [PMS logs.](https://support.plex.tv/articles/200250417-plex-media-server-log-files/)

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 1, 2024, 7:40am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/6 "2024-09-01T07:40:04Z")

</div>

Attached, thank you.

[Plex Media Server Logs\_2024-09-01\_14-39-12.zip](https://forums.plex.tv/uploads/short-url/m6iDrsZ69lMoBMA1xQDm3I9OqEw.zip) (645.4 KB)

---

<div class="post-metadata">

**Author:** ![ChristianKent](https://avatars.discourse-cdn.com/v4/letter/c/f17d59/32.png) [@ChristianKent](https://forums.plex.tv/u/ChristianKent)\
**Post date:** [September 1, 2024, 8:10am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/7 "2024-09-01T08:10:28Z")

</div>

I’ve also been getting this and I’m also on debian. I assume Plex monitors those crash events and sends crash reports to plex. I’m on PMS Version 1.41.0.8911

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 1, 2024, 3:56pm UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/8 "2024-09-01T15:56:14Z")

</div>

@The-Manager

Your logs are showing me some database issues.

```auto
Aug 28, 2024 20:12:22.396 [140343907343160] ERROR - [NSB/SSDP/Grabber] Exception inside transaction (inside=1) (/home/runner/actions-runner/_work/plex-media-server/plex-media-server/MediaProviders/Grabbers/MediaGrabber.cpp:171): sqlite3_statement_backend::loadOne: UNIQUE constraint failed: media_provider_resources.uuid
Aug 28, 2024 20:12:22.401 [140343907343160] ERROR - [NSB/SSDP/Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media_provider_resources set parent_id=:media_provider_resources_parent_id,type=:media_provider_resources_type,status=:media_provider_resources_status,state=:media_provider_resources_state,identifier=:media_provider_resources_identifier,protocol=:media_provider_resources_protocol,uri=:media_provider_resources_uri,uuid=:media_provider_resources_uuid,extra_data=:media_provider_resources_extra_data,last_seen_at=:media_provider_resources_last_seen_at,created_at=:media_provider_resources_created_at,updated_at=:media_provider_resources_updated_at where id=:media_provider_resources_id]: UNIQUE constraint failed: media_provider_resources.uuid
Aug 28, 2024 20:12:22.402 [140343907343160] ERROR - [NSB/SSDP/Grabber] Exception inside transaction (inside=1) (/home/runner/actions-runner/_work/plex-media-server/plex-media-server/MediaProviders/Grabbers/MediaGrabber.cpp:171): sqlite3_statement_backend::loadOne: UNIQUE constraint failed: media_provider_resources.uuid
Aug 28, 2024 20:12:22.402 [140343945337656] WARN - [HttpClient/HCl#b9] HTTP error requesting GET http://localhost:34450/discover.json (7, Couldn't connect to server) (Failed to connect to localhost port 34450 after 0 ms: Couldn't connect to server)
Aug 28, 2024 20:12:22.403 [140343907343160] ERROR - [NSB/SSDP] DVR:Device: Error refreshing existing device device://tv.plex.grabbers.hdhomerun/2021-08-3XGL-8ZGZ30:5, marking as dead.
Aug 28, 2024 20:12:27.408 [140343907343160] ERROR - [NSB/SSDP] DVR:Device: Error refreshing existing device device://tv.plex.grabbers.hdhomerun/2021-08-LZ2T-QCHOEF:5, marking as dead.
Aug 28, 2024 20:12:27.410 [140343907343160] ERROR - [NSB/SSDP/Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media_provider_resources set parent_id=:media_provider_resources_parent_id,type=:media_provider_resources_type,status=:media_provider_resources_status,state=:media_provider_resources_state,identifier=:media_provider_resources_identifier,protocol=:media_provider_resources_protocol,uri=:media_provider_resources_uri,uuid=:media_provider_resources_uuid,extra_data=:media_provider_resources_extra_data,last_seen_at=:media_provider_resources_last_seen_at,created_at=:media_provider_resources_created_at,updated_at=:media_provider_resources_updated_at where id=:media_provider_resources_id]: UNIQUE constraint failed: media_provider_resources.uuid
Aug 28, 2024 20:12:27.410 [140343907343160] ERROR - [NSB/SSDP/Grabber] Exception inside transaction (inside=1) (/home/runner/actions-runner/_work/plex-media-server/plex-media-server/MediaProviders/Grabbers/MediaGrabber.cpp:171): sqlite3_statement_backend::loadOne: UNIQUE constraint failed: media_provider_resources.uuid

```

Notice the constraint errors. These errors mean there is another entry (record) trying to use the same ID number. (constrained ID numbers guaranteeing uniqueness)

Whatever the cause, I have a way of cleaning that up at the DB level

> **[GitHub - ChuckPa/PlexDBRepair: Database repair utility for Plex Media Server...](https://github.com/ChuckPa/PlexDBRepair)**
>
> Database repair utility for Plex Media Server databases

1. Stop Plex
2. Ignore constraint errors
3. Automatic cleanup  
— It will hiss & spit at you while doing this. Ignore the comments (the tool is)
4. Start PMS
5. STAY in the tool if you like
6. When you see it’s working better, now you can exit.  
– Otherwise you can undo that last action.

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 2, 2024, 3:14am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/9 "2024-09-02T03:14:47Z")

</div>

Thanks for the update, so I have just done the following,

cd; wget [https://raw.githubusercontent.com/ChuckPa/PlexDBRepair/master/DBRepair.sh](https://raw.githubusercontent.com/ChuckPa/PlexDBRepair/master/DBRepair.sh)  
chmod +x DBRepair.sh  
./DBRepair.sh

Options: 1, 42, 2, 7.

Output:

Automatic Check,Repair,Index started.

Checking the PMS databases  
Check complete. PMS main database is OK.  
Check complete. PMS blobs database is OK.

Exporting current databases using timestamp: 2024-09-02\_09.54.27  
Exporting Main DB  
Exporting Blobs DB  
Successfully exported the main and blobs databases.  
Start importing into new databases.  
Importing Main DB.  
Importing Blobs DB.  
Successfully imported databases.  
Verifying databases integrity after importing.  
Verification complete. PMS main database is OK.  
Verification complete. PMS blobs database is OK.  
Saving current databases with ‘-BACKUP-2024-09-02\_09.54.27’  
Making repaired databases active  
Repair complete. Please check your library settings and contents for completeness.  
Recommend: Scan Files and Refresh all metadata for each library section.

Backing up of databases  
Backup current databases with ‘-BACKUP-2024-09-02\_09.58.54’ timestamp.  
Reindexing main database  
Reindexing main database successful.  
Reindexing blobs database  
Reindexing blobs database successful.  
Reindex complete.  
Automatic Check, Repair/optimize, & Index successful.

I’ve cleared the logs at Library/Application Support/Plex Media Server/Logs/Plex Media Server.log and will review for further database issues and update on the status.

Everything seems to be okay so far.

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 2, 2024, 3:19am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/10 "2024-09-02T03:19:22Z")

</div>

More constraint issues in the logs just now,

| \>\>\> [root@plex ~]$ grep -a SQLITE3 /var/lib/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Logs/Plex\ Media\ Server.log  
Sep 02, 2024 10:15:46.108 [140669045599032] ERROR - [Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid  
Sep 02, 2024 10:15:46.110 [140669045599032] ERROR - [Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid  
Sep 02, 2024 10:15:51.118 [140669045599032] ERROR - [Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid  
Sep 02, 2024 10:15:57.272 [140669028723512] ERROR - [NSB/SSDP/Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid  
Sep 02, 2024 10:15:57.273 [140669028723512] ERROR - [NSB/SSDP/Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid  
Sep 02, 2024 10:16:02.282 [140669028723512] ERROR - [NSB/SSDP/Grabber] SQLITE3:0x80000001, 2067, abort at 46 in [update media\_provider\_resources set parent\_id=:media\_provider\_resources\_parent\_id,type=:media\_provider\_resources\_type,status=:media\_provider\_resources\_status,state=:media\_provider\_resources\_state,identifier=:media\_provider\_resources\_identifier,protocol=:media\_provider\_resources\_protocol,uri=:media\_provider\_resources\_uri,uuid=:media\_provider\_resources\_uuid,extra\_data=:media\_provider\_resources\_extra\_data,last\_seen\_at=:media\_provider\_resources\_last\_seen\_at,created\_at=:media\_provider\_resources\_created\_at,updated\_at=:media\_provider\_resources\_updated\_at where id=:media\_provider\_resources\_id]: UNIQUE constraint failed: media\_provider\_resources.uuid

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 2, 2024, 5:16am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/11 "2024-09-02T05:16:40Z")

</div>

Soemthing bashed your DB badly.

Look at your backups.

DBRepair will help you roll back to one of your previous ones (if it’s not corrupted at the SQLite level)

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 2, 2024, 6:35am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/12 "2024-09-02T06:35:46Z")

</div>

The oldest db backup is still a problem, any suggestions on how I could fix this manually?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 2, 2024, 6:53am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/13 "2024-09-02T06:53:24Z")

</div>

Let me ask one more time to be certain I understand we’re in sync.

1. You started DBRepair
2. Enabled IGNORE mode (42)
3. Ran “Auto” and ignored the constraint errors
4. Started PMS
5. Checked the logs and still found CONSTRAINT errors ?

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 2, 2024, 6:54am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/14 "2024-09-02T06:54:15Z")

</div>

That’s right, so Options: 1, 42, 2, 7. In that order.

---

<div class="post-metadata">

**Author:** ![The-Manager](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/the-manager/32/209465_2.png) [@The-Manager](https://forums.plex.tv/u/The-Manager)\
**Post date:** [September 2, 2024, 7:06am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/15 "2024-09-02T07:06:39Z")

</div>

I think I have fixed this now, ran delete from media\_provider\_resources and rebuilt the DVR fresh. Hopefully not broken anything else.

| \>\>\> [root@plex Databases]$ sqlite3 com.plexapp.plugins.library.db  
SQLite version 3.40.1 2022-12-28 14:03:47  
sqlite\> SELECT id FROM media\_provider\_resources;  
51  
52  
50

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [September 2, 2024, 7:32am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/16 "2024-09-02T07:32:27Z")

</div>

that looks good.

See if it remains stable.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [December 1, 2024, 7:32am UTC](https://forums.plex.tv/t/plex-server-crashing-on-debian/885233/17 "2024-12-01T07:32:58Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
