Plex Server on PR4100 crashing during music streaming



Twice while controlling a Plex client app with my iPhone to play music through my LG TV, the server completely crashed. It started playing the album OK but then when it got to the second track, the iPhone had disconnected from the Plex LG media player and when I went to check why, the App on the TV screen was full of many words essentially saying the server on the NAS drive could not be reached. Checked all other apps I use on the WD PR4100 NAS to ensure it was not the problem, they were all working and communicating normally as was the overall health of the NAS drive. Thus NAS drive connectivity was eliminated as the source of the problem. Then tried to log in via a Firefox browser (V56.00) on OSX (V10.12.6) to the Plex server on the NAS. The connection could not be established so could not log in to Plex. Therefore as a test I re-booted the NAS drive and could then connect normally to the Plex server via the browser. Then re-tried the exact same music control situation again via the iPhone (was iOS 11.0.1 when this happened) client and the same no server message happened again in exactly the same sequence i.e when it came time to go to the bext track. At that point, rather that re-booting the server, I re-installed Plex with the most recent and current update (Version which I was on when it crashed) and was able to connect via a browser login. Have not tried to run additional music tests since then as had other stuff to do rather than spend my time trying to identify crash causes within Plex's software. Note I am not using anti-virus software as am mostly Apple products. Please advise thoughts on cause of problem and solution as do want to have to re-install the server app every time I play music through a client being managed by my iPhone. Thank you.


Hello and welcome to the forum.

We are not aware of any specific reason for the symptoms you are seeing. We will need to see your server logs to investigate. From Plex Web, go to Settings \ Server \ Help \ Download logs. This will download a zip file onto the computer you are using to access Plex Web. Attach that file to your next post here, or if you want to keep it private, you can message me directly with that file.


Here are the logs, have at it. Thank you


Thank you for the log. I’m reviewing it now.


I’ve looked over your logs. It appears that the last crash occurred on Oct 7 but your PMS logs don’t go that far, so not sure what was going on. I’ve asked someone to dig through the crash reports that automatically come to us to see if your’s is still available to review.

Alternatively, if you can cause PMS to crash again, then get us the PMS logs right away, that would also help.


Ok, yes I saw the crash reports for the events in question. In my first message I described exactly what the conditions were that caused the 2 crashes. It is my belief the crash was caused by using my iPhone Plex App to control playing the audio media on the specific Plex App that was running when the PMS crashed. I have run the App on that same device a number of times since then without the iPhone App being the controlling App. It has worked OK without crashing the PMS. When I get time I will try to replicate the conditions to see if the PMS crash can be repeated. Have noticed while I was doing that recent test, that the client in use (LG TV) was not showing on my iPhone as an available player even though it was the media player in use. The only player that shows on my phone is the phone itself. In the events when it crashed and numerous other times, the TV first showed as an available player on the iPhone. I select what to play on the TV App from the iPhone and then started playing. By the time it gets to start the next track, the Player is no longer showing as available on the Phone and the TV Player does not select the next track. In the earlier times this happened (has been 100% consistent in it’s behavior) the PMS did not crash and the next track could be started from the Plex TV App. On October 7th as in the crash reports, the iPhone controlling process crashed the server both times. (BTW, tested it with an Android App also and it behaved in exactly the same way.) This is what leads me to believe the bug is connected to controlling via iPhone or Android. Hope this helps you duplicate the problem in your lab. The only way(s) I could get the server restarted is what I outlined in the first message. Is there another way? Thanks.


Ok, just heard back. They’ve found the crash report for your situation. I’ll provide more info when I hear more.

To restart PMS, have you tried from the NAS’s Western Digital Admin page. I thought there was an option there to stop and restart PMS.


Thanks for searching and finding the crash report, that restores my faith a bit in Plex having a mechanism to review and try to identify the causes for crashes. You really should re-write your logging process such that server crash logging is in it’s own folder and all relevant files necessary for diagnosing crash problems are saved for a longer period or provide a user functionality to set file trim or delete dates as a maintenance task - just an idea. There is an on/off button in the App section of the PR4100, so if it happens again I shall try that before re-installing - even though re-installing is not a big deal as I am saving the last 5 software updates - just in case I have to go back to an earlier version if there is a buggy update release. Hoping your log files shows you something that will help you figure out the cause of the crash. Thanks again.


Have you found anything out yet from reviewing the crash reports. Another strange situation happened just now, I could not log into Plex on my NAS just now yet my iPhone could access and play content from the server as could the Media Client on my Yamaha receiver. I re-started the server through the PR4100 menu and then could log in. Did immediately download the log files so they are available. Why is this server acting so buggy for me? Thank you


They did find an issue related to casting. This is being looked into.

Please provide the log and the approximate time when you noticed the issue. Have you checked if your PR4100 is running the latest firmware? Just to rule out issues with the device itself.


I got your new log. Can you also provide me the log from your iPhone?


A fix for this crash was released today in Plex Pass Beta Release

See Release note

  • (Companion) A crash could occur when using companion (#7689)