Plex server only allows indirect connection after upgrade

server-linux

#1

I recently upgraded to 1.9.2 from 1.5.7 and now all my attempts to connect to my Ubuntu server from the app.plex.tv domain result in a warning indicating that only indirect connection is available.

I have verified that the port 32400 is open and forwarding properly to the server. I can even work around the issue by using navigating directly to the server using my domain name on port 32400. This isn't ideal as I have lots of users and I don't want to require them to use my domain name to work around this issue.

It appears that at least a couple of other users ran into this issue on ubuntu but their resolution was that it simple "went away". https://www.reddit.com/r/PleX/comments/6z2iop/plex_says_not_available_outside_your_network_but/


#2

I'll need your log files to see what's happening (settings - server - help - download logs). The entire ZIP file please. attach here with your next post.

Also, you have your own domain name? Is PMS aware of this? You might be getting DNS rebinding protection and other security kicking back.. Much has changed since 1.5.7


#3

I downgraded to 1.5.7 but issue persisted so I re-upgraded to 1.9.2 so it appears not to be an issue related to changes between those versions.

I do have my own domain name. I’m wasn’t exactly sure what you meant by “Is PMS aware of this” so I added my domain to the “Custom server access URLs” setting and restart the plexmediaserver service and it didn’t appear to change the behavior.

I didn’t bother to add it to the “Custom certificate domain” setting as I am not using my own certificate but just using the auto generated plex.direct certificate. Otherwise I haven’t done any special configuration regarding my custom domain in PMS.

I’ve attached the requested zip after which I downloaded shortly after reproducing the connection test failure. Let me know if you need me to enable verbose logging or gather any other info from the server.

Thanks.


#4

If the issue persisted after downgrading, it can’t be PMS. Something else changed concurrently.

Did you enable, or did the configuration of, ufw change ? Indirect most often occurs when firewall changes occur. Did you setup a proxy?


#5

Looking at the logs myself it looks like there are always errors indicating that the notifyConnect event is received with an incorrect async identifier. It doesn’t ever appear to return the async identifier that is expected.


#6

That is something Engineering and Operations are working on… It is technically an error but otherwise harmless. It only impacts remote access operations. It has no impact on local connections


#7

Issues with remote access operations is the problem I am having. I am having no problem with PMS locally or while connected directly to the server via 32400. It only allows indirect connection while connecting via app.plex.tv.

Since this is an issue Engineering and Operations are already aware of then I’d simply request that they bump the priority of this issue.

It looks like lots of people have been having this issue. I found 38 plex forum posts mentioning this error specifically dating back as far as last year. I’d hate to think of how many people just live with it and don’t post about it online.


#8

Are you connecting to your server from a WAN or LAN perspective ?

Use of app.plex.tv implies WAN. If the server isn’t directly remotely accessible (remote access port), indirect is the only access method which means the Indirect indication is indeed correct


#9

I am able to connect without an indirect connection over WAN (e.g. from work or out of state) if I access my server via my domain name using port 32400. Accessing my server from app.plex.tv however only allows indirect connection.


#10

Ah… that is the missing piece of information.

Did you import your certificate into PMS? Settings - Server - Network. (PMS will not accept your domain’s cert for a direct HTTPS unless it already trusts it)