# Plex server with error on console

**URL:** <https://forums.plex.tv/t/plex-server-with-error-on-console/912142>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [April 7, 2025, 1:46pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142 "2025-04-07T13:46:06Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 7, 2025, 1:46pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/1 "2025-04-07T13:46:06Z")

</div>

Server Version#: 4.145.1

Hi! I’m having those errors in the console:

[Req#a7cc/Transcode/0f9c2650-6ba5-4ab2-9f75-6ea11c1e7e1e/3c30405e-84dc-44a7-aebc-815f38cb1cab] [eac3\_eae @ 0x1540240fdb80] error reading output: -5 (I/O error)  
[Req#a841/Transcode/0f9c2650-6ba5-4ab2-9f75-6ea11c1e7e1e/3c30405e-84dc-44a7-aebc-815f38cb1cab] Error while decoding stream #0:1: I/O error

Some files are not playing also, specially if they are in HEVC.

Any thoughts? Thanks in advance!

---

<div class="post-metadata">

**Author:** ![JKalchik](https://avatars.discourse-cdn.com/v4/letter/j/8e8cbc/32.png) [@JKalchik](https://forums.plex.tv/u/JKalchik)\
**Post date:** [April 8, 2025, 12:20am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/2 "2025-04-08T00:20:30Z")

</div>

I’d start by checking your hardware logs. Errors displayed on the console like that are not usually application errors, but are indicative of potential hardware problems. And errors where some files but not others are not available may be a pointer of failing storage.

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 8, 2025, 12:41am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/3 "2025-04-08T00:41:23Z")

</div>

Would you please recreate the error with [DEBUG logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) enabled (it is on by default).

After recreating it, Download the [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) (Troubleshooting - Download Logs)

Attach the ZIP file here please.

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 8, 2025, 8:38am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/4 "2025-04-08T08:38:45Z")

</div>

Thanks folks! I attached my console screen and the log file.

I’m using PLEX docker on Unraid.

 ![console](https://global.discourse-cdn.com/plex/original/4X/4/c/c/4cce37641ab4600d47b696840dc94d5d39b913fa.jpeg)

[Plex Media Server Logs\_2025-04-08\_05-24-50.zip](https://forums.plex.tv/uploads/short-url/j86EBkP0FMkoJdnlPL4SDy7QkeY.zip) (3.6 MB)

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [April 9, 2025, 12:48am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/5 "2025-04-09T00:48:37Z")

</div>

take a look at the `/tmp` directory, permissions or something may have gone sideaways there. (just peaked at your logs for that info)

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 9, 2025, 9:27am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/6 "2025-04-09T09:27:43Z")

</div>

Hi!

Those are the permissions fot /tmp:

 ![tmp](https://global.discourse-cdn.com/plex/original/4X/a/d/7/ad762d4bac4a05e9a964b8264e74bb4a0720a855.png)

Here is the content:

 ![ls-la](https://global.discourse-cdn.com/plex/original/4X/c/6/0/c6053e4828709aa5cde7653660e7f112b84e66e1.png)

Should I delete everything there?

Thanks for any comment on this!

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 10, 2025, 10:09am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/7 "2025-04-10T10:09:00Z")

</div>

Hi @ChuckPa ! Any thoughts on the log?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 10, 2025, 6:25pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/8 "2025-04-10T18:25:59Z")

</div>

very sorry. been swamped.

```auto
Apr 07, 2025 20:36:52.000 [22846242962232] ERROR - [Req#44f1d/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] [eac3_eae @ 0x146b4db50b80] EAE timeout! EAE not running, or wrong folder? Could not read '/tmp/pms-f333e80e-d54a-484b-9744-a9aa0beeff5d/EasyAudioEncoder/Convert to WAV (to 8ch or less)/f3a89269-f362-450f-89c9-4ae55c765d8d_72835-0-2235.wav'
Apr 07, 2025 20:36:52.001 [22846214212408] ERROR - [Req#44ff2/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] [eac3_eae @ 0x146b4db50b80] error reading output: -5 (I/O error)
Apr 07, 2025 20:36:52.001 [22846474734392] ERROR - [Req#44ff3/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] Error while decoding stream #0:1: I/O error

```

This error means that the file/directory doesn’t exist.

> Could not read ‘/tmp/pms-f333e80e-d54a-484b-9744-a9aa0beeff5d/EasyAudioEncoder/Convert to WAV (to 8ch or less)/f3a89269-f362-450f-89c9-4ae55c765d8d\_72835-0-2235.wav’

How it’s supposed to work.

1. PMS creates a temp folder
2. PMS sets a Notify event for that folder
3. PMS launches FFMPEG for the video
4. PMS launches EAE for the dolby audio.
5. Error occurs if there is no audio file to load and merge with the video

Most common causes:

1. Notify table is full (too many directories being watched – fills up the max\_users\_watches table in the Linux kernel
2. tmp directory is on a network drive where notify will not work.

Given the most common cause is max\_user\_watches fills.  
( 8192 directories on some, 65535 directories on other Linux kernels )  
the solution is to:

1. Count to total number of directories being used for ALL media
2. See what the kernel currently allows ( `fs.inotify.max_user_watches` )

```auto
root@lizum:/glock/media/testfiles# sysctl -a | grep max_user_watches
fs.epoll.max_user_watches = 14541022
fs.inotify.max_user_watches = 1048576
root@lizum:/glock/media/testfiles#

```

1. If needed, increase it.  
– newer Linux kernels dynamically set the table size based on memory available. (be careful when limiting a container’s memory – it can hurt you here )

2. Round up number of directories in use to next integral multiple of 32768  
(it’s ok to increase another 32768 if you’re frequently adding and have plenty of memory)

- On regular Linux kernel,

– ON HOST, edit file `/etc/sysctl.conf`  
– at bottom of file, add:

```auto
fs.inotify.max_user_watches=<YOUR_NEW_VALUE>

```

For general Linux, here’s how to do it.

> [@Linux Tips](https://forums.plex.tv/t/linux-tips/276247/9):
>
> Increase the number of directories Linux can monitor (inotify) for PMS The default size of the Linux inotify table is 8192 directories (\*1). When PMS is configured to update automatically when media is added, with properly organized media, especially music, this table rapidly fills and exceeds the default allocation requiring you to increase it. The solution to this is straight forward. Increasing the table size is easy. The first step is to determine how many directories to alloca…

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 11, 2025, 11:48am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/9 "2025-04-11T11:48:14Z")

</div>

Thanks @ChuckPa. I have 11.253 folders and I used this command:

```auto
echo fs.inotify.max_user_watches=262144 >> /etc/sysctl.conf

```

I checked the sysctl.conf and the new line was there. I restart the docker but I still having the errors:

 ![image](https://global.discourse-cdn.com/plex/original/4X/0/5/9/0594a168aabbccd6c27af45df756214a06738ce3.jpeg)

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 18, 2025, 10:21am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/10 "2025-04-18T10:21:36Z")

</div>

Hi @ChuckPa ! Any other thoughts on this?

Thanks in advance!

Eduardo

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 18, 2025, 6:53pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/11 "2025-04-18T18:53:00Z")

</div>

@edal86

Did you restart the host to make it active ?

Alternatively, `sudo sysctl -p` will make it active immediately.

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 19, 2025, 11:21am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/12 "2025-04-19T11:21:50Z")

</div>

@ChuckPa

Yes, I did…

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 19, 2025, 4:04pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/13 "2025-04-19T16:04:58Z")

</div>

I will try to recreate this so we can move forward  
Not sure what is causing it but will try some ideas to see if I can recreate it at the OS level. (this is an OS/kernel issue - inotify )

---

<div class="post-metadata">

**Author:** ![edal86](https://avatars.discourse-cdn.com/v4/letter/e/9fc348/32.png) [@edal86](https://forums.plex.tv/u/edal86)\
**Post date:** [April 20, 2025, 9:01am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/14 "2025-04-20T09:01:53Z")

</div>

Thanks for this! I’m looking forward.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [July 19, 2025, 9:02am UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/15 "2025-07-19T09:02:07Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
