# Plex server with error on console

**URL:** <https://forums.plex.tv/t/plex-server-with-error-on-console/912142>\
**Category:** Plex Media Server\
**Tags:** server-linux\
**Created:** [April 7, 2025, 1:46pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142 "2025-04-07T13:46:06Z")\
**Posts on this page:** 1\
**Showing post:** 8

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [April 10, 2025, 6:25pm UTC](https://forums.plex.tv/t/plex-server-with-error-on-console/912142/8 "2025-04-10T18:25:59Z")

</div>

very sorry. been swamped.

```auto
Apr 07, 2025 20:36:52.000 [22846242962232] ERROR - [Req#44f1d/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] [eac3_eae @ 0x146b4db50b80] EAE timeout! EAE not running, or wrong folder? Could not read '/tmp/pms-f333e80e-d54a-484b-9744-a9aa0beeff5d/EasyAudioEncoder/Convert to WAV (to 8ch or less)/f3a89269-f362-450f-89c9-4ae55c765d8d_72835-0-2235.wav'
Apr 07, 2025 20:36:52.001 [22846214212408] ERROR - [Req#44ff2/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] [eac3_eae @ 0x146b4db50b80] error reading output: -5 (I/O error)
Apr 07, 2025 20:36:52.001 [22846474734392] ERROR - [Req#44ff3/Transcode/f3a89269-f362-450f-89c9-4ae55c765d8d/20f205c9-b351-4167-9f2e-cfb0b6d4dc0f] Error while decoding stream #0:1: I/O error

```

This error means that the file/directory doesn’t exist.

> Could not read ‘/tmp/pms-f333e80e-d54a-484b-9744-a9aa0beeff5d/EasyAudioEncoder/Convert to WAV (to 8ch or less)/f3a89269-f362-450f-89c9-4ae55c765d8d\_72835-0-2235.wav’

How it’s supposed to work.

1. PMS creates a temp folder
2. PMS sets a Notify event for that folder
3. PMS launches FFMPEG for the video
4. PMS launches EAE for the dolby audio.
5. Error occurs if there is no audio file to load and merge with the video

Most common causes:

1. Notify table is full (too many directories being watched – fills up the max\_users\_watches table in the Linux kernel
2. tmp directory is on a network drive where notify will not work.

Given the most common cause is max\_user\_watches fills.  
( 8192 directories on some, 65535 directories on other Linux kernels )  
the solution is to:

1. Count to total number of directories being used for ALL media
2. See what the kernel currently allows ( `fs.inotify.max_user_watches` )

```auto
root@lizum:/glock/media/testfiles# sysctl -a | grep max_user_watches
fs.epoll.max_user_watches = 14541022
fs.inotify.max_user_watches = 1048576
root@lizum:/glock/media/testfiles#

```

1. If needed, increase it.  
– newer Linux kernels dynamically set the table size based on memory available. (be careful when limiting a container’s memory – it can hurt you here )

2. Round up number of directories in use to next integral multiple of 32768  
(it’s ok to increase another 32768 if you’re frequently adding and have plenty of memory)

- On regular Linux kernel,

– ON HOST, edit file `/etc/sysctl.conf`  
– at bottom of file, add:

```auto
fs.inotify.max_user_watches=<YOUR_NEW_VALUE>

```

For general Linux, here’s how to do it.

> [@Linux Tips](https://forums.plex.tv/t/linux-tips/276247/9):
>
> Increase the number of directories Linux can monitor (inotify) for PMS The default size of the Linux inotify table is 8192 directories (\*1). When PMS is configured to update automatically when media is added, with properly organized media, especially music, this table rapidly fills and exceeds the default allocation requiring you to increase it. The solution to this is straight forward. Increasing the table size is easy. The first step is to determine how many directories to alloca…

---

_[View the full topic](https://forums.plex.tv/t/plex-server-with-error-on-console/912142)._
