Plex service is not working in Sonos-app

sonos

#1

Hello,

I have a problem with my Plex service running in the Sonos app. When i open the Plex service in the Sonos app, all the albumcovers on my Plex server are not shown. When i try to play a song it says: unable to play song, cannot connect to plex. According to the Plex app in Windows, my server is accessible from the outside. (green check) herefore I forwarded port 32400 in my router. UPNP is sett of. If i turn UPNP on, i doesn't change anything in Sonos. How can i get Plex working on Sonos? I hope someone can help me with this issue.


#2

I'm having the same problem now. Everything was working until a few days ago so no idea what changed. It's making my wife pretty mad though.


#3

I’m very new to posting, but I too have the same issue about Sonos playback with Plex. I absolutely love Plex and have fully adopted the implementation in my home. Does anyone from Plex answer the question about Sonos & Plex? They’ve add some great new features but this topic seems dark, unanswered and not supported. How do I get a response, call them by chance? Anyone know?


#4

I have the same problem. Plex used to work perfectly in Sonos. Now I get 'Unable to contact Plex Media Server. Please check your sever setting at https:// plex.tv and make sure that Remote Access is enabled.

Well it is and all my other devices still connect.

If I look in Plex at Devices the Sonos Device is sort of greyed out it doesn't have any colour.

I have re registered the connection and still it doesn't work.

Something has changed either at Plex or Sonos.


#5

I've been using the Sonos / Plex integration since it came out last July and it worked ~80% of the time. I found out that I had the "double NAT" problem - my router was issuing one IP address and my cable modem was issuing a different IP address when going out to the global network. I contacted my IP service provider and they were able to shut NAT off in the cable modem they provide. Since then, my Sonos / Plex connection works 100% of the time, well almost! Between my NAS, router, Sonos, and Plex, there is an almost weekly software upgrade that needs to be downloaded and installed to keep the Sonos / Plex integration working.


#6

I have the Same problem - took me ages to get sonos to work with plex - months of fiddling reasearching reorganising my library and trial and error. Finally worked with manual settings Then about 2 weeks ago just stopped connecting.
Like the previous comments all settings show green and connected. When I search in Sonoplex all my music appears but when I try to play it Sonos says unable to find file. Software and firmware all up to date sonos /qnap/Plex which took me a good couple of hours as well. Please guys get your act together!
Funnily enough when Im using an old ipad 1as my controller with a third party app called sonopad ( as support for ipad 1 discontinued by sonos- bad ) It works! Note to sonos - sonopad a much better app than the native controller - it works, easier to find tracks and it is supported by its developer......


#7

I’m new to posting, but does anyone from Plex answer these posts? It doesn’t appear like they do from my limited view. Love plex to death, I’ve spent hundreds of hours working with my server for movies, pics, music, tv shows. So, Sonos and Plex connection is iciing on the cake. One place to store and many places to access.


#8

No Mintwood
I dont think anyone from Plex answers or even reads the posts. This problem has been going on for ages and I think to Plex it is small biscuits. Sonos cares even less - the posts about the limited library filing have been around for going on 5 years and they didnt help - 'Sorry thats just the system hardware limits" was the repetitive answer. I used to use a server that sort of worked with Sonos then that was discontinued and they came up with Plex- another "who cares" company. Its frustrating and if I wasnt stuck with my Sonos system I'd toss the lot and go with another hardware wireless system provider like Bose or Yamaha


#9

Thanks for your comments, appreciate that someone viewed and answered. As you can see, I don’t go on this blog every day. Well, I’ve got Plex working very well with Google Chromecast Audio. It doesn’t have the nice user interface but it does work with no issues. At least all my work for putting my music in Plex is not in vain. I’ll see how this evolves and probably like you, I’ll always be looking for the newest and best server and streaming opportunities. Thanks again.


#10

OK, two months later, and…nothing? I got two new Sonos speakers with the idea of using just Plex… I tried disabling my NAT settings in my router, as someone suggested, and…nothing. Please, people who work for Plex, fix the problem with connecting to Sonos so I (we) can listen to my (our) music. Thank you.


#11

Just got a shiny new Sonos speaker but for the life of me I can’t get it to work with Plex :frowning:

I can see everything including album art, but whenever I try and play something it says “the file can not be found”

Works fine in my iPad app & the web app

@“Chris C” can you help ??


#12

So some time have passed including Christmas since the question was asked and there still seem to be no answer on how to change or make the router settings connecting the wifi Sonos use the LAN address rather than the WAN when connecting to Plex, if that is what I understand the route of the problem really is of Sonos not playing the visible Plex library. If a knowledgeable techy member or Plex support could perhaps explain in simple language how to change the router config or whatever settings need changing to make Sonos play the music, I and it seems several other members would be very grateful!

Before Christmas, I had several email chat conversations with Sonos support on this problem but no working solution was found, so even the experts seem baffled by this! So if anybody has got a working fix for this then they are up for a gold star!

I also have an even bigger anomaly with this situation and that is when my internet connection is going through my VPN the Sonos reads the Plex library and PLAYS the music too, also the artwork pictures are displayed, but only when connected through my VPN, so can anybody tell me why this should be? And like others on here, the Plex libraries work fine through the Smart TV sound bar and other playing devices, just the Sonos has the problem with playing the Plex music!


#13

@jjross said:
I’m having the same problem now. Everything was working until a few days ago so no idea what changed. It’s making my wife pretty mad though.

I think they changed the auth to cloud then. They do appear to have reverted that now. However mine is still broken. There is crappy workaround I’ve found. Replace the queue with one mp3. Then all should play exempt flac. Flac breaks the queue.


#14

I have same problem. I am connected to Plex on My Cloud Home. I am on the same network. Some files are mp3’s others are m4a’s. I can see the tracks and albums via Sonos, but without any album cover art. I only see the music note symbol. When I press play - I get this message; " unable to to play “… (name of track)” - unable to connect to Plex". Can anybody please help ? Thanks.


#15

@LarsBruun said:
I have same problem. I am connected to Plex on My Cloud Home. I am on the same network. Some files are mp3’s others are m4a’s. I can see the tracks and albums via Sonos, but without any album cover art. I only see the music note symbol. When I press play - I get this message; " unable to to play “… (name of track)” - unable to connect to Plex". Can anybody please help ? Thanks.

You have NAT reflection enabled?


#16

@jjross said:
You have NAT reflection enabled?

That sounds like the symptoms I would expect if NAT reflection, aka hairpin NAT, aka NAT loopback, were not available or enabled on your router. Your PMS (currently) needs to be accessible to your Sonos via your public IP in order for music playback to work.


#17

I am having the same difficulties with Plex working with my Sonos.

When I use https://{public IP}:{port} from within my LAN I can access my Plex server perfectly. So NAT Loopback is working. However like most of the contributors on this thread, Sonos cannot play music from my Plex library. In addition, the artist and album art are very hit and miss, with some showing but the bulk of them not showing any cover art.

Both the Sonos and Plex apps are up-to-date. Plex runs on a Synolgy NAS and can be accessed from multiple devices both within the LAN and from external IP’s. Sonos can play music from all my other music services.

A recent email I received from Plex suggested these issues had been resolved but this is obviously not the case.

Anyone had success in getting Plex and Sonos to work together seamlessly?


#18

I had exactly the same problem with Sonos and Plex running on a Synology NAS. Set up port forwarding on my router and could access my Plex library from my LAN and also externally. However, from the Sonos app, while I could see my music library, I couldn’t see any artwork or play the songs. The solution for me was to disable UPnP on the router then everything worked.

Only downside is that now my Plex app no longer works. Seems that I need UPnP enabled for the Plex app to work but need it turned off for Sonos to work.

Very frustrating and interested to try any other suggestions!


#19

I was reading discussions on this problem the whole morning as I have the exact same issue with SONOS not being able to connect to the Plex server. I tried rjc356’s suggestion to turn of UPnP on my router and initially I got the exact same result. Turning off UPnP fixed SONOS but Plex Remote Access didn’t work anymore.

Then I setup Port Forwarding to 32400 for External and Internal and in Plex Server I have “Manually specify public port” switched on and set the port to 32400. This seems to have worked initially and got me excited, but when I tried it on another device this is still not working… :frowning:


#20

Same story here. In spite of Sonus working to local SMB shares, it doesn’t work to actually play music from plex. I can browse plex, I can browse the music, pick a song, put it in the queue, but playback never starts, errors out. " unable to connect to plex" - which is stupid, because the Sonos speakers and Plex live on the same subnet!

Perhaps when plex is aware Sonos is the client, it would be able to feed URI/URL’s that Sonos can get it? :frowning:

(As an aside, you can’t browse by folder… :frowning: )