Plex Streams Instantly in Web Browser but is Stuck at 33% on Roku Premiere Plus

roku

#1

Hello,

I have a computer and a roku both connection to the internet via ethernet. My browser plays high quality 22mbps 1080p movies instantly through the plex site while my roku stays stuck at 33% buffering. I have tried forcing direct play, different qualities, but nothing seems to work and the video will not play.

Any suggestions?


#2

I recently had a problem with one of my Friends not being able to play any movie at all on his Roku. It ended up being that I had enabled hardware acceleration in the Transcoder settings, and as soon as I did that his Roku would buffer endlessly. All I did was untick the box in Transcoder settings and it worked perfectly for him. Hope this helps? Are you the server owner?


#3

I rent the server from bytesized-hosting.com, I’ve checked the ethernet port with my laptop and it still plays instantly though so it is something with the app. The plex app on my samsung tv would constantly buffer as well. I will look for the hardware acceleration setting, where did you find this on the server or on the roku app?


#4

It is on the server side. Settings>Server>Transcoder>Use hardware acceleration when available

To see the option you need to click on Show Advanced in the top right corner of the Transcoder settings page.


#5

You should also review the Read First: Posting Media Playback Issues on Roku thread pinned to the top of the Plex App for Roku forum. That thread provides instructions for determining if your media playback issue is a Plex app for Roku issue, as well as the information to include in your posts to ensure others can help you resolve the issue.

Without this information and log files, the users who provide support on this forum will not be able to isolate and recreate the cause of your issue, which is necessary to find a solution. Also see the “General Help and How To” section of the Forum Community Guidelines


#6

I figured out the issue, the roku was trying to direct play rather than transcode, I disabled direct play and it works great now! Thanks for your help.


#7

did you disable direct play in the server or in the roku app?