Plex to AppleTV transcoding all audio regardless of source (MOST of the time!)



No matter what movie i play on my apple TV3 (via airplay from either my iPhone or iPad), the audio gets transcoded. This is even the case when the original file is in 2.0 5.1 AAC format. I could just about cope with this, were it not for the fact that it down mixes all surround sound formats to stereo.

The frustrating thing is this happens MOST but NOT ALL of the time. For example, playing 'The Avengers', which is an H.264-encoded MKV with DTS5.1 audio, just now, and it is playing in surround - but this is the first time it's done this in an hour. Plex status indicates it is transcoding audio from DCA to AC3. However, i stop it, play something else, and now return to the Avengers, and it reverts to stereo. Alex says it is now transcoding from DCA to AAC. Same file, just on two separate occasions merely seconds apart - transcoded differently.

So this is an inconsistent issue. Sometimes it transcodes to AC3 with full 5.1 output, other times (99% of the time) it transcodes to 2.0 AAC. Note that also, 99% of the time when playing a file that even contains a source in AAC 2.0, it transcodes it - the status still says 'transcoding DCA to AAC'. Occasionally though, it direct plays this.

Any thoughts on what is going on here? I've tried changing my Dolby Digital settings on Apple TV from Auto to On to Off and it makes no difference. Is the fault with my iOS device, the apple TV 3, or the Plex server??!


Any thoughts on this from anyone? My guess is that PMS thinks my Apple TV3 can only output AAC2.0, though this clearly isn't the case.

My PMS is installed on A WD MyCloud2100, I'm guessing there is no way to modify configs to force it to output 5.1 when casting via IOS to my Apple TV3?


Note to all - this has been resolved as of version


..still I have the same issue. DTS not possible.. Tried different files now. "Audio Transcoding DCA to ACC"
Latest iOS app. Latest AppleTV OS (3.gen)