# PlexAPI: "We failed to reach a server: No host given"

**URL:** <https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649>\
**Category:** Apps & Creations\
**Created:** [October 15, 2013, 9:55pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649 "2013-10-15T21:55:17Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![jmp909](https://avatars.discourse-cdn.com/v4/letter/j/919ad9/32.png) [@jmp909](https://forums.plex.tv/u/jmp909)\
**Post date:** [October 15, 2013, 9:55pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/1 "2013-10-15T21:55:17Z")

</div>

Hi,

&nbsp;

seems to be an issue in the latest update i think. looking at the log, i can see pms address is coming out blank...actually should there be a value there? &nbsp;

```
22:49:19 WebServer: http request path:
/PMS()/library/sections&PlexConnectUDID=DY5JP5QDDRHN
22:49:19 Localize: aTVLanguage: en
22:49:19 WebServer: pms address:
 
22:49:19 WebServer: cleaned path:
/library/sections
22:49:19 WebServer: PlexConnect options:
```

anyway if i go back to a previous version of plexconnect from a few days ago it works fine though

&nbsp;

here is my config

```
[PlexConnect]  
logpath = .  
enable\_dnsserver = True  
ip\_webserver = 192.168.0.100  
port\_webserver = 80  
prevent\_atv\_update = True  
enable\_plexconnect\_autodetect = False  
ip\_plexconnect = 192.168.0.100  
certfile = C:\Portable\PlexConnect\PlexConnect-master\assets\certificates railers.pem  
ip\_dnsmaster = 194.168.8.100  
loglevel = High  
enable\_plexgdm = False  
ip\_pms = 192.168.0.100  
port\_pms = 32400  
port\_ssl = 443  
port\_dnsserver = 53  
enable\_webserver\_ssl = True
```

thanks

j

---

<div class="post-metadata">

**Author:** ![jmp909](https://avatars.discourse-cdn.com/v4/letter/j/919ad9/32.png) [@jmp909](https://forums.plex.tv/u/jmp909)\
**Post date:** [October 15, 2013, 10:53pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/2 "2013-10-15T22:53:55Z")

</div>

signing out of MyPlex in the settings menu fixed it . don't know why

thanks

j

---

<div class="post-metadata">

**Author:** ![SHOCKWAVE](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/shockwave/32/190787_2.png) [@SHOCKWAVE](https://forums.plex.tv/u/SHOCKWAVE)\
**Post date:** [October 21, 2013, 11:03am UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/3 "2013-10-21T11:03:50Z")

</div>

Confirmed. This bug still exists.&nbsp;(and signing in and out) makes no difference.

I have downgraded until a fix is available

---

<div class="post-metadata">

**Author:** ![baa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/baa/32/2026_2.png) [@baa](https://forums.plex.tv/u/baa)\
**Post date:** [October 21, 2013, 7:11pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/4 "2013-10-21T19:11:47Z")

</div>

jmp909 had it fixed.

shockwave confirmed no fix?

How does that work?

Anyways, just to keep you guys informed: this issue is known, though not really understood.&nbsp;

We are working on new code, not directly to fix it... but to provide a bigger overhaul to the whole server handling stuff. My estimate is, that this "bug" will go away. Or at least hide much better. :-)

---

<div class="post-metadata">

**Author:** ![Dorv](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dorv/32/141276_2.png) [@Dorv](https://forums.plex.tv/u/Dorv)\
**Post date:** [October 22, 2013, 2:18am UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/5 "2013-10-22T02:18:56Z")

</div>

So the moral is to downgrade at this point if you're experiencing the bug?

---

<div class="post-metadata">

**Author:** ![f00b4r](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/f00b4r/32/768_2.png) [@f00b4r](https://forums.plex.tv/u/f00b4r)\
**Post date:** [October 22, 2013, 9:19pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/6 "2013-10-22T21:19:46Z")

</div>

> So the moral is to downgrade at this point if you're experiencing the bug?

  
Try signing out or refreshing the server, if that does not work then you can downgrade until it is fixed.  
Implementing MyPlex with a clean approach and without quirks is quite involved.

---

<div class="post-metadata">

**Author:** ![k0ax](https://avatars.discourse-cdn.com/v4/letter/k/7ba0ec/32.png) [@k0ax](https://forums.plex.tv/u/k0ax)\
**Post date:** [October 28, 2013, 3:24pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/7 "2013-10-28T15:24:51Z")

</div>

Your ATV model :&nbsp;**aTV 3 (5.1 5201)**

The DNS server set on the ATV: **192.168.1.5**

The device and operating system that PlexConnect is installed on: **PC,**  **Windows 7**

The local IP address of the device that PlexConnect is installed on:&nbsp; **192.168.1.5**

The device and operating system that the Plex media server (PMS) is installed on:&nbsp;&nbsp; **PC,**  **Windows 7**

The Plex media server (PMS) version number you are running : **v1.2.17**

The local IP address of the device that the Plex media server (PMS) is installed on:&nbsp; **192.168.1.5**

The PlexConnect version number: **downloaded today (28 October 2013)**

The content of your 'Settings.cfg' file (if you do not have this file you are running an old version, please update)

**Settings.cfg**

[PlexConnect]  
enable\_webserver\_ssl = True  
logpath = .  
enable\_dnsserver = True  
prevent\_atv\_update = True  
port\_dnsserver = 53  
enable\_plexconnect\_autodetect = True  
port\_pms = 32400  
port\_webserver = 80  
ip\_plexconnect = 0.0.0.0  
certfile = ./assets/certificates/trailers.pem  
ip\_dnsmaster = 8.8.8.8  
loglevel = Normal  
ip\_pms = 192.168.178.10  
enable\_plexgdm = True  
port\_ssl = 443  
&nbsp;

  

**ATVSettings.cfg**

[DEFAULT]  
showsynopsis = Hide  
movies\_navbar\_decades = checked  
showplayerclock = True  
tv\_navbar\_unwatched = checked  
movies\_navbar\_directors = checked  
subtitlesize = 100  
transcoderaction = Auto  
tv\_navbar\_genres = checked  
durationformat = Hours/Minutes  
pms\_uuid = \*  
clockposition = Center  
movies\_navbar\_more = checked  
showview = List  
movieview = Grid  
movies\_navbar\_unwatched = checked  
overscanadjust = 0  
movies\_navbar\_actors = checked  
showendtime = True  
tv\_navbar\_more = checked  
audioboost = 100  
transcodequality = 1080p 40.0Mbps  
seasonview = List  
myplex\_auth =  
showunwatched = True  
movies\_navbar\_collections = checked  
listviewmetadata = Show  
myplex\_user =  
timeformat = 24 Hour  
actorview = Movies  
movies\_navbar\_genres = checked  
  
[C0HJQTKVDRHN]  
pms\_uuid = 74835f425e6ae2431xxxxxxxa34e9f59d4c438d6  
durationformat = Hours/Minutes  
transcodequality = 1080p 40.0Mbps  
myplex\_user =  
myplex\_auth =  
&nbsp;

Detail on the media file if it is an issue related to playing a media file:

**None**

PlexConnect log:

```
16:16:06 PlexConnect: started: 16:16:06
16:16:06 PlexConnect: IP_self: 192.168.1.5
16:16:06 DNSServer: started: 16:16:06
16:16:06 DNSServer: ***
16:16:06 DNSServer: DNSServer: Serving DNS on 192.168.1.5 port 53.
16:16:06 DNSServer: ***
16:16:06 WebServer: started: 16:16:06
16:16:06 WebServer: ***
16:16:06 WebServer: WebServer: Serving HTTP on 192.168.1.5 port 80.
16:16:06 WebServer: ***
16:16:06 PlexAPI: ***
16:16:06 PlexAPI: looking up Plex Media Server
16:16:06 PlexAPI: ***
16:16:06 WebServer: started: 16:16:06
16:16:06 WebServer: ***
16:16:06 WebServer: WebServer: Serving HTTPS on 192.168.1.5 port 443.
16:16:06 WebServer: ***
16:16:07 PlexAPI: servers discovered: 1
16:16:07 XMLConverter: PlexGDM - PMS: 192.168.1.5:32400
16:17:10 PlexConnect: Shutting down.
16:17:10 WebServer: Shutting down.
16:17:11 WebServer: Shutting down.
16:17:11 DNSServer: Shutting down.
16:17:11 PlexConnect: shutdown
```

A&nbsp;detailed description of the issue&nbsp;(the clearer you can make this the better):

**Trying to get PlexConnect working on a windows 7 pc, same location that i run PMS.**

**When i go the first time to Trailer app on the Apple-TV there is no PMS Server in the Namefield and i get this Lines in the Log:**

**PlexAPI: No Response from Plex Media Server**

**PlexAPI: We failed to reach a server. Reason: no host given**

&nbsp;

**After refreshing the Field the Server comes up. But when i want to start a film now, i have all the time the issue "trailer is not available..."**

&nbsp;

**I did this installation guide from github -\> [https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Windows](https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Windows) with option 2, profil directly into the atv**

&nbsp;

Whats wrong? How could i downgrad to an older version of plexconnect? I couldn't find older files and no how to.

&nbsp;

Thanks!

---

<div class="post-metadata">

**Author:** ![f00b4r](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/f00b4r/32/768_2.png) [@f00b4r](https://forums.plex.tv/u/f00b4r)\
**Post date:** [October 28, 2013, 8:06pm UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/8 "2013-10-28T20:06:51Z")

</div>

> Your ATV model :&nbsp;**aTV 3 (5.1 5201)**  
> The DNS server set on the ATV: **192.168.1.5**  
> The device and operating system that PlexConnect is installed on: **PC,**  **Windows 7**  
> The local IP address of the device that PlexConnect is installed on:&nbsp; **192.168.1.5**  
> The device and operating system that the Plex media server (PMS) is installed on:&nbsp;&nbsp; **PC,**  **Windows 7**  
> The Plex media server (PMS) version number you are running : **v1.2.17**  
> The local IP address of the device that the Plex media server (PMS) is installed on:&nbsp; **192.168.1.5**  
> The PlexConnect version number: **downloaded today (28 October 2013)**  
> The content of your 'Settings.cfg' file (if you do not have this file you are running an old version, please update)  
> &nbsp;  
> **Settings.cfg**  
> [PlexConnect]  
> enable\_webserver\_ssl = True  
> logpath = .  
> enable\_dnsserver = True  
> prevent\_atv\_update = True  
> port\_dnsserver = 53  
> enable\_plexconnect\_autodetect = True  
> port\_pms = 32400  
> port\_webserver = 80  
> ip\_plexconnect = 0.0.0.0  
> certfile = ./assets/certificates/trailers.pem  
> ip\_dnsmaster = 8.8.8.8  
> loglevel = Normal  
> ip\_pms = 192.168.178.10  
> enable\_plexgdm = True  
> port\_ssl = 443  
> &nbsp;  
>   
> **ATVSettings.cfg**  
> [DEFAULT]  
> showsynopsis = Hide  
> movies\_navbar\_decades = checked  
> showplayerclock = True  
> tv\_navbar\_unwatched = checked  
> movies\_navbar\_directors = checked  
> subtitlesize = 100  
> transcoderaction = Auto  
> tv\_navbar\_genres = checked  
> durationformat = Hours/Minutes  
> pms\_uuid = \*  
> clockposition = Center  
> movies\_navbar\_more = checked  
> showview = List  
> movieview = Grid  
> movies\_navbar\_unwatched = checked  
> overscanadjust = 0  
> movies\_navbar\_actors = checked  
> showendtime = True  
> tv\_navbar\_more = checked  
> audioboost = 100  
> transcodequality = 1080p 40.0Mbps  
> seasonview = List  
> myplex\_auth =  
> showunwatched = True  
> movies\_navbar\_collections = checked  
> listviewmetadata = Show  
> myplex\_user =  
> timeformat = 24 Hour  
> actorview = Movies  
> movies\_navbar\_genres = checked  
> [C0HJQTKVDRHN]  
> pms\_uuid = 74835f425e6ae2431xxxxxxxa34e9f59d4c438d6  
> durationformat = Hours/Minutes  
> transcodequality = 1080p 40.0Mbps  
> myplex\_user =  
> myplex\_auth =  
> &nbsp;  
>   
> &nbsp;  
> Detail on the media file if it is an issue related to playing a media file:  
> **None**  
> &nbsp;  
> PlexConnect log:
> 
> ```
> 16:16:06 PlexConnect: started: 16:16:06
> 16:16:06 PlexConnect: IP_self: 192.168.1.5
> 16:16:06 DNSServer: started: 16:16:06
> 16:16:06 DNSServer: ***
> 16:16:06 DNSServer: DNSServer: Serving DNS on 192.168.1.5 port 53.
> 16:16:06 DNSServer: ***
> 16:16:06 WebServer: started: 16:16:06
> 16:16:06 WebServer: ***
> 16:16:06 WebServer: WebServer: Serving HTTP on 192.168.1.5 port 80.
> 16:16:06 WebServer: ***
> 16:16:06 PlexAPI: ***
> 16:16:06 PlexAPI: looking up Plex Media Server
> 16:16:06 PlexAPI: ***
> 16:16:06 WebServer: started: 16:16:06
> 16:16:06 WebServer: ***
> 16:16:06 WebServer: WebServer: Serving HTTPS on 192.168.1.5 port 443.
> 16:16:06 WebServer: ***
> 16:16:07 PlexAPI: servers discovered: 1
> 16:16:07 XMLConverter: PlexGDM - PMS: 192.168.1.5:32400
> 16:17:10 PlexConnect: Shutting down.
> 16:17:10 WebServer: Shutting down.
> 16:17:11 WebServer: Shutting down.
> 16:17:11 DNSServer: Shutting down.
> 16:17:11 PlexConnect: shutdown
> ```
> A&nbsp;detailed description of the issue&nbsp;(the clearer you can make this the better):  
> **Trying to get PlexConnect working on a windows 7 pc, same location that i run PMS.**  
> **When i go the first time to Trailer app on the Apple-TV there is no PMS Server in the Namefield and i get this Lines in the Log:**  
> &nbsp;  
> **PlexAPI: No Response from Plex Media Server**  
> **PlexAPI: We failed to reach a server. Reason: no host given**  
> &nbsp;  
> **After refreshing the Field the Server comes up. But when i want to start a film now, i have all the time the issue "trailer is not available..."**  
> &nbsp;  
> **I did this installation guide from github -\> [https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Windows](https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Windows) with option 2, profil directly into the atv**  
> &nbsp;  
> Whats wrong? How could i downgrad to an older version of plexconnect? I couldn't find older files and no how to.  
> &nbsp;  
> Thanks!

  
[https://github.com/iBaa/PlexConnect/wiki/Supported-Apple-TV-devices-and-firmwares](https://github.com/iBaa/PlexConnect/wiki/Supported-Apple-TV-devices-and-firmwares)  
Essentially you either need to upgrade your ATV firmware or use the play button to skip the pre play screen (rather than hitting the centre button to select a film).

---

<div class="post-metadata">

**Author:** ![k0ax](https://avatars.discourse-cdn.com/v4/letter/k/7ba0ec/32.png) [@k0ax](https://forums.plex.tv/u/k0ax)\
**Post date:** [October 29, 2013, 7:30am UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/9 "2013-10-29T07:30:21Z")

</div>

> Essentially you either need to upgrade your ATV firmware or use the play button to skip the pre play screen (rather than hitting the centre button to select a film).

Thats the point!

"5.1 with limitation: aTV doesn't support so the PrePlayScreen is broken. Workaround: directly PLAY form movie list."

I didn't understand this, but now i know what it means. It works fine with the Play Button, thanks alot f00b4r! :)

---

<div class="post-metadata">

**Author:** ![SHOCKWAVE](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/shockwave/32/190787_2.png) [@SHOCKWAVE](https://forums.plex.tv/u/SHOCKWAVE)\
**Post date:** [November 3, 2013, 8:38am UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/10 "2013-11-03T08:38:51Z")

</div>

Confirmed fixed for me with the latest release.

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [December 21, 2019, 12:15am UTC](https://forums.plex.tv/t/plexapi-we-failed-to-reach-a-server-no-host-given/44649/11 "2019-12-21T00:15:56Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
