Plexconnect suddendly stopped working

plexconnect

#11

Just using the manual method, and a WebServer.py file you kindly provided a link to in the 11-page icon thread.

I've just had a look at the code and guess something needs adding between lines 137-146 but I can't see anything in there for the old WSJ channel 

EDIT

No, I'll take that back :D

Just checked and your latest file has lots more in there!  Can I just change the wsj line to video-api-secure.wsj.com?

hosticons = {
                        'www.icloud.com': 'iMovieNewAuth',
                        'atv.hbogo.com': 'vega',
                        'atv.qello.com': 'qello',
                        'a248.e.akamai.net': 'hulu',
                        'appletv.vevo.com': 'com.vevo.appletv',
                        'apps.sho.com': 'com.smithsonian.appletv',
                        'appletv.watchdisneyjunior.go.com': 'com.disney.junior.appletv',
                        'appletv.watchdisneychannel.go.com': 'com.disney.channel.appletv',
                        'appletv.watchdisneyxd.go.com': 'com.disney.xd.appletv',
                        'ssl.weather.com': 'com.weather.appletv',
                        'secure.marketwatch.com': 'wsj',
                        'trailers.apple.com': 'movie-trailers',
                        'secure.showtimeanytime.com': 'com.showtime.appletv',
                        'vimeo.com': 'vimeo',
                        'd6mhwe3a8uvr5.cloudfront.net': 'skynews',
                        'video.pbs.org': 'com.pbs.appletv',
                        'neulion-a.akamaihd.net': 'com.mlssoccer.appletv',
                        'itunesconnect.apple.com': 'iTunesConnect',
                        'abcnews.go.com': 'com.abcnews.appletv',
                        'atvapp.willow.tv': 'com.willowtv.appletv',
                        'player.aetndigital.com': 'com.aenetworks.lifetime.appletv',
                        'www.crunchyroll.com': 'crunchyroll',
                        'watchabc.go.com': 'com.abc.appletv.v2',
                        'appletv.redbull.tv': 'com.redbulltv.appletv',
                        'neulion-a.akamaihd.net': 'NHL',
                        'appletv.cnbc.com': 'com.cnbc.appletv',
                        'appletv.now.nfl.com': 'com.nfl.now.appletv',
                        'secure.net.wwe.com': 'com.wwe.appletv.v2',
                        'api-global.netflix.com': 'netflix',
                        'player.aetndigital.com': 'com.aenetworks.appletv',
                        's.yimg.com': 'com.yahoo.screen.appletv',
                        'kids.pbs.org': 'com.pbskids.appletv.v2',
                        'kortv.com': 'com.wkntv.appletv',
                        'appletv.crackle.com': 'com.crackle.appletv.v2',
                        'd1d0j1u9ayd8uc.cloudfront.net': 'com.acc.appletv',
                        's.cdn.turner.com': 'nba',
                        'player.aetndigital.com': 'com.aenetworks.history.appletv',
                        'aptve.foxneodigital.com': 'com.foxnow.appletv',
                        'appletv.flickr.com': 'flickr',
                        'a248.e.akamai.net': 'carterville',
                        'securea.mlb.com': 'flagstaff',
                        'mobapi.bloomberg.com': 'com.bloomberg.appletv',
                        'aptve-fx.foxneodigital.com': 'com.fxnow.appletv',
                        'festival.itunes.apple.com': 'com.festival.appletv',
                        's.aolcdn.com': 'com.aolon.appletv'
                    }

#12

WSJ_Live-V2@720.png

iOS 5-7

'video-api-secure.wsj.com': 'WSJ_Live-V2',

iOS 8+

'video-api-secure.wsj.com': 'com.wsjlive.appletv.v2',

Might not work on iOS 5-7, I don't believe it did prior. Yes you can change it and it should work.


#13

More thanks!


Too late to try this now, but will have a go tomorrow. Need an icon or small people and SWMBO will complain :D


#14

Nope!

Can't get an icon back whichever way I try and do things.

Tried using the new WebServer.py with the updated settings for wsj and just end up with a blank icon.

Updated OpenPlex and tried with that, after editing the Settings.py file with the "-" but just the same blank icon.

I can get plex to run through the wsj channel, so that's good,  but really want to get the icon back.

Any ideas what to check?  Using the Reset Settings option with internet cable disconnected at the appropriate points, and have tried adding profile back both before and after plugging cable back in.

UPDATE:

Well, it's something in the wsj settings as I've just ran through the same manual process and added the Plex icon to iMovie Theater at my first attempt :D

Just changed the Hosttointercept in the Settings.cfg, copied my certificates (I'd saved www.cloud.com version) back to trailers.* and then reset the aTV without internet connectivity.  After applying network settings and reconnecting to internet the Plex icon appeared after a few minutes.  Added profile and copied old DNSServer.py and WebServer.py files and all is good.

Didn't really use the iMovie Theater channel anyway, so will leave things as they are, but would be interested to know why it wasn't loading with the new wsj settings above


#15

Hi guys

I managed to update both Settings files. I also managed to generate the new certificate with the updated host string.

But I struggle to import the profile on my AppleTV. Could you please clarify the URL to use ? secure.marketwatch.com/marketwatch.pem ? video-api-secure.wsj.com/marketwatch.pem ?

For whatever reason I cannot add the profile on the AppleTV, I keep getting the 109 error.

Thanks in advance for your feedback,

Michka


#16

I will upload some for ya, worked for me on OS X:

Trailers.cer

Trailers.key

Trailers.pem

Download the .zip from here if the links don't work for you:

ZIP

Put them in the /assets/certificates folder, restart plexconnect, delete old certs from the aTV, install the new certs onto your aTV, reboot the aTV and then try the wsj app.

*You can upload certs directly from github if desired just make sure the matching certs are in your /assets/certificates folder:

https://github.com/wahlmanj/test/raw/master/certs/WSJ/trailers.cer

#17

Nope!

Can't get an icon back whichever way I try and do things.

Tried using the new WebServer.py with the updated settings for wsj and just end up with a blank icon.

Updated OpenPlex and tried with that, after editing the Settings.py file with the "-" but just the same blank icon.

I can get plex to run through the wsj channel, so that's good,  but really want to get the icon back.

Any ideas what to check?  Using the Reset Settings option with internet cable disconnected at the appropriate points, and have tried adding profile back both before and after plugging cable back in.

UPDATE:

Well, it's something in the wsj settings as I've just ran through the same manual process and added the Plex icon to iMovie Theater at my first attempt :D

Just changed the Hosttointercept in the Settings.cfg, copied my certificates (I'd saved www.cloud.com version) back to trailers.* and then reset the aTV without internet connectivity.  After applying network settings and reconnecting to internet the Plex icon appeared after a few minutes.  Added profile and copied old DNSServer.py and WebServer.py files and all is good.

Didn't really use the iMovie Theater channel anyway, so will leave things as they are, but would be interested to know why it wasn't loading with the new wsj settings above

Anyone found a fix?  I am having the exact same problem trying to change the icon.

JEFF


#18

Hi,

Thanks. I got the certificates.

I put them into the plexconnect folder as stated. But I am still wondering when adding the profile on the aTV, which URL should I type ? 

Sorry I am confused.

Thanks,

Michka


#19

Your Ip/trailers.cer (for example mine is):

192.168.1.101/trailers.cer

or

https://github.com/wahlmanj/test/raw/master/certs/WSJ/trailers.cer

#20

thanks guys. i'm back in business.


#21

I got the functionality back, but what about the icon?


#22

My PlexConnect install broke after this WSJ change.

I've updated the settings, to reflect the new hosttointercept value, as well as patched the DNS to allow dashes. I also created a new certificate and reinstalled.

However, as soon as I access it from my ATV, I get the message that "WSJ is Unavailable".

Here's my config:

[PlexConnect]
enable_plexgdm = True
ip_pms = 0.0.0.0
port_pms = 32400
enable_dnsserver = False
port_dnsserver = 53
ip_dnsmaster = 192.168.1.1
prevent_atv_update = True
enable_plexconnect_autodetect = True
ip_plexconnect = 0.0.0.0
hosttointercept = video-api-secure.wsj.com
port_webserver = 81
enable_webserver_ssl = True
port_ssl = 443
certfile = /usr/local/plexconnect/etc/certificates/wsj.pem
allow_gzip_atv = False
allow_gzip_pmslocal = False
allow_gzip_pmsremote = True
loglevel = High
logpath = /usr/local/plexconnect/var

and here's the log after it fails:

18:56:37 WebServer: pms address:

18:56:37 WebServer: cleaned path:
/api-video/appletv/wsjvideo/javascripts/application.js
18:56:37 WebServer: PlexConnect options:
{'aTVScreenResolution': '720', 'aTVFirmwareVersion': '7.2', 'aTVLanguage': 'en', 'aTVAddress': '192.168.1.21'}
18:56:37 WebServer: additional arguments:

18:56:37 WebServer: serving /js/application.js
18:56:37 Settings: getsetting allow_gzip_atv=True

As you can see, I'm hitting PlexConnect properly, and it's logging that it is serving application.js. However, it doesn't appear to load on the ATV.

Any hint? Troubleshoot tip?


#23

created/installed fresh certs (for new host address)?


#24

created/installed fresh certs (for new host address)?

Yep. Created with these two commands:

openssl req -new -nodes -newkey rsa:2048 -out ~/Desktop/wsj.pem -keyout ~/Desktop/wsj.key -x509 -days 7300 -subj "/C=US/CN=video-api-secure.wsj.com"

openssl x509 -in ~/Desktop/wsj.pem -outform der -out ~/Desktop/wsj.cer && cat ~/Desktop/wsj.key >> ~/Desktop/wsj.pem

Copied the three files to the proper location and added the profile in the AppleTV. Just tried a wget to the certificate, and I get the proper file, so it's serving it fine.


#25

So far no luck.

What did I do?
1 - updated Settings.cfg and it is like that
[PlexConnect]
enable_plexgdm = True
ip_pms = 0.0.0.0
port_pms = 32400
enable_dnsserver = True
port_dnsserver = 53
ip_dnsmaster = 8.8.8.8
prevent_atv_update = True
enable_plexconnect_autodetect = True
ip_plexconnect = 0.0.0.0
#hosttointercept = trailers.apple.com
hosttointercept = video-api-secure.wsj.com
port_webserver = 81
enable_webserver_ssl = True
port_ssl = 444
certfile = /usr/local/plexconnect/etc/certificates/trailers.pem
allow_gzip_atv = False
allow_gzip_pmslocal = False
allow_gzip_pmsremote = True
loglevel = High
logpath = /usr/local/plexconnect/var

2 - Updated Settings.py line 35 and it is now

('hosttointercept' , ('trailers.apple.com', '[a-zA-Z0-9_.-]+')),

3 - Downloaded the 3 files from post of wahlman.j and put it on /usr/local/plexconnect/etc/certificates/
drwxr-xr-x 3 root root 4096 Sep 3 20:19 .
drwxr-xr-x 3 root root 4096 Jul 15 18:54 ..
drwxrwxrwx 2 root root 4096 Sep 3 20:19 @eaDir
-rwx------ 1 root root 890 Sep 3 20:18 trailers.cer
-rwx------ 1 root root 1679 Sep 3 20:18 trailers.key
-rwx------ 1 root root 2940 Sep 3 20:18 trailers.pem

4 - Restarted PlexConnect
5 - Deleted profiles from ATV3
6 - Retrieved the new certificates inside ATV and created a profile that automatically recieved the name video-api-secure.wsj.com

But it does not work

What am I missing?


#26

Does not work for me too.
How should I create cert files it plexconnect running on Cent OS?
Should I create it on Mac or Cent OS?


#27

You can use the mac guide to get certs on linux:

https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Linux

https://github.com/iBaa/PlexConnect/wiki/Install-Guide-Mac-Certificates

Otherwise I have test certs here also:

https://github.com/wahlmanj/test/tree/master/certs


#28

Yes I tried that certs from github.
Also I tried to change /etc/httpd/conf.d/plexconnect.conf
and set ServerAlias video-api-secure.wsj.com

But still having "WSJ Video is unavailable. Try again later"

And nothing print to PlexConnect.log

:-(


#29

I think that certs from GitHub and generate cert commands for Mac are not applicable for Linux.
Because when I put trailers.cer trailers.key trailers.pem from package (cp /etc/pki/plexconnect/trailers.* .)
Everything work well for trailers.
(Trailers/trailers.* from GitHub does not)


#30

My problem has resolved at Nov 7. I've forgot to add paths to cer & key inside Apache configuration file