PMP not following Windows Scaling

plex-media-player

#1

I installed the new version today on my Surface, and immediately ran into this issue. By default Windows is set to scale everything to 150%, due to the high DPI, but PMP ignores this, and launches at the native resolution. It makes the UI very small, and unfriendly (especially the libraries along the side become very hard to select with precision).

Could we get this to follow the system setting by default? Or at least a setting somewhere to get it to respect it?

Windows 10 Pro, Current PMP.


#2

I should add that I am referring to when the App is NOT full screen, but Windowed.


#3

Same issue here though on a Dell XPS 15 9550. Also when viewing the “wrapped” Web App in Plex Media player the UI remains comically tiny no matter the window size. Marking the app’s Properties, Compatibility, “Disable display scaling on high DPI settings” has no effect either.


#4

same problem here. Any fixes?


#5

Seems numerous people have ran into the same issue I am facing. Like the rest of the people have stated, if by any chance you have scaling set above 100% in windows, it makes PMP useless… can’t even use it as a paper weight. It would be nice to hear from the Plex team on if this will be addressed anytime soon.


#6

We disabled it for now because of DPI scaling bugs in one of the libraries we use. We’ll enable it again once that is solved. When I tested this myself it didn’t seem too bad (and I tested on high DPI screens).

You can enable it manually by passing --scale-factor= (empty argument) to it.


#7

Experiencing this issue. How do you implement the above suggestion? Is this in the config file in App Data on Windows?


#8

In your Windows shortcut, add the flag that @vlang mentioned such as:

"C:\Program Files\Plex\Plex Media Player\PlexMediaPlayer.exe" --scale-factor=

Worked great - Thanks @vlang !


#9

I have a 13" screen with 2560x1440 resolution on it. Setting my shortcut’s “target” to “C:\Program Files\Plex\Plex Media Player\PlexMediaPlayer.exe” --scale-factor=1.5 --desktop

Worked perfectly for me! It was so tiny before but 1.5 scale is great. Devs: might you consider making this easier to figure out? It’s great you have the parameters coded into the .exe but novices probably wouldn’t know to search for “dpi scaling parameters” and other such related keywords.


#10

Wanted to check if this was fixed already, i guess not :disappointed:
Windows dont seem to be priority for the dev team. Without proper scaling the windows player is really bad, text is soooo small.
Any ETA on the fix ?


#11

We disabled HIDPI support temporarily because it caused other problems, but want to switch back as soon as they are fixed. It actually depends on the Qt update, which broke something else on Embedded.


#12

HiDPI still not in the main release, but now that I’ve found this thread I can use PMP again on my 4k laptop (no idea why I bought a 4k laptop in the first place - seemed like a good idea at the time!)
Thanks for the solution, and hopefully this gets back into the main release soon.