# PMS CreditsDetectionManager - daily - performing same task on same media

**URL:** <https://forums.plex.tv/t/pms-creditsdetectionmanager-daily-performing-same-task-on-same-media/898779>\
**Category:** Plex Media Server\
**Tags:** server-linux, server-docker\
**Created:** [December 13, 2024, 3:43pm UTC](https://forums.plex.tv/t/pms-creditsdetectionmanager-daily-performing-same-task-on-same-media/898779 "2024-12-13T15:43:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lexuu](https://avatars.discourse-cdn.com/v4/letter/l/45deac/32.png) [@lexuu](https://forums.plex.tv/u/lexuu)\
**Post date:** [December 13, 2024, 3:43pm UTC](https://forums.plex.tv/t/pms-creditsdetectionmanager-daily-performing-same-task-on-same-media/898779/1 "2024-12-13T15:43:48Z")

</div>

Server Version#: 1.41.3.9292  
Player Version#:  
\<If providing [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) please do NOT turn on verbose logging, only [debug logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) should be enabled\>

For the last few days I have noticed high CPU usage on the machine that PMS runs on (i5-1340P mini pc with Ubuntu 22.04.05 LTS, PMS is running as a Docker container and I’m using the Plex Inc Docker image).

It seems that when doing the daily tasks PMS CreditsDetectionsManager keeps scanning the same media over and over again and throws errors such:

> Level  
> Error
> 
> Thread  
> 140291373804344  
> Message  
> [CreditsDetectionManager] Credits detection for item 32651 has failed too many times, we will not retry again.

Where item 32651 is the item #, in this case some One Piece episode and judging by the logs, today it has a problem with multiple One Piece episodes but who knows, maybe tomorrow it’ll have a problem with other TV shows.

And:

> Level  
> Error  
> Thread  
> 140291373804344  
> Message  
> [CreditsDetectionManager] BufferingLineReader: failed to read line (error: -1)

My media is on my custom-built NAS and Plex has R/W access to the mounted share where the media resides.  
All PMS files (database and so on) are stored locally on the mini pc that PMS runs on.  
Transcoding is set to /dev/shm and PMS also has access to the folder inside /dev/shm/plex

I kept searching the internet and trying what worked for others regarding this issue but it seems that nothing really worked for me.

This issue only occurs when PMS does it’s daily scheduled tasks, when adding media and after a library rescan, PMS detects the new media, generates thumbnails, detects voice activity, creates intro and credits markers.

[Plex Scheduled Tasks (Upgrade media analysis)](https://support.plex.tv/articles/201553286-scheduled-tasks/#:~:text=Upgrade%20media%20analysis%20during%20maintenance)

Per the above link it isn’t clear if PMS should daily search for intro/credits of media that has been present on the server for a few couple of months.

I’m not sure where to go from here except turning off Credits detection, which I hope it won’t come to.

If anyone has had a similar problem and found a fix, something or can share a link to something to try, that’d be greatly appreciated.

Thank you!

[Plex Media Server Logs\_2024-12-13\_15-36-51.zip](https://forums.plex.tv/uploads/short-url/y8gBWpEFY1Ie9j10qkSsOMTPBul.zip) (4.3 MB)

---

<div class="post-metadata">

**Author:** ![system](https://global.discourse-cdn.com/plex/original/3X/2/a/2acb9765406f63293d357b4ec509ec39aa28f2ad.png) [@system](https://forums.plex.tv/u/system)\
**Post date:** [March 13, 2025, 3:43pm UTC](https://forums.plex.tv/t/pms-creditsdetectionmanager-daily-performing-same-task-on-same-media/898779/2 "2025-03-13T15:43:51Z")

</div>

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.
