# PMS Failing to start - Database corruption: sqlite3\_statement\_backend::loadOne: database or disk is

**URL:** <https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113>\
**Category:** Plex Media Server\
**Tags:** server-asustor\
**Created:** [August 24, 2024, 1:12pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113 "2024-08-24T13:12:52Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 24, 2024, 1:12pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/1 "2024-08-24T13:12:52Z")

</div>

Server Version#: 1.40.5.8854-f36c552fd  
Player Version#: N/A  
\<If providing [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) please do NOT turn on verbose logging, only [debug logging](https://support.plex.tv/articles/201643703-reporting-issues-with-plex-media-server/#toc-1) should be enabled\>

Plex Media Server has been running fine for about a year, pushed an update through the App Manager yesterday and now it won’t work

When I start the app it will run an xml page with this status for a few minutes which will then just fail

`<Response code="503" title="Maintenance" status="Plex Media Server is currently running database migrations.">`

I have tried ChuckPA’s DBrepair tool and that is reporting no issues

```auto
Automatic Check,Repair,Index started.

Checking the PMS databases
Check complete. PMS main database is OK.
Check complete. PMS blobs database is OK.

Exporting current databases using timestamp: 2024-08-24_11.40.23
Exporting Main DB
Exporting Blobs DB
Successfully exported the main and blobs databases.
Start importing into new databases.
Importing Main DB.
Importing Blobs DB.
Successfully imported databases.
Verifying databases integrity after importing.
Verification complete. PMS main database is OK.
Verification complete. PMS blobs database is OK.
Saving current databases with '-BACKUP-2024-08-24_11.40.23'
Making repaired databases active
Repair complete. Please check your library settings and contents for completeness.
Recommend: Scan Files and Refresh all metadata for each library section.

Backing up of databases
Backup current databases with '-BACKUP-2024-08-24_11.46.01' timestamp.
Reindexing main database
Reindexing main database successful.
Reindexing blobs database
Reindexing blobs database successful.
Reindex complete.
Automatic Check, Repair/optimize, & Index successful.

```

I have tried backup databases from when it was working fine and still the same issue ( I have done this manually and using Chuck’s tool

```auto
Are you sure you want to restore a previous database backup (Y/N) ? Y
Checking for a usable backup.
Database backups available are: 2024-08-21 2024-08-18 2024-08-15 2024-08-09
Checking database 2024-08-21
Found valid database backup date: 2024-08-21
Use backup '2024-08-21' ? (Y/N) ? N
Checking database 2024-08-18
Found valid database backup date: 2024-08-18
Use backup '2024-08-18' ? (Y/N) ? Y
Saving current databases with timestamp: '-BACKUP-2024-08-24_11.48.33'
Copying backup database 2024-08-18 to use as new database.
Copy complete. Performing final check
Database recovery and verification complete.

```

df -h is showing more than enough space

```auto
Filesystem Size Used Avail Use% Mounted on
rootfs 287M 60M 227M 21% /
tmpfs 310M 1.9M 309M 1% /tmp
/dev/md0 2.0G 345M 1.5G 19% /volume0
/dev/loop0 951K 16K 915K 2% /share
/dev/md1 17T 12T 4.9T 70% /volume1
cgroup 310M 0 310M 0% /sys/fs/cgroup
overlay 17T 12T 4.9T 70% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/09ab5f65f9ece352b0e3204fe3a222fd8009017d8ceaa95b2c9bd5a937e59c99/merged
overlay 17T 12T 4.9T 70% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/833fc67b5b45a2f5e55ddcf0dbf2728c8678ba6187fea5df4fa56c231a724e1f/merged
overlay 17T 12T 4.9T 70% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/1187b3fd21d689bd7e7a35d25eb142117922106b40c0184eacadaa0231c880e5/merged

```

I have tried deleting the db files (I backed them up) and letting it start again but no luck.

I have reinstalled through the app manager, I can’t see anyway to install an older version manually but I don’t know if that would help

The only thing that has changed is I pushed the update

Does anyone have anything else I can check or try to get this working again?

[Plex Media Server (8).log](https://forums.plex.tv/uploads/short-url/w6hQp5nKYoWZbK9ZIydap6tZd66.log) (55.7 KB)

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [August 24, 2024, 5:11pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/2 "2024-08-24T17:11:13Z")

</div>

`sqlite3_statement_backend::loadOne: database or disk is full` means that the disk plex is using is full, free up some space or make the drive larger.

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 24, 2024, 5:34pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/3 "2024-08-24T17:34:23Z")

</div>

I have 1 volume which has just under 5TB free I can’t see where or why it would report that

Based on the logs the App central entries in my df -h are Plex which have the 5TB available

 ![Screenshot_2024-08-24-18-47-38-59_33c485448b01a70faac917a22ce09db9](https://global.discourse-cdn.com/plex/original/4X/6/7/6/676099bcd8b389ba2fc26e51a3fdd4ee4922fb00.jpeg)

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [August 24, 2024, 5:51pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/4 "2024-08-24T17:51:59Z")

</div>

Can you post a complete copy of your [server logs?](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) They may show something that your excerpt didnt.

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 24, 2024, 5:53pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/5 "2024-08-24T17:53:40Z")

</div>

I included the full [server log](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) in the post are there other logs I can grab?

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [August 24, 2024, 5:56pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/6 "2024-08-24T17:56:08Z")

</div>

You included 1 log file out of anywhere from 20-100 log files that the server generates. If you see the yellow [server logs](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) link it explains what they are and where you can find them and how to upload a zip of those logs.

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 24, 2024, 7:06pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/7 "2024-08-24T19:06:20Z")

</div>

Here’s the full log folder compressed. Appreciate the help I couldn’t find anything abnormal other than what I’ve posted when checking

[Logs.zip](https://forums.plex.tv/uploads/short-url/qZsuLdLAj2BrQUaYmrEmDMBfh8f.zip) (309.3 KB)

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [August 25, 2024, 12:36am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/8 "2024-08-25T00:36:01Z")

</div>

Ok looks like we are working on a NAS can you check the free space on `/volume1/Plex/Library` (I am going to make the assumption that the error you are getting is a red herring if there is space there) If there is space available can you check your database and attempt a repair using [GitHub - ChuckPa/PlexDBRepair: Database repair utility for Plex Media Server databases](https://github.com/ChuckPa/PlexDBRepair)

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 25, 2024, 3:30am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/9 "2024-08-25T03:30:57Z")

</div>

Tried that already and it reported no issues.

```auto
Automatic Check,Repair,Index started.

Checking the PMS databases
Check complete. PMS main database is OK.
Check complete. PMS blobs database is OK.

Exporting current databases using timestamp: 2024-08-24_11.40.23
Exporting Main DB
Exporting Blobs DB
Successfully exported the main and blobs databases.
Start importing into new databases.
Importing Main DB.
Importing Blobs DB.
Successfully imported databases.
Verifying databases integrity after importing.
Verification complete. PMS main database is OK.
Verification complete. PMS blobs database is OK.
Saving current databases with '-BACKUP-2024-08-24_11.40.23'
Making repaired databases active
Repair complete. Please check your library settings and contents for completeness.
Recommend: Scan Files and Refresh all metadata for each library section.

Backing up of databases
Backup current databases with '-BACKUP-2024-08-24_11.46.01' timestamp.
Reindexing main database
Reindexing main database successful.
Reindexing blobs database
Reindexing blobs database successful.
Reindex complete.
Automatic Check, Repair/optimize, & Index successful.

```

I tried one of the backup DBs using the tool and manually just renaming them but nada.

It has 5 TB available and it has no quotas on space/files

```auto
df -h Library/
Filesystem Size Used Avail Use% Mounted on
/dev/md1 17T 12T 4.9T 70% /volume1

repquota: Mountpoint (or device) /share/Plex not found or has no quota enabled.

```

---

<div class="post-metadata">

**Author:** ![dbirch](https://avatars.discourse-cdn.com/v4/letter/d/f19dbf/32.png) [@dbirch](https://forums.plex.tv/u/dbirch)\
**Post date:** [August 25, 2024, 3:32am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/10 "2024-08-25T03:32:28Z")

</div>

@ChuckPa Thoughts?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [August 25, 2024, 3:57am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/11 "2024-08-25T03:57:35Z")

</div>

> [@chrisbarber252](#):
>
> ```auto
> repquota: Mountpoint (or device) /share/Plex not found or has no quota enabled.
> 
> ```

What is this please ?

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [August 25, 2024, 4:00am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/12 "2024-08-25T04:00:09Z")

</div>

MOST IMPORTANT ==

> Aug 24, 2024 14:49:15.332 [548097122336] ERROR - Error: Unable to set up server: sqlite3\_statement\_backend::loadOne: database or disk is full (N4soci10soci\_errorE

Disk is full.

The database is NOT malformed else it would say so.

Is this on Volume1 ?

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 25, 2024, 4:19am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/13 "2024-08-25T04:19:06Z")

</div>

Yes it’s on volume 1  
Df -h in last response on library (I was in the Plex path already) shows its in /dev/md1 which is on volume on

That was the response to repquota, I didn’t set any up but was double checking none were set by something

I didn’t include the command just the output

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [August 25, 2024, 5:36am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/14 "2024-08-25T05:36:50Z")

</div>

Did quotas accidentally get applied to the Plex / PlexMediaServer shared folder ?

They should be unlimited.

If quota applied, it would show as Full.

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 25, 2024, 10:04am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/15 "2024-08-25T10:04:44Z")

</div>

There are no quotas applied it was just another thing I was checking as nothing else is making sense.

Just to confirm:  
The volume has just under 5TB free, there are no and were not quotas applied to that or any folder.  
I have tried the tool and everything reported as fine  
I’ve tried backups and had the same error  
I’ve deleted the DB’s to let them start from scratch and same issue.

Plex was working fine on the 22nd, I pushed the update offered for Plex by the App manager on the 23rd and it has since been doing this

---

<div class="post-metadata">

**Author:** ![anon5074910](https://avatars.discourse-cdn.com/v4/letter/a/db5fbb/32.png) [@anon5074910](https://forums.plex.tv/u/anon5074910)\
**Post date:** [August 25, 2024, 12:27pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/16 "2024-08-25T12:27:24Z")

</div>

How are your inodes `df -i` ?

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 25, 2024, 1:01pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/17 "2024-08-25T13:01:40Z")

</div>

Free

```auto
df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
rootfs 73238 2780 70458 4% /
tmpfs 79359 7 79352 1% /tmp
/dev/md0 131072 6751 124321 6% /volume0
/dev/loop0 544 17 527 4% /share
/dev/md1 1098358784 408545 1097950239 1% /volume1
cgroup 79359 11 79348 1% /sys/fs/cgroup
overlay 1098358784 408545 1097950239 1% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/1187b3fd21d689bd7e7a35d25eb142117922106b40c0184eacadaa0231c880e5/merged
overlay 1098358784 408545 1097950239 1% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/09ab5f65f9ece352b0e3204fe3a222fd8009017d8ceaa95b2c9bd5a937e59c99/merged
overlay 1098358784 408545 1097950239 1% /volume1/.@plugins/AppCentral/docker-ce/docker_lib/overlay2/833fc67b5b45a2f5e55ddcf0dbf2728c8678ba6187fea5df4fa56c231a724e1f/merged

```

I started plex again and no increase in the inode usage whilst it’s trying to startup, still the same behaviour

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [August 26, 2024, 9:39pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/18 "2024-08-26T21:39:07Z")

</div>

Do you have anything else we can check? I can’t see any reason for it to report as full

---

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [August 27, 2024, 1:27am UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/19 "2024-08-27T01:27:13Z")

</div>

@chrisbarber252

I’ve asked my team member (who’s more familiar with ASUSTOR than I) to take a look.

My thought is: Move PMS to another drive and see if it works. That’s how I would test Synology but don’t know if you can do that with moving App data around on ASUSTOR

---

<div class="post-metadata">

**Author:** ![chrisbarber252](https://avatars.discourse-cdn.com/v4/letter/c/85e7bf/32.png) [@chrisbarber252](https://forums.plex.tv/u/chrisbarber252)\
**Post date:** [September 1, 2024, 3:03pm UTC](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113/20 "2024-09-01T15:03:51Z")

</div>

Unfortunately as it’s a 2 drive nas in Raid 1 I have no where to move it to.

I’ve completely wiped out all of the plex install files including dbs etc (not ideal) and setting it up fresh. no issues so far it’s currently performing the scan but will come back if the issue comes up again

[Next page](https://forums.plex.tv/t/pms-failing-to-start-database-corruption-sqlite3-statement-backend-database-or-disk-is/886113.md?page=2)
