PMS on dedicated Server Portforwarding

server-linux

#1

Hello i have running PMS on a dedicated server.
There is only one network interface on the server (enp0s20f0).
When i enable remote access with manually specify port (for example 22345) the public IP and private IP are the same on the webui.
I open the specify port in ufw, but the green status (Fully accessible outside your network) is only shown a few seconds and then comes "Not available outside your network".
Has anybody an idea to solve the problem?


#2

If it’s on a VPN, I thought there was an issue where you can’t stray from the stock 32400. Otherwise, no idea.


#3

@ink0gnito303 said:
Hello i have running PMS on a dedicated server.
There is only one network interface on the server (enp0s20f0).
When i enable remote access with manually specify port (for example 22345) the public IP and private IP are the same on the webui.
I open the specify port in ufw, but the green status (Fully accessible outside your network) is only shown a few seconds and then comes “Not available outside your network”.
Has anybody an idea to solve the problem?

Is this server directly connected to the internet?
What IP Addresses does ifconfig show

Any logs (after restart)
See
https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files


#4

ifconfig shows me the interface enp0sf20 with the public ip address and interface lo 127.0.0.1.
thats all


#5

I presume opening 32400 and have that manually specified as the public port would work ok?

I am not sure if you can port forward a wan port to a different port for the same IP - ie WAN IP and LAN IP the same


#6

when i don’t change the plex port in webui and open the port 32400 in firewall (iptables) everything is okay.
The problem is only when i try to change the plex port in webui.
Thank you for your answer sa2000


#7

@ink0gnito303 said:
when i don’t change the plex port in webui and open the port 32400 in firewall (iptables) everything is okay.
The problem is only when i try to change the plex port in webui.
Thank you for your answer sa2000

Plex media server must use 32400 for the local port. Your local IP is the public IP and we need to have port 32400 for the local IP


#8

Any reason why there is no local subnet / router ?


#9

I don’t know.
Thats my network/interfaces

source /etc/network/interfaces.d/*

The loopback network interface

auto lo
iface lo inet loopback

The primary network interface

allow-hotplug enp0s20f0
iface enp0s20f0 inet dhcp


#10

Is it your own machine / your setup - or is this hosted system on the web?


#11

it is a dedicated server (dedibox xc2016) from online.net


#12

Stick with 32400
Have a good password on your Plex.tv account for your server

Note that servers connected to the Internet directly must have all access authenticated and if you ever sign the server out, you need to go through ssh tunnel to reclaim it

This is Outlined on the support.plex.tv site in installation page