PMS settings

server-freebsd

#1

Hello everyone, sorry if you are posting in the wrong place, but I looked for my problem and I did not find anything like it, I use pms freenas after the last pms update, there was an error where I had to delete the plugin and reinstall again after the new installation when accessing the web interface, does not appear the pms settings, is there any other way to access the pms settings or activate them?


#2

The first area to look into is your local network IP subnet range. It is not within the Private Network Range and as such will be treated differently and would need ssh tunnel to get to it until it is configured. After that it would be accessible but only authenticated access permitted (using plex.tv account for both server and clients)

See https://support.plex.tv/hc/en-us/articles/200288586-Installation
Section headed Opening the Plex Web App on a Device Other than the Server Itself / On a different network


#3

sa2000, i checked the ips, it is in agreement on the same network, I changed the ip as well and I restarted the service, but the server still does not appear, I can access via ssh in ip 100.200.100.113, via web I also try to access but I do not find the PMS , according to the print, within the settings does not appear the SERVER


#4

@Samorvell said:
sa2000, i checked the ips, it is in agreement on the same network,

Being on the same network does not help.
If the IP subnet range is outside the definition of what a Private Network subnet is - see https://en.wikipedia.org/wiki/Private_network then there would be very strict security in allowing access to the server and your only way is going through ssh tunnel as outlined on the support page i linked earlier. Once you are through the ssh tunnel, you should be able to sign in to the plex.tv account and claim the server fro that account. After this the server should be accessible through the plex.tv account and should be visible

You need an ssh tunnel as described on the support page


#5

Hi, I’ve checked the network and pms network mask as in print, I’m sure I’m on the same network, but I still can not access the server settings, what else can I check?


#6

Sorry I said the subnet range has to be within the definition of what a private network subnet is. 100.x.x.x is not

If a server is on a ip subnet that is defined to be a public ip range then one needs to go through a secure ssh tunnel to it and than use localhost to get to it

See section on support page I linked earlier


#7

sa200, Thank you very much, you were right, really my network did not agree, now I just have to configure the directories of the files, again thank you very much for the help!