# Problems transcoding files with EAC3 sound

**URL:** <https://forums.plex.tv/t/problems-transcoding-files-with-eac3-sound/864826>\
**Category:** Plex Media Server\
**Tags:** server-synology\
**Created:** [January 2, 2024, 11:45am UTC](https://forums.plex.tv/t/problems-transcoding-files-with-eac3-sound/864826 "2024-01-02T11:45:59Z")\
**Posts on this page:** 1\
**Showing post:** 4

<div class="post-metadata">

**Author:** ![ChuckPa](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/chuckpa/32/79710_2.png) [@ChuckPa](https://forums.plex.tv/u/ChuckPa)\
**Post date:** [January 2, 2024, 6:06pm UTC](https://forums.plex.tv/t/problems-transcoding-files-with-eac3-sound/864826/4 "2024-01-02T18:06:28Z")

</div>

@Thrawn

Thank you for this. The failure was easily found.

```auto
Jan 02, 2024 18:26:24.000 [139701501410104] ERROR - [Req#5e65b/Transcode/B30A5E58-1DEE-46A3-A813-13732A120F64/5a005382-3b76-4ecc-a1ae-2f5b9b237aa0] [eac3_eae @ 0x7f798eab7040] EAE timeout! EAE not running, or wrong folder? Could not read '/var/packages/PlexMediaServer/shares/PlexMediaServer/AppData/tmp/pms-035f0dde-fac7-4218-943d-239d182b9f98/EasyAudioEncoder/Convert to WAV (to 8ch or less)/B30A5E58-1DEE-46A3-A813-13732A120F64_4775-0-0.wav'

```

This error, “EAE not running, or wrong folder?” will occur when there are more folders being watched than the Linux kernel table can monitor.  
(your media is well structured and you have a lot of it 🕶 )

The problem occurs because DSM Linux doesn’t allocate a big table by default  
(Most systems ship with only 2GB of RAM so they keep the table small)

You add your media and ask PMS to monitor/watch for changed automatically.

The table fills

If you look at [PMS Logs,](https://support.plex.tv/articles/200250417-plex-media-server-log-files/) about 3-4 minutes after you restart it, you’ll see “No space left on device” while it’s setting up inotify. This is the table overflowing.

Later, when you want to transcode anything with Dolby (needs the EAE), there aren’t any free slots for the transcode & EAE to use so they fail (they need 2 slots)

The solution is simple; Increase the number of folders PMS can monitor WITHOUT filling your memory. ( I don’t know how much memory you have installed – 8GB is a great memory amount for Synology NAS systems )

Here’s the procedure.

> [@Synology FAQ - Questions, Answers, and How-To's](https://forums.plex.tv/t/490215/22):
>
> FAQ 16: Increase the number of folders Plex can monitor Applicable to all supported versions of DSM. When the Linux ‘inotify’ table fills up, this will cause when Plex to stop automatically detecting new media you add to the server. It will also manifest when there are transcoder problems with Dolby audio codecs. Linux has a default table size which is static. We can increase this at will. On some versions it’s 8192. On newer kernels, the default is 65536 folders. This is easy to incr…

Each ‘slot’ you allocate is 540 bytes + Pathname (length in bytes) ~= 668 bytes each.  
(128 byte path length)

The process is simple.

1. use the above procedure to count up how many directory slots you’ll need / allocate
2. Multiply NumberOfSlots \* 668 ==\> Total amount of memory used.

If this isn’t a concern then continue.  
If you only have 2GB in the NAS, or you need a really big table size, you might want to consider increasing memory to 8GB.

Please feel free to ask questions. This is that ‘freaky linux kernel’ stuff 🤣

---

_[View the full topic](https://forums.plex.tv/t/problems-transcoding-files-with-eac3-sound/864826)._
