Problems with multiple audio tracks, Screen freezing during seeking and direct playing subtitles



There are number of issues with Plex on Chromecast 2. I would like to ask if these issues are normal and if devs are aware of them, or is this just me.

  1. Chromecast will never Direct Play, if you have 2 audio tracks while AAC is not set to default/forced one. Even if you pre-select AAC on your phone, Plex and Chromecast will force default track (which in my case is DTS or AC3), and it will force transcoding. If you change audio track to AAC while movie is playing, it will stop transcoding and start direct streaming, but never direct playing. If you look into server log, you will see this error:

Direct play failed; multi-track audio is required

I also get this:

Direct Play is disabled
selected audio stream is not the first audio stream and direct play stream selection is not enabled

I specifically made a 2nd encode of my movie, all settings the same (.mp4 container, .x264 high level 4.1) except I swapped audio tracks. I set AAC as default one and DTS as 2nd one. After doing so and testing it, movie started Direct Playing. This is not a solution however, because all my media is set as DTS/AC3 primary track and AAC as 2nd. There is no way I can change all tracks to force AAC, it would take too much time.

  1. You might ask me why I even bother with Direct Play. Direct streaming both video and audio is very low CPU intensive. Well you are right, but there is an issue. When I direct stream both video+audio, there is a bug while seeking. Sometimes, after seeking back and forward (usually takes 2-3 times) while playing a movie, buffering will freeze, screen will go black and audio will stop playing. This never happens if I transcode video or audio. It only happens when I direct stream both video+audio together.

To unfreeze this, I have to go to video quality and lower quality, so I force video transcoding. Then after few seconds, everything unfreezes and video/sound continues playing. After it starts playing, I can go to quality settings again and change quality back to original. It will continue direct stream without further problems (at least until I start jumping/seeking through movie again). You can do the same with audio and it will also fix the problem (change from AAC to DTS to force audio transcoding, and then back to AAC for direct stream and to unfreeze).

  1. Something is seriously wrong with .srt subtitle support. So far, no matter what I tried, I never managed to make them direct play. They are external .srt subtitles, named XXXXX (2013).eng as they are supposed to be. Even when I have AAC set as primary audio track, and video is Direct Playing, as soon as I enable subtitles, it starts direct streaming both video and audio. In server log I get this error:

Direct play failed; srt subtitles

Subs are in proper .srt format and encoded in UTF-8.

If anyone has any similar issues, or any dev is aware of these problems, please respond or help me figure out what I am doing wrong.


It’s about to get worse - because apparently Google have suddenly decided that they are no longer supporting AAC 5.1 on the Chromecast 2 or Ultra. And as the firmware has hit production and started rolling out - any of us with AAC 5.1 are about to lose the ability to play multi channel audio. Plex is going to have re-transcode - Google are suggesting AC3 or Opus if you still want 5.1 sound. I’m not sure what the devs at Plex will do…

Since someone will eventually ask: Proof:


I don’t really care about that change because all my AAC tracks are in Stereo, to be as compatible with other clients/devices as possible. For surround, I have ac3/dts.


OK well - the recent bug that caused issues with playing files with more than one audio track - where the track you were trying to play is AAC - was eventually fixed by Google - but I remember there being a question about Direct Playing a multitrack file - because when you Direct Play a file to the Chromecast - you are sending the video AND ALL AUDIO tracks to the Chromecast and asking the player on the Chromecast to select the track to play - which means there is wasted bandwidth - because at least one other track is being sent to the Chromecast - which is not used, so it’s just bloat. Direct Stream allows Plex to pick just the stream you want and send it together with the video - and basically uses practically no CPU to do so, because it’s not transcoding.

Plex tried to fix the issue on their end before Google fixed on theirs - and may have disabled the ability to direct play multitrack audio files to the Chromecast - as this was a known trigger of the bug, but it was proved that files with 1 video track and 1 audio track played absolutely fine.


But when I encode movie with AAC as primary/default track and DTS as 2nd track, file still contains multi-track audio, but it direct plays without issue (if no subtitles are applied). So Direct Playing multi-track audio even with ac3/dts track is working, but Plex somehow freaks up if ac3/dts is set as default track. What the hell?


OK I think the starting point is probably trying to play the file directly in Chrome, take Plex out of the loop - cast the video using Chrome’s native casting control. See if the Chromecast accepts it and doesn’t do the playing video but no audio thing - then we can at least figure out if the bug is with Plex or the Chromecast firmware.


Just tested it with Chrome browser, and it does the same thing. When DTS is default track and I switch to AAC, it direct streams. When AAC is default track (and DTS second), it Direct Plays. Basically same as on my android phone.

edit: What do you mean “take Plex out of the loop”? I casted via Chrome browser Plex server UI. How else should I cast it?


If you open the file directly in Chrome (and it is natively supported by Chrome) - Chrome will load it and add video controls - one of which will be a Chromecast button.


Ok I tried it. My url was like this:

file:///C:/Users/[path to video]

When I played a file with DTS as default track, video played without problem but there was no audio. When I played a file with AAC as default track, video and audio played fine.


Okay this is an issue not only with Chromecast but also with Chrome web client. When I am trying to play a movie with AAC audio as default track and DTS as second, it Direct Plays correctly on web. But when I try to play a movie with DTS as default track and AAC as second, it direct streams both video and audio. Identical issue as on Chromecast, so there is an obvious bug or issue with Plex software on web and Chromecast when it comes to multiple audio tracks. Are devs aware of this?