PS3: DLNA Protocol Error (2110) has Occurred

server-dlna

#1

I'm not sure if this is actually limited to the PS3, but it's the only DLNA client I have. Anyway...



When I try to browse the folder of a particular TV show on my PS3 I'm getting the error "Media Server Error: A DLNA protocol error (2110) has occurred" followed by "Media Server Error: A DLNA protocol error (2101) has occurred" and instead of the episode list I get "There are no titles." This also affects the "Recently Aired" and "Recently Added" folders due to episodes of the show being included in those lists as well. Looking at the server logs it seems the DLNA server dies and restarts when this happens.



The show in question is Conan (as in the talk show on TBS). The only particularly unique thing about this show that I can think of is that when I did the original library scan it matched on Conan, an apparent Conan the Barbarian TV show, I then had to "Fix incorrect match" in Plex Media Manager. I thought originally that perhaps the parentheses in the filenames (e.g. "Conan (2010) - S01E01 - Guest Name Here.avi") might be problematic, but I have other shows named similarly that work fine.



The server is v0.9.6.0.11 running on Ubuntu 11.04 and there doesn't seem to be any issue on the other (non-DLNA) clients I've tried (Windows and Android). I've attached what I think are the relevant logs.


#2

[quote name='HipToday' timestamp='1335416481' post='259053']


I'm not sure if this is actually limited to the PS3, but it's the only DLNA client I have. Anyway...



When I try to browse the folder of a particular TV show on my PS3 I'm getting the error "Media Server Error: A DLNA protocol error (2110) has occurred" followed by "Media Server Error: A DLNA protocol error (2101) has occurred" and instead of the episode list I get "There are no titles." This also affects the "Recently Aired" and "Recently Added" folders due to episodes of the show being included in those lists as well. Looking at the server logs it seems the DLNA server dies and restarts when this happens.



The show in question is Conan (as in the talk show on TBS). The only particularly unique thing about this show that I can think of is that when I did the original library scan it matched on Conan, an apparent Conan the Barbarian TV show, I then had to "Fix incorrect match" in Plex Media Manager. I thought originally that perhaps the parentheses in the filenames (e.g. "Conan (2010) - S01E01 - Guest Name Here.avi") might be problematic, but I have other shows named similarly that work fine.



The server is v0.9.6.0.11 running on Ubuntu 11.04 and there doesn't seem to be any issue on the other (non-DLNA) clients I've tried (Windows and Android). I've attached what I think are the relevant logs.

[/quote]




I had this issue setting up my brother-in-laws plex setup. In his case his plex server was a windows box. I solved it by allowing plex through the windows firewall. I can't remember if I just added plex, or the port.....Try just disabling the windows firewall and see if it will work.


#3

[quote name='evil_hero' timestamp='1335469911' post='259215']


I had this issue setting up my brother-in-laws plex setup. In his case his plex server was a windows box. I solved it by allowing plex through the windows firewall. I can't remember if I just added plex, or the port.....Try just disabling the windows firewall and see if it will work.

[/quote]




It's definitely not a firewall issue as all my other shows, movies, queue, etc. are working, and I'm not filtering anything on this box:



<br />
$ sudo iptables -L<br />
Chain INPUT (policy ACCEPT)<br />
target     prot opt source               destination<br />
<br />
Chain FORWARD (policy ACCEPT)<br />
target     prot opt source               destination<br />
<br />
Chain OUTPUT (policy ACCEPT)<br />
target     prot opt source               destination<br />



#4

I've played around some more and this appears to be a bug with the combination of fixing the incorrect match of Conan, the Linux build of Plex Media Server, and DLNA.



I removed Conan the Talk Show Host from the library, and re-added it. Then when I refreshed the library it matched again as Conan the Barbarian. If I leave the meta data wrong, the episodes show up on the PS3 and play fine. Obviously the show information is wrong, Conan (the talk show) is numbered by air date in the file names and there certainly aren't Conan the Barbarian episodes from 2012, but at least I don't get "There are no titles" and protocol errors.



I messed around with this on a spare Windows box I have with PMS v0.9.6.0.11 on that as well and this is NOT an issue there, fixing the incorrect match works as expected and Conan shows up via DLNA on the PS3 just fine.


#5

I've bumped up the DlnaPlatinumLoggingLevel to FINEST in an attempt to get some more info. Attached are the logs from a fresh restart of the Plex Media Server and doing nothing more than attempting to browse to Video -> TV Shows -> All Shows -> Conan (2010) -> Season 2012 (this is where the errors occur and the DLNA server dies and restarts) on the PS3.



Am I really the only one that is trying to watch Conan with Plex and a PS3?



If anybody would like to try to reproduce this, I believe all they'd need to do is rename any old TV show file to something like "Conan (2010) - 2012.04.25.avi".



EDIT: I failed to mention, DlnaTraceVerbose="1" is also set.


#6

This is still an issue in v0.9.6.1.