[Re-Solved] N2800 CPU always at 100% usage since the last Plex update 0.9.15.2 and 1.7.3.3937

server-thecus

#1

Hello,

As with the previous update of Plex, since I installed the latest update (0.9.15.2) I encourred problem with the CPU usage. In fact, the CPU of my Thecus NAS N2800 is continuously at 100%

Can you propose a patch to remedy a problem is like with the older version.

Thank you beforehand,


#2

What thecus version are you running, because I had thought that all the threads on this concluded a thecus firmware downgrade resolves this issue. From what I understand, past Plex releases have worked and new releases continue to work on thecus v2.05.08, just not on thecus vv2.05.12, including my N7510.

Shouldn't the conclusion be then, that Thecus made a change between 8 and 12 that is no longer compatible with Plex, since 10/15/15? It seems unclear as to whether it is Plex that broke something and so far, I've heard nothing directly from Plex taking responsibility.


#3

Thanks latweek for your reply,
but I can't downgrade my firmware to the v2.05.08 I get this message : "Lower update error
The firmware version currently installed is newer than the version you are attempting to install.
The firmware can not be updated to a lower version."


#4

Sure, you need to contact Thecus to get the downgrade patch. There are 2-3 threads about high CPU, one of them describes the process.


#5

you need to contact thecus support to get a downgrade FW for your system...

they'll then send you an email like this:
https://forums.plex.tv/discussion/comment/1080882/#Comment_1080882


#6

Thanks I will try immediatly


#7

This works, thanks to indications supplied by the Thecus support :

Please follow steps below to downgrade your firmware,

  1. Log in WEB UI
  2. [System Management] -> [Firmware Upgrade] -> Upload the attached firmware tool “N2800.V1.014020039_0014FD1776BE.rom” -> DO NOT REBOOT THE UNIT -> [Firmware Upgrade] -> Upload the firmware file -> Reboot the unit
  3. Once the unit reboots completely, please confirm if the firmware version is the version uploaded by the 2nd step and if the issue still remains.

Here is the download link for the firmware:
http://www.thecus.com/Downloads/beta/FW/64_V2.05.08.20150416_build8457_FW_N2800_N4510U_N4800_N5550_N7510.rom

And it work, show the result with the graph of the CPU utilization :

Thank for your help, it’s a shame that Thecus and Plex fail to put work together to develop a new working version.

Ptitsnake


#8

The Plex Development team are looking into this issue which appears to have started with theCus firmware update after v2.05.08


#9

Hello,

I’ve updated my Thecus N2800 with the firmware 3.00.01.4.cdv and the CPU consumption is again a problem. The Plex process uses almost all of the available CPU:

It appears that the CPU consumption is linked to the Plex application:

PID USER PR NI VIRT RES SHR S% CPU% MEM TIME + COMMAND
9145 root 20 0 474m 28m 11m S 334.0 1.4 3447: 31 Plex_Media_Serv
20 root 20 0 0 0 0 S 21.5 0.0 166: 37.75 ksoftirqd / 3
16 root 20 0 0 0 0 S 17.5 0.0 166: 33.23 ksoftirqd / 2
12 root 20 0 0 0 0 R 12.2 0.0 165: 56.11 ksoftirqd / 1


Do you have an idea to solve this problem?

Thank you in advance for your assistance,

Ptitsnake.


#10

@ptitsnake said:

Hello,

I’ve updated my Thecus N2800 with the firmware 3.00.01.4.cdv and the CPU consumption is again a problem. The Plex process uses almost all of the available CPU:

It appears that the CPU consumption is linked to the Plex application:

PID USER PR NI VIRT RES SHR S% CPU% MEM TIME + COMMAND
9145 root 20 0 474m 28m 11m S 334.0 1.4 3447: 31 Plex_Media_Serv
20 root 20 0 0 0 0 S 21.5 0.0 166: 37.75 ksoftirqd / 3
16 root 20 0 0 0 0 S 17.5 0.0 166: 33.23 ksoftirqd / 2
12 root 20 0 0 0 0 R 12.2 0.0 165: 56.11 ksoftirqd / 1


Do you have an idea to solve this problem?

Thank you in advance for your assistance,

Ptitsnake.

Last time this happened, it was a firmware issued fixed by TheCus Firmware 2.05.14.4 v2

See https://forums.plex.tv/discussion/comment/1187966/#Comment_1187966


#11

@ptitsnake - could you get the Plex Media Server logs (ensuring debug logging enabled and server restarted) - with the logs captured when the cpu is that high so that we can see what Plex Media Server was doing at the time

https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

We will raise it with TheCus but please do so as well. As mentioned the last time this arose, it was an issue with TheCus firmware which was subsequently fixed in a firmware release


#12

@ptitsnake - We understand that TheCus team have asked you to try now with firmware v3.02.00.4

Please let me know if that resolves the issue.


#13

Thanks sa200 for your help.

I just installed the latest firmware BETA available on the site of Thecus v3.02.00.04.
And the problems of excessive CPU usage and RAM on used seem to have been solved:

Thank you again for your help,

Ptitsnake.


#14

Thanks @ptitsnake for the feedback