Receive shaka4011 (Manifest) error when playing media via Firefox/Chromium on Fedora 27

plex-web

#1

I am unable to play any type of media on a Linux machine running Fedora 27. I receive a shaka4011 (Manifest) error.

Fedora: 27
Plex Media Server: 1.10.1.4602
Firefox: 57.0.1
-or-
Chromium 62.0.3202.89

Can someone help me resolve this?
Thanks
Ray


#2

Can anyone help here?


#3

I’m having the same issue, I just installed Fedora 27. Plex Media Server 1.9.6.4420, and Chromium Version 62.0.3202.89 and Firefox 57.0.1 both generated this playback error.

:expressionless:


#4

Any help here? Would like to know how to resolve this…


#5

SOLVED: In Chromium settings, I was offered the chance to update the Codec and Digital Rights. I clicked on both, restarted, and the error is gone. I suspect that a recent Chromium update did not automatically update those and Plex Player needed them. Good luck!


#6

@beninator I’m not sure where you see the ability to update Chromium, but I don’t see it. Regardless, I want to be able to use Firefox. I’m frustrated that no one from Plex has offered any guidance into what this error means and how to resolve it.


#7

As with the OP, I also get shaka4011 (Manifest) error when playing videos in latest version of Plex (as of 1/24/18) in Fedora 27. The difference for me, though, is that I only get the error on Chromium with the PPAPI flash. It strangely works in Chrome (PPAPI) and Firefox (NPAPI), though. Another difference for me with the OP’s post is I only get it when playing videos (The OP said that he gets it playing any media). Music works on all browsers.

None of the above comments/suggestions worked.


#8

I’m having the same issue. Fedora 27 and Firefox Quantum 58 64 bit.

EDIT: I have found a fix. I installed VLC and it installed ■■■■-ton of codecs and my Plex started working.
I followed the instructions on this page: https://www.itzgeek.com/how-tos/linux/fedora-how-tos/install-vlc-media-player-2-0-6-on-fedora-17-fedora-18.html


#9

Thanks @cplessinger, this worked for me as well. Would have been nice if the error was"missing codec" instead of shaka4011.


#10

Had the same issue on Ubuntu distro. There’s no need to install VLC. All I had to do was to install missing codecs.

sudo apt-get install ubuntu-restricted-extras


#11

Here is what you have to do in Fedora 27 to watch Plex in Mozilla:

Enable the repo, it ships disabled with metadata enabled

$ sudo dnf config-manager --set-enabled fedora-cisco-openh264

then install the mozilla integration and the gstreamer plugin

$ sudo dnf install mozilla-openh264 gstreamer1-plugin-openh264