[REL] Str2Utf-8


#1

Welcome to SRT2UTF-8

This is the official thread for a plug-in (Agent) named srt2utf-8

If you are having the problem, that national characters in your subtitles, that are not embedded in the movie, but either downloaded by yourself and put next to the movie (Sidecar SRT) or a subtitle automatically fetched by the Open-Subtitle Agent, are displayed as garbage, then this Agent might be the answer for you!

In short, it'll make sure, that your subtitle files are encoded in utf-8, so national character-sets doesn't show as garbage in the players

If you are having problems with this plugin, then feel free to post a Question in this thread, but I urge you to at least read the manual first

Find it here, or simply install via the UAS

/Tommy


#2

Thank you Tommy.  It will probably take a few days before it shows in the UnSupported Appstore.


#3

Thank you Tommy.  I will probably take a few days before it shows in the UnSupported Appstore.

Well....First I'll have to make a req. to add it.....My post was a tad before it's time here :D

In the mean time, you can install it manually, I've @ least managed to make that part of the wiki ready

Find instructions here:

https://github.com/ukdtom/SRT2UTF-8.bundle/wiki

/Tommy


#4

omg, thank you so much, can't wait to go home and give it a try. it was such a waste of time re-encoding the subtitles by hand... thanks!


#5

Rebuilding the library as we speak, will report back about my findings!

THANKS A LOT!

Edit: How do I know it is running? (because it seems like nothing happened yet, and I guess I should expect a rewritten .srt in the folder?)


#6

Rebuilding the library as we speak, will report back about my findings!

THANKS A LOT!

Edit: How do I know it is running? (because it seems like nothing happened yet, and I guess I should expect a rewritten .srt in the folder?)

The spinning wheel on top left right next to the section title should appear while running

Also you should see backup files created in your file-structure, for files that needs to be converted

And lastly, the log-file should stop increasing

The file is fould in a directory named Plug-Ins below this one here:

https://plexapp.zendesk.com/hc/en-us/articles/200250417-Log-File-Locations

/Tommy


#7

The spinning wheel on top left right next to the section title should appear while running

Also you should see backup files created in your file-structure, for files that needs to be converted

And lastly, the log-file should stop increasing

The file is fould in a directory named Plug-Ins below this one here:

https://plexapp.zendesk.com/hc/en-us/articles/200250417-Log-File-Locations

/Tommy

Ah yes now I see, I managed to test the 1 movie which did not get altered (it is an .avi video file, does this matter?)

For your personal use, do you keep the back up subtitles?

Superb tool at a perfect moment for me. Thanks, thanks, and thanks again!!!!!!


#8

Ah yes now I see, I managed to test the 1 movie which did not get altered (it is an .avi video file, does this matter?)

For your personal use, do you keep the back up subtitles?

Superb tool at a perfect moment for me. Thanks, thanks, and thanks again!!!!!!

It handles all media types that Plex knows of, and I keep the backup's until I've confirmed it's working okay

And you're welcome

/T


#9

And adding....in the srt2utf-8.log you can search for the word "convert" to find items that has been altered by this agent

/T


#10

Tommy

On line 90 of __init__.py you have misspelled BeautifulSoap.

Only noticed from looking at the logfile.

Kevin.


#11

Tommy

On line 90 of __init__.py you have misspelled BeautifulSoap.

Only noticed from looking at the logfile.

Kevin.

ROTFL....Okay.....I wasn't expected feedback like this :D

And since it's only for logging, it shouldn't have an impact on the plug-in itself, but I'll fix it next time I update it.

So far simply waiting for peoples feedback, or issues created on github, so I can get a feeling about how it works for people.

Personally, it saves me a lot of time.

/T


#12

https://github.com/ukdtom/SRT2UTF-8.bundle/issues?state=open

/T


#13

Tommy

If I force a check on a movie section that has subtitles it won't check them.

If I remove a movie from that section and add it back then the check takes place.

Kevin.


#14

Tommy

If I force a check on a movie section that has subtitles it won't check them.

If I remove a movie from that section and add it back then the check takes place.

Kevin.

Huh....Working okay here.....

Care to upload the log for me to digest?

Or PM it to me

/T


#15

Sorry

I've already removed the section and added the movies back again.

Kevin.


#16

Darn.....but guess/hope that if others stumble over this, will grap a set of logs, so I can get this fixed

/T


#17

I know that with mine a turbo scan or deep scan wouldn't do it. I had to do a Force Refresh.


#18

I know that with mine a turbo scan or deep scan wouldn't do it. I had to do a Force Refresh.

Just tried that on a small section, success.

Kevin.


#19

Just tried that on a small section, success.

Kevin.

But isn't that what you did before?

Tommy

If I force a check on a movie section that has subtitles it won't check them.


#20

Well....First I'll have to make a req. to add it.....

And did so,,,,No waiting for Mike to either bluestamp it, or telling me this is a dead end

/T