[REL] TV Land


#1

Here is a channel I created awhile back for TVLand.

This channel is now available from the Channel Store.

 

LATEST UPDATE - 6/8/2018 - Fixed issue with URL Pattern.

OTHER UPDATES
7/14/2015 - Fixed issue due to a change on the site.

The channel can be downloaded through my Github account at https://github.com/shopgirl284/TVLand.bundle

Client and Region Restrictions:This channel is region restricted to the United States, because you can only access the videos on this website from a United States IP address. This channel may not work on newer Plex clients if they cannot handle full episode videos from channels in parts


#2

works great, thank you. I had tried my hand at a tvland plugin as well and had gotten most of it working but you beat me to it, so I'll just use yours :-)


#3

I put this on but keeps telling me after goign through a few folders nothing is there


#4

I put this on but keeps telling me after goign through a few folders nothing is there

I just tested it and it seems to be working.

Can you give a little more info about your setup, like PMS version, Plex client.


#5

I have updated the code for this channel to make it simpler and therefore more easy to manage and use, I have removed the video clips. So now it only returns full episodes. I also fixed an issue that was keeping new shows from producing episodes, so now Kirstie produces episodes.

The search still returns Video Clips, if there are any in particular you want to access. I have found that if you add a space and the letter c to the end of your search phrase, the search will only return video clips. For example, "exes c" will return only video clips from The Exes. This can be helpful if searching for a particular clip since full episodes are always returned first and only 20 results can be returned due to its inclusion in the Plex-wide search results.


#6

i wish this one wasn't geo-blocked, theres some good family programming here.


#7

Thanks for the channel shopgirl284! When I click on latest full episodes I get media server responded with an error with a sad face.


#8

Thanks for the channel shopgirl284! When I click on latest full episodes I get media server responded with an error with a sad face.

Just tested it on my setup with Roku, Plex/Web and PHT and load quickly. What is your setup? What client and what OS are you using? 

Also if possible, the channel log file would be helpful com.plexapp.tvland.log (https://plexapp.zeIt is loading prettndesk.com/hc/en-us/articles/201106148-Channel-Log-Files). If you use pastebin - http://pastebin.com/ it makes it easy to paste it as a link


#9

Just tested it on my setup with Roku, Plex/Web and PHT and load quickly. What is your setup? What client and what OS are you using? 

Also if possible, the channel log file would be helpful com.plexapp.tvland.log (https://plexapp.zeIt is loading prettndesk.com/hc/en-us/articles/201106148-Channel-Log-Files). If you use pastebin - http://pastebin.com/ it makes it easy to paste it as a link

I haven't tried on my Roku yet. I am getting the sad face using Plex/Web through chrome on Win7.  Here is the log file:

http://pastebin.com/2WrYXTH7

update: on my Roku I get something to the effect an error has occurred... blah blah blah when clicking on the 'latest full episodes' menu option.


#10

Thanks for the log. I am getting the error now, I must have been getting a cached version of the page. It should not be a hard fix, but I want to look into it a little bit first and make sure I have it set up in a way that will prevent any more errors like this from popping up if I can. I will let you know when I have uploaded a fix


#11

I have tried many times to get this plugin to work with a Roku 2 xs player and it is not coming up on the directory at all. I am in the United States so was wondering what options there are. Does this not work in some US locations? I am running Plex Rarflix 3.1, could this be an issue also?

Thanks!


#12

Thanks for the log. I am getting the error now, I must have been getting a cached version of the page. It should not be a hard fix, but I want to look into it a little bit first and make sure I have it set up in a way that will prevent any more errors like this from popping up if I can. I will let you know when I have uploaded a fix

Sorry I must have forgotten to post here that I had uploaded a fix for this. So it should be working now.


#13

I have tried many times to get this plugin to work with a Roku 2 xs player and it is not coming up on the directory at all. I am in the United States so was wondering what options there are. Does this not work in some US locations? I am running Plex Rarflix 3.1, could this be an issue also?

Thanks!

Actually you must be in the US for the plugin to work and it is compatible with the Roku 2XS.

But this channel is not in the Channel directory, it is a channel you must install manually.   See the first post where it gives a link to the Github repository for downloading. See this for link for how to manually install a plugin - https://plexapp.zendesk.com/hc/en-us/articles/201187656-How-do-I-manually-install-a-channel-

And make sure you have rebooted your Plex Media Server after you have installed it.


#14

Ok. I am in the US and I did what it said on the link that you posted, the only thing that I did differently was cut and paste the un- zipped file to the Plex Plug in file. Would this be the reason they are not showing up? Is there another setting that would be blocking them from showing up?


#15

Ok I would need to know what steps you have tried. First are you unable to see all channels or just TVLand? If no channels are showing up, it is not a problem with the TV Land channel.

it is most likely the authentication setting or that you are not on the same network as discussed here - https://plexapp.zendesk.com/hc/en-us/articles/201375923-Why-are-none-or-only-some-of-my-installed-channels-showing-up-on-my-Plex-app-

If you have already tried this and no channels are producing. Check to see if it is an issue with your client or  PMS by opening Plex/Web client (Media Manager). If the channels show up there, the issue is with your client. If not, it is PMS that is giving the issue. You can find answers or post questions in the section of the forum for that client or PMS OS.

Other Things To Check

Did you make sure to delete "-master" from the end of the bundle name?

Did you make sure you put the bundle in the right folder?

See https://plexapp.zendesk.com/hc/en-us/articles/201106098-How-do-I-find-the-Plug-Ins-folder-

Other causes could be the permissions you have on your PMS computer.

If all else fails, you can upload a copy of your log. But if this is an issue with all channels, and not just TV Land, you will need to post that in the appropriate section of the forum.


#16

Thanks for your help! I think I got it straightened out.


#17

Hi, this just stopped working for me, I can get to the shows but not to the episodes. Is anyone else seeing this?


#18

Hi, this just stopped working for me, I can get to the shows but not to the episodes. Is anyone else seeing this?

I've found the issue, an update for this will be pushed out in a couple of minutes.


#19

This plugin has stopped working for me now, in a different way - doesn't even open the plugin (can't get to the shows or the episodes). Any ideas?


#20

It is not working.

It looks like they have revamped their website. I will give it a look and see how big the changes are.