Remote Access not working from any Alexa device

alexa
voice-control

#1

My plex server is online and reachable, but when I ask alexa from any of my Amazon devices, including my Echo and Firestick, it tells me that it cannot connect to my server. Yet, my server is showing the green check mark and appears to be accessible.

The firestick opens plex and can play content just fine.

If I ask plex to change my server, she gives me a list of servers and I can change them.

But if I ask alexa to open plex on any of my alexa enabled devices, she tells me my server cannot be reached.

I have tried unlinking and linking Plex in my Alexa app but to no avail.

“your Plex server Mac Mini sierra appears to be online but remote access is not available please see your Alexa app for details on how to enable it or select a different server”


#2

I’m also having the above issues. I set port forwarding, I can reach my plex server from anywhere yet Alexa keeps saying the above as well.


#3

I too am having this same issue. I have two echo dots and they both give the error, “your server appears to be online but remote access is unavailable” even though it is available and working. I have removed the skill and re-linked my accounts. This is driving me mad!

Any ideas?


#4

Just wondering. What routers are you using? Could it be that the router is filtering incoming Alexa requests somehow? Ie, although remote access is available the router blocks Alexa’s incoming remote requests.


#5

rkp91… I am using a TP-LINK gigabit router, but do not believe that has any bearing on the issue as I can get to my servers remotely from my IOS app. I went to a friends house who also has Plex and an Echo like mine and could not connect to his server either.


#6

@Flashsolutions, hmm… it was just an idea but thanks for the reply.

I can also access my server remotely via the iOS app over cellular. It seems so bizarre.

I’ve escalated the issue to Plex and will just have to see. I hope it works as the Plex Skill is the whole reason I bought the echoes - multiroom Plex Music.

Have you escalated the issue?


#7

rkp91, No, I’m not sure how to escalate it. I don’t think I am the only one with this problem. I saw it another post reporting the same thing. Strange, because their website eludes to it supporting the Alexa devices including the Echo. They show the Echo Dot and a few of commands.

https://www.plex.tv/apps/streaming-devices/amazon-alexa/


#8

Reading thru a lot of the Alexa related posts and seeing the problem being reported by a lot of folks. No response from Plex. I am using the 2nd Generation Echo and Echo Dots. Seems that might have something to do with it. Wish someone from Plex would let us know what is causing this.


#9

There was an issue with plex.tv. Please restart your Plex Server and Alexa devices and see if you can now connect.


#10

kegobeer-plex, That helped somewhat. Alexa now sees the server and responds to my commands, however, when I ask her to play some of the music in my collection, she acknowledges it, but then I never hear the music playing, she just goes silent.


#11

Everything seems to be working now. Thank you again!


#12

@Flashsolutions said:
kegobeer-plex, That helped somewhat. Alexa now sees the server and responds to my commands, however, when I ask her to play some of the music in my collection, she acknowledges it, but then I never hear the music playing, she just goes silent.

I am in this same position, I’m hoping in an hours time my music will also play haha


#13

@kegobeer-plex, restarting has not helped me. Are there any other solutions?


#14

I think the issue that causes the problem is NAT hairpinning (NAT loopback). Look at your router settings and see if there is an option to enable NAT hairpinning/NAT loopback/NAT reflection. If there are companion settings for hairpin/loopback/reflection, enable those one at a time after you test just enabling NAT loopback.


#15

Thanks for the help but I did not see that option (have a Fritz Box 7490 and Airport Extreme). Not sure why it stopped working but thanks or your help.


#16

There are many threads on this forum with people having the same or similar issues. I do agree the issue is NAT and some people have had success enabling NAT hairpinning or loopback. I am behind a double NAT (on purpose) with a phone ATA sitting out in front of my network so my problems are worse than others.

I have gotten my echo to play music as of this morning but unfortunately I’ve changed many things so I can’t pinpoint exactly what part was critical for me to get it working. I’ll detail what I’ve done though.

There was another thread I saw where someone set secure connections to “Required” under Server network settings and also disabled http pipelining. I did the same and this was the last thing I changed before it started working.

I have remote access enabled on a different port and this may have been part of the problem which I’ll detail later. I have a custom certificate enabled because I was trying to get around my double-NAT problems. The custom cert is from let’s encrypt with my own custom subdomain. I have my custom subdomain listed on the custom server access URL with the public facing remote port number. (https://custom.subdomain.org:32444)

Now I don’t know if this actually worked but I wanted to trick my local plex server to resolve my custom subdomain to my local ip address and not the real public address so I added custom.subdomain.org to my local dnsmasq server and made it resolve to my local ip address.

Now the last part is since I published the different remote port number I thought if my local plex server tries to resolve that it will fail since dnsmasq will work and it will resolve to my local ip address but Plex isn’t listening to port 32444. Therefore I had to add 2 new iptables rules to redirect port 32444 to port 32400 (this is what the router also does for the outside public traffic).

This is way more than anyone should have to do and many won’t have access to these tools like I do on a Linux box. I hope at least the thought process will help if it’s even valid. The last part is I also read just to wait a while and try again the next morning. This is what I did and it worked this morning.


#17

I tried setting secure connections to “Required” under Server network settings and also disabled http pipe-lining. It made no difference, for me at least.


#18

Hi
Looks like I have same prob as being described here. Not sure I understand all the NAT/Router stuff. Is there not a simpler way? Or are there any instructions anywhere how to check NAT etc?
Thanks Tim


#19

I have the same issue. No solutions offered seem to work.


#20

I talk about about this issues here: https://forums.plex.tv/discussion/303556/update-on-playback-issues/

tl;dr we can’t actually detect where on the network your Alexa device is. We’re currently building way to intercept a playback failure due to NAT loopback and fall back to a relay connection (a direct local connection won’t work outright due to a quirk with how the echo devices load media. long-term we’re looking at a solution there as well.) I anticipate our first deploy of this fallback method will ship soon.