Remote Access w/ Echo Show - Do I need to be a networking engineer to make this work?

alexa
voice-control

#1

I love Plex, and for some reason paid for the Plex pass, and one of the greatest benefits of doing that seems impossible. My remote access settings say not available outside my network. But somehow, I get a very slow and lousy connection when I AM outside my network. So...I guess it works..kind of. Now, with our new Echo Show, after pairing them up...echo just says that my server is online but remote access is not enabled. I'm really not sure what to change in my settings. It only seems to work with the manual port enabled. Other than that...I get this message from Plex settings.

Not available outside your network
Your server is signed in to Plex, but is not reachable from outside your network. Learn more
Tip: It looks like your server may be connected to the internet through multiple routers or other network devices. Try connecting it directly to your primary device, or visit our support site for more information about troubleshooting this "Double-NAT" scenario. Learn more

Any advice?
T


#2

You need to add a port forwarding rule in your router settings. The rule should use TCP - Port 32400 - Your Plex Server IP Address.

In Plex settings > server > remote access > show advanced, enable the Manually specify port and leave it set to 32400. Click on apply and then click on Save Changes.

You may need to refresh your browser page before the tick icon turns green and you are able to use remote access.

If that does not help, then make sure your router does not have a firewall enabled or that your PC (Plex server machine) also allows Plex to pass through it's firewall.

If you have any anti-virus programs installed, make sure they allow Plex to communicate with the net through their firewall.

Also, refer to this document: https://support.plex.tv/hc/en-us/articles/200931138-Troubleshooting-Remote-Access

Do you have an ISP supplied modem/router and your own router plugged into it, if so, then you probably have double NAT. See the Tips, Tricks and How-To's forum for help with Double NAT.

https://forums.plex.tv/categories/how-to


#3

I’m going to try what you are suggesting. Here is where I’m at…

  • “Manually specify public port” is already checked…with 32400.

  • Do I use the public or private IP address from Plex settings? Do I add that to my port fwding rule in router settings?
    (attached pic) .

  • There is also this setting in my router, which gave a warning when I enabled it. Is this relevant?
    Remote Config Management Enable Warning - Your Modem is Now Enabled for Remote Access

  • Turned off firewall in router and on Mac. I have no antivirus software.

  • My modem is an ISP supplied motorola modem/router combo. So…double NAT not an issue?

Thanks for the help,
T


#4
  1. That is correct.
  2. Use the local IP Address your NAS uses. I assume 0.0.0.0 means all WAN addresses in your router?
  3. I suspect that option allows you to configure the modem remotely. I would advise you to disable it.
  4. Good.
  5. If you only have the ISP supplied modem/router then you are OK. If you have another router plugged into the ISP supplied modem/router then you most likely have a Double NAT problem.

#5

Andy…thanks for your continued help.

  1. I have no idea. Thats just what it was set to. Replace that with NAS IP?

  2. Done…THANKS

I’m under the impression that my NAS IP is the same as my computer IP…? I use a VPN, so doesn’t my IP change?
Is it possible that my 3TB External HD(thats my NAS right?) isn’t setup to be networked?

Attaching pic of my Plex settings. The private must populate with my router address. The private seems to populate with my computers address.

Tom


#6

@JW2013 said:
Andy...thanks for your continued help.

  1. I have no idea. Thats just what it was set to. Replace that with NAS IP?

Use the PC (PMS server machine) IP Address.

  1. Done...THANKS

I'm under the impression that my NAS IP is the same as my computer IP...? I use a VPN, so doesn't my IP change?

Is it possible that my 3TB External HD(thats my NAS right?) isn't setup to be networked?

Sorry, I meant to say your PMS server machine (PC), but I said NAS. Must have been tired when I replied.

Yes your VPN will change your WAN IP Address. I suggest you turn off the VPN if you want to have remote access in Plex. Some VPN's will not allow remote access for Plex.

NAS = Network Attached Storage device. Plex Media Server can be installed on many NAS.

Attaching pic of my Plex settings. The private must populate with my router address. The private seems to populate with my computers address.

Your Plex settings look good.


#7

Well we tried. I took the public and private IP shown in my plex settings, and made sure they matched the local and external IPs in my routers forwarding settings. (the router IP was originally off by 1)

I disconnected the VPN for now. Clicked Retry in Plex, and it flashed a green "Fully Accessible Outside Your Network" for a nano-second...then went red again, stating not available.

I'm lost...not to mention, I dont understand how I can be away from home and load Plex on my phone, and access all my media yet, the Plex settings state I cant access it remotely, and my Echo does as well.

Also not sure it's worth it if I have to disable VPNs and firewalls.....aren't they my protection?

Confused,
Tom


#8

@JW2013 said:
paid for the Plex pass, and one of the greatest benefits of doing that seems impossible.

Remote access is free, it doesn't and has never required a Plex Pass.

What motorola router ( model number ) do you have exactly?

@JW2013 said:
There is also this setting in my router, which gave a warning when I enabled it. Is this relevant?
Remote Config Management Enable Warning - Your Modem is Now Enabled for Remote Access

This is not relevant to Plex. that is so you can access your routers own settings when you are not at home. unless you plan to do that it is better if you turn it off

Also not sure it's worth it if I have to disable VPNs and firewalls.....aren't they my protection?
did you add a rule to allow Plex through firewall?


#9

Hello Plex Employee...

I have a SURFboard SBG6580. I didn't add any rules to my firewall, but I did disable it as per prior discussion.
I also disabled remote modem access....was just curious about it.

Thanks, Tom


#10

Hello, I would LOVE to get remote access working. However, the support I received in the forum was not successful.

Is it possible to work with someone directly, to get this resolved once and for all? Not by sending messages in a bottle every other day. Maybe with a Phone call? Live Chat? Screen share? Anything? I'm sure I'm just missing a setting or something, but I'm not savvy enough to figure it out.

Thanks, Tom


#11

Part of the problem is, that you have not answered any crucial questions when you were asked. Without those answer we often have no idea how to deal with your issue, it is not like we can read your mind and we certainly don't have a camera trained on you 24/7, so we must rely on the answers and other information that YOU provide us with.

If you correctly followed the instructions given to you, then you should have remote access working. If that is not the case, then you may need to contact your ISP and ask them if they have blocked any ports or if they are using CGNAT. Answers to these questions are important and we will need to know those answers.

As far as support goes, this is it.


#12

@JW2013 said:
I love Plex, and for some reason paid for the Plex pass, and one of the greatest benefits of doing that seems impossible. My remote access settings say not available outside my network. But somehow, I get a very slow and lousy connection when I AM outside my network. So...I guess it works..kind of. Now, with our new Echo Show, after pairing them up...echo just says that my server is online but remote access is not enabled. I'm really not sure what to change in my settings. It only seems to work with the manual port enabled. Other than that...I get this message from Plex settings.

Not available outside your network
Your server is signed in to Plex, but is not reachable from outside your network. Learn more
Tip: It looks like your server may be connected to the internet through multiple routers or other network devices. Try connecting it directly to your primary device, or visit our support site for more information about troubleshooting this "Double-NAT" scenario. Learn more

Any advice?
T

What r u trying to do with your Echo Show?

I have a remote setup working only after getting a static ip from my ISP (at USD15 a month).
I have Dots, shows and a spot and am confused what you want them to do remotely!!?


#13

Well, it's two different things I guess. I can't get remote access working for one thing...to access server from anywhere of course. And the Show is supposed to work with Plex....I guess it would play movies via voice request?? but that just tells me that remote access isn't setup. So...remote access is THE problem, which is just keeping me from playing with Plex on the Show.

So...paying for a static IP huh?


#14

Your last access to your server shows that you have a double NAT issue which may or may not be the issue, but it is certainly a clue. That was addressed in my first response, which you either ignored or did not bother to respond to.

Static IP addresses (local) cost nothing. I do wish you would stop jumping to conclusions and start paying attention to what you are being told and what is being asked of you.

Until you do that, you will get nowhere and noone will be able to assist you. It's your call.


#15

The show will not play any plex video at this time. Plex music may work but won't look pretty.
And yes a double nat is the issue as @trumpy81 has stated.


#16

http://www.aftvnews.com/alexa-devices-in-the-uk-and-germany-can-now-remotely-control-the-amazon-fire-tv-and-fire-tv-stick/