Remote Access with Eero Mesh Wifi

server-windows

#1

I am having some issues with the remote access for my plex server. It use to connect just fine without any issue, but not it will not connect at all. When I refresh plex, it will enable remote access for about 2 seconds and then shut it off. I have gone through and found that a double NAT is not an issue as my modem does not double down as a router and I have gone through and set up port forwarding for the server and it still does not work.

If it helps, I am running an Eero Mesh Wifi network with two access points and the main hub, along with a Netgear cm400 modem.

I don't know if anyone has dealt with this before, but any help would be awesome.


#2

So looking at this your Netgear cm400 is just a cable modem so no config there.
Did you follow this guide for port forwarding on your eero?

If you go to http://canyouseeme.org/ and change the port to the port you setup for forwarding does it show success?


#3

@nokdim said:
So looking at this your Netgear cm400 is just a cable modem so no config there.
Did you follow this guide for port forwarding on your eero?

If you go to http://canyouseeme.org/ and change the port to the port you setup for forwarding does it show success?

Yep, that's exactly how I forwarded the port. I just checked with canyouseeme.org and got success.


#4

Well you are 99% there!

I saw this on a different post so try this now -

If you do disable / re-enable remote access or tick/untick manually specify port, there are some timing problems that may give rise to status being incorrect - a reboot after enabling it and manually specifying the port may help. The issue would be arise if there are numerous clicks and in quick succession - best to leave 30 second gap between clicks and if set correctly best not to unset/reset

So get the check box ticked for port specified and make sure its all set right get a reboot for a nice fresh start and make sure.

Also you should be able to browse http://x.x.x.x:32400 from your mobile phone while NOT on your home Wifi where x.x.x.x is the IP that canyouseeme.org reports and get a plex login screen.


#5

@nokdim said:
Well you are 99% there!

I saw this on a different post so try this now -

If you do disable / re-enable remote access or tick/untick manually specify port, there are some timing problems that may give rise to status being incorrect - a reboot after enabling it and manually specifying the port may help. The issue would be arise if there are numerous clicks and in quick succession - best to leave 30 second gap between clicks and if set correctly best not to unset/reset

So get the check box ticked for port specified and make sure its all set right get a reboot for a nice fresh start and make sure.

Also you should be able to browse http://x.x.x.x:32400 from your mobile phone while NOT on your home Wifi where x.x.x.x is the IP that canyouseeme.org reports and get a plex login screen.

Seems to be working now. I did a reboot and it was up, but I had an update for the server. I ran the update and the remote access didn't work again. I went ahead and did a second reboot and it seems to be fine now. I just hope I don't have to continue to reboot after every server update.

Thanks for all your help!!


#6

Nah mine is stable once its setup and not being messed with its happy, I haven't had to mess with that in ages.


#7

I am also seeing problems.
Today it said it only allowed indirect connections.
When I reset the connections on the remote settigns the server is completely offline


#8

@calvo.family said:
I am also seeing problems.
Today it said it only allowed indirect connections.
When I reset the connections on the remote settigns the server is completely offline

I am now having the same issue. I am trying to do the same troubleshooting, but not getting anywhere. It was working fine for a while, but has since stopped all of the sudden.


#9

I had no problems with Plex and Eero up until early September when I moved into a CenturyLink area and ran into doubleNAT issues. I've bridged my Eeros and port forwarded and I still get remote access/indirect connection issues. Not sure if this is due to my CL setup or something else going on like what was reported above.


#10

did you fix your issues? I have CL too and have ruined into the same issue.

@Travillion said:
I had no problems with Plex and Eero up until early September when I moved into a CenturyLink area and ran into doubleNAT issues. I’ve bridged my Eeros and port forwarded and I still get remote access/indirect connection issues. Not sure if this is due to my CL setup or something else going on like what was reported above.


#11

@Jrb2jrb said:
did you fix your issues? I have CL too and have ruined into the same issue.

@Travillion said:
I had no problems with Plex and Eero up until early September when I moved into a CenturyLink area and ran into doubleNAT issues. I’ve bridged my Eeros and port forwarded and I still get remote access/indirect connection issues. Not sure if this is due to my CL setup or something else going on like what was reported above.

TBH, I’m not sure. It’s working for me now, but it has been unreliable in the past. In my first attempt at port forwarding, I did not setup a static IP for my server (PC), so things broke once my computer reset.

In my latest effort, I setup a static IP, and that alone seems to be working. Strangely enough, things would break when I would try the port forwarding step :confused: