Rename from default "PlexMediaPlayer" on RPi

plex-media-player

#1

Just installed this on 2 Macs & a Pi 2. The Macs get named after my system fine but the Pi is still a default "PlexMediaPlayer" No UI option to change this yet or am I missing it somehow?


#2

There does not appear to be a GUI option. However it is in the configuration file:
/storage/.local/share/plexmediaplayer/plexmediaplayer.conf

SSH to the raspberry pi 2 (username/password: root/plex)
Stop the plex media player front end (systemctl stop plex)
Edit the configuration file using vi or nano (nano is easier for a new user, vi is much more powerful)
In the "openelec" section, change the "systemname" variable to your desired name.
Save and exit the file.
Start the plex media player front end (systemctl start plex) OR reboot the raspberry pi 2 (reboot)

See also:
https://support.plex.tv/hc/en-us/articles/207338798-Advanced-Configuration


#3

We will take a look at this and see if we can make that look better :) Thx!


#4

correct. we are working on that, the reason it's not exposed to the UI is that we haven't got a on screen keyboard yet, but that will have to be added for search, when that's done we will be able also add in text settings.