Renaming Fire as a Device, Alexa not listing active clients



I have two Fire TV units local to my house, all named properly by Amazon - meaning, if I go to Amazon, sign in, and go to Manage My Media and Devices, I see them named "Master Bedroom Fire" and "Living Room Fire" and if I look at the Fire menu under Settings, Device, it says the name of my device matches that which was set on the Amazon website (i.e. "Master Bedroom Fire").

If I go to my Plex server, however, they are listed as "Fire TV" and that's it. I can only differentiate them by the MAC address identifier next to their version number. I have tried unregistering them from the server, uninstalling and reinstalling/re-registering the device to my server, everything - nothing changes its name. There is also no ability to change the device's name in the Plex app on the Fire device, nor is there an option to name the device in the Plex server web GUI. I need this option to be able to differentiate between my two units, not only from the standpoint of managing them in the web GUI but also so that they can be controlled by name with Alexa.

While I don't want to present two problems in a single request, I have another issue as well - if I ask Alexa to change my default player, it says it can only find a single player connected, and sets it as default automatically - but it sets "Google Chrome," not "Fire TV." Which is odd because I'm literally looking at my master bedroom TV right now, looking at the open Plex app, which is actively playing music from my Plex server, and it's obviously not using Chrome as its player. The Alexa app is registered properly to both my account and the Plex Media Server per the setup guidelines.

I just updated both the Plex app and the Media Server, which are running and, respectively. Everything is hard-wired on gigabit ethernet. I can watch content from Amazon and through Plex, even full-bitrate Blu-Rays, with ease, so it's not a connectivity or setup issue, just a manageability and Alexa integration one.

Any clue? Without the ability to rename the Fire TV in Plex, I can't tell them apart. I also can't possibly tell Alexa which device to play things on if I can't rename them, and even if I can I can't seem to list them with Alexa.


Hi tpomerhn - Thanks for your well worded post as I was having the same problem on both my FireTV box Gen-1 (FireOS Version (Build 562254320)) and Gen-2 (FireOS Version (Build 565189620)) devices.

I have just updated the Plex app to (2.11.2) released on 3 Feb 2017 and I am now able to successfully use Alexa to voice select either of these devices as the default output device. I did a quick test of telling Alexa to Ask Plex to play a particular movie title and to tell me what is on deck. Both skill requests were successful on both devices.

I would suggest checking to see if you can prompt your device to pull down the latest Plex update from Amazon or go to your Amazon account and "Deliver" it to the devices. I hope that helps!

p.s. I did have the Plex app open on both devices when I asked to set the default player.


Thanks but I cannot get that version... amazon has as the latest version available. Tried uninstalling it, clear cache and data, reboot, install from scratch, reassociate to my Plex server... Came in as, and tried to have Alexa change my default player while the Fire was signed in to my server... Doesn't list Fire as a device, only lists Chrome. I don't see any mention of the version you're running on Amazon and I can't update any further because Amazon thinks I'm on the latest and greatest.

My hope is that you're in the developer channel... I'm only in the stable channel. Maybe an app update will fix all of this. Until then I can't use Alexa with anything at all, and can't differentiate between the two devices because Plex refuses to name them properly and has no facility to change a device's name, which is something it should have had for ages IMNSHO.

Does your system list your Fire as the name you have it designated as in Amazon, or just "Fire TV" or "My AFTS" or something on the build you're running? Crossing fingers that this feature will also work soon, I can't tell the difference between any devices I have except for a single iPad.


Hi tpomerhn - A thousand apologies on my sloppy copy/paste from the AFTV device window. I do have the same app version as you and no, I am not in the developer channel. Just like your experience, even though I have renamed my devices in the App & Device management section of my Amazon account, Plex reflects the name Amazon gave the device (see pic):


Thanks for confirming - yeah, that's the kind of screen I see as well. They are not capable of being renamed (on either the client or the server side), which is absolutely unacceptable. Either we need the Fire to show up in Plex with the correct name from Amazon, or we need the ability (like the Android app has) to rename the device on the client, or the ability to create/rename an alias on the server.

I still can't add any Fire to my Alexa, even when they are running on a TV five feet away and running a blu-ray. It's not a deal breaker, but it sucks that I was really looking forward to this functionality and it doesn't work.

Thanks for your feedback - any recommendations on getting other folks to chime in, say a developer or something? I'd like to get to the bottom of this.


I have the same issue. I originally added my Amazon Fire and Amazon Fire Stick to Plex and now want to change the default names to Living Room TV and Dining Room TV. Changed the names in the Amazon service, new name shows up correctly in the Fire settings menu, but no matter what I do it does not change in Plex. I have removed the devices and re-added them, power reset everything, ... No luck, still the old names. I did the same for my Roku box and after removing it and re-adding it to Plex now it has the new name, worked perfectly. Running