REQUEST: No update for 3.13.1 found on LG webOS 3.00.17

smart-tv

#1

Seems like the latest version (3.13.1) of Plex client for LG smart TVs was released a few weeks ago, but I can't find one for my LG projector (PF1500W) running webOS 3.00.17.

Its Content Store is still stuck with an old version (3.8.0) which has a serious issue preventing me from using it. While I almost gave up on using Plex client for webOS, I'd like to give a last shot hoping this new version might have fixed some issues under the hood.

I guess the Plex dev might need to poke LG Content Store to make updates available to this particular device. That was how XPlay got released for this device when its developer (thankfully) didn't bother to let them know it's not shown up in the store.


#2

sorry to reply only … is that i have the exact same issue … unable to watch anything via the app. having to stream via tablet etc …


#3

Have you tried TV reset


#4

@SE56 I’ve reset my device more than three times and also tried IN-STOP factory reset, but no luck.


#5

I as well have a PS1500W projector and face this issue. I can’t even connect to my PMS, I keep getting the error to reset plex and start over. Multiple reset to factory result in the same problem. Is there anyway to “sideload” the latest plex client in WebOS?


#6

Just checked my PF1500W and still no luck to find any updates on Plex. It’s stuck to 3.8.0.

I don’t know other ways to “sideload” this app, and to be honest, I don’t feel like this issue is ever going to be taken care by Plex team either. I talked to LG reps and they acknowledged this problem and was willing to contact Plex, but that’s already several months ago and nothing has changed. At the same time, I’ve posted questions/requests regarding this issue multiple times, but didn’t get any single response from Plex team. Very disappointing indeed.


#7

Same problem with my LG B7P

Any news ?


#8

The LG content store has version 2.1.0, that app has not been updated recently, but the web app updates every time the app launches.