Request: Select AC3 track as default

apple-tv

#1

All my video files have 1 AAC track and 1 AC3 track.
Apple TV itself is using the AC3 track automatically.
But Plex will always play AAC as default.
Could you please provide an option that it will select AC3 as default if available.


#2

+1

That would be awesome. My videos are all the same way:

  • the video
  • German AAC-track (stereo)
  • German AC3-track
  • English AAC-track (stereo)
  • English AC3-track
  • and then maybe some DTS-tracks and/or subtitles and/or chapters

PlexConnect managed to select always the German AC3-track on my ATV2 and the tvos-app always starts the first AAC-track :-S


#3

I'd like the AC3 track to be the default also.


#4

I believe (I could be wrong) that Plex selects the first track it finds.

You could try changing the order of the tracks with a piece of software (I haven't tried it but I think MKVToolNix may work) and see what happens.


#5

I deleted all AAC tracks. Problem solved.


#6

thats what I did also! removed all others but AC3


#7

Mines says in settings that the AAC track will play (it has the check mark), but that's not what happens when I actually play the movie. When I play, the AC3 Surround track plays via Direct Play.