# \[Resolved\] Can't sign in, interal server error 500 for plex.tv/api

**URL:** <https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877>\
**Category:** General Discussions\
**Tags:** server-docker, server-unraid, plex-web, player-windows\
**Created:** [October 4, 2019, 11:59am UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877 "2019-10-04T11:59:46Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 11:59am UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/1 "2019-10-04T11:59:46Z")

</div>

I can’t find a support category, so forgive me for posting this in general.

As of the early hours of 03 Oct (about 05:00 GMT), I updated my docker instance of Plex (to v1.18), and ever since have been unable to sign in.

I’m unable to claim my server without using Claimit, I’m unable to log in through the Plex web app, or locally accessing my server. I keep getting redirected to the [app.plex.tv](http://app.plex.tv) sign in page, proceed to do so, and then get an “Internal Server, something went wrong on our end.” error.

I originally thought I’d borked something during the upgrade - but I’ve been through various recent versions of my database, I’ve been back through the last 5 tags for the docker instance I’m running (rolled back pretty much straight away to the last known version that _did_ work). I’ve cleared browser cache, cookies, hosted app data, etc etc.

The one thing I’ve been able to discern is that it looks like my Plex server has a cert installed for plex.direct that doesn’t match the plex.direct address that is being issued. (No amount of cache clearing, renewing the certs etc has managed to make this match - I see a new cert installed in the server, but the plex.direct address still seems to point to the old one. (I’ve no idea how this plex.direct works, so I don’t know if that’s relevant or not…) To try and eliminate the plex direct thing, I’ve run through a reverse proxy using only HTTP (local side) and having disabled remote access all together, and I’m still unable to get signed in or claim the server.

I have tried installing fresh servers, on fresh machines, on separate networks, I’ve tried using different browsers and machines for signing in - I’ve even spun up a few virtual browsers in docker to eliminate any cache or cookie stuff. Still nothing - no matter fresh server or old, nothing helps.

I keep seeing:

`GET https://plex.tv/api/v2/user?includeSubscriptions=1&includeProviders=1&includeSettings=1&includeSharedSettings=1&X-Plex-Product=Plex%20Web&X-Plex-Version=4.8.3&X-Plex-Client-Identifier=7lky0udti0qptauqixsyio89&X-Plex-Platform=Chrome&X-Plex-Platform-Version=79.0&X-Plex-Sync-Version=2&X-Plex-Features=external-media&X-Plex-Model=hosted&X-Plex-Device=Windows&X-Plex-Device-Name=Chrome&X-Plex-Device-Screen-Resolution=850x868%2C1920x1080&X-Plex-Language=en-GB&X-Plex-Token=XXXXXXXXXX 500 (Internal Server Error)`

and

`GET https://plex.tv/api/v2/user?includeSubscriptions=1&includeProviders=1&includeSettings=1&includeSharedSettings=1&X-Plex-Product=Plex%20Web&X-Plex-Version=4.8.3&X-Plex-Client-Identifier=7lky0udti0qptauqixsyio89&X-Plex-Platform=Chrome&X-Plex-Platform-Version=79.0&X-Plex-Sync-Version=2&X-Plex-Features=external-media&X-Plex-Model=hosted&X-Plex-Device=Windows&X-Plex-Device-Name=Chrome&X-Plex-Device-Screen-Resolution=850x868%2C1920x1080&X-Plex-Language=en-GB&X-Plex-Token=XXXXXXXXXX 500 (Internal Server Error)`

in the developer console - as well as (if I connect locally):

`GET http://127.0.0.1:32400/media/providers?X-Plex-Product=Plex%20Web&X-Plex-Version=3.108.2&X-Plex-Client-Identifier=arsnmiz65sbilyeuo8u1wsgc&X-Plex-Platform=Chrome&X-Plex-Platform-Version=79.0&X-Plex-Sync-Version=2&X-Plex-Features=external-media&X-Plex-Model=bundled&X-Plex-Device=Windows&X-Plex-Device-Name=Chrome&X-Plex-Device-Screen-Resolution=850x868%2C1920x1080&X-Plex-Language=en-GB net::ERR_CONNECTION_REFUSED`

I’m not sure why it’s trying to talk to 127.0.0.1 though, as the server isn’t localhost.

I also keep seeing this in the server logs:  
`ERROR - Error issuing curl_easy_perform(handle): 60`

However, the machine this is running on is kept up to date with NTP (and I’ve verified that it’s correct on various other machines) - I thought maybe this would have something to do with the mismatched certs?

This all seems to me like some sort of [plext.tv](http://plext.tv) or plex api issue - but as it happened right after I upgraded, I can’t be sure. The fact that fresh server installs on separate networks all give me the same issue - could there be something at the Plex side of things that has “stuck”?

I don’t know, a full 24 hours troubleshooting the same thing over and over and over is somewhat draining… I think I need a coffee now.

Any help much appreciated, I can of course provide logs or whatever else may help.

Thanks,  
David

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 12:08pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/2 "2019-10-04T12:08:18Z")

</div>

Zip of all the logs, instead of snips please

And loopback address 127.0.0.1 is mandatory for a PMS server!

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 12:17pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/4 "2019-10-04T12:17:34Z")

</div>

Yeah, I get that about loopbacks - but I’m seeing that in the developer console of the client I’m trying to connect from, so I thought it should have been trying to connect to the private address and not the loopback. If that is just the developer console telling me that the server is connecting to itself, then it’s not an issue. I’m just not massively familiar with the developer console.

Anyway, there’s information in my logs that I’d rather not be public - can I send you these non publicly?

Thanks,  
David

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 12:24pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/5 "2019-10-04T12:24:45Z")

</div>

> [@alwaysblamedave](#):
>
> can I send you these non publicly?

Sure, NP

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 12:38pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/6 "2019-10-04T12:38:11Z")

</div>

Can you for a start try and reboot your unraid.

I see certificate problems here, and have seen in the past, that for some unknown reason, intermediate certs only goes into action after a complete OS restart ☹

Then report back

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 12:38pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/7 "2019-10-04T12:38:55Z")

</div>

Sure thing! Thanks 🙂

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 12:52pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/8 "2019-10-04T12:52:30Z")

</div>

No change, still getting the login loop and

`GET https://plex.tv/api/v2/user?includeSubscriptions=1&includeProviders=1&includeSettings=1&includeSharedSettings=1&X-Plex-Product=Plex%20Web&X-Plex-Version=3.108.2&X-Plex-Client-Identifier=pnxcqf80k6gccmp6c9bfmpwp&X-Plex-Platform=Chrome&X-Plex-Platform-Version=79.0&X-Plex-Sync-Version=2&X-Plex-Features=external-media&X-Plex-Model=bundled&X-Plex-Device=Windows&X-Plex-Device-Name=Chrome&X-Plex-Device-Screen-Resolution=850x868%2C1920x1080&X-Plex-Language=en-GB&X-Plex-Token=XXXXXXXX 500 (Internal Server Error)`

in the developer console.

Fresh logs?

Edit: still seeing  
`DEBUG - CERT: incomplete TLS handshake: sslv3 alert certificate unknown` in the server logs

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 1:02pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/9 "2019-10-04T13:02:12Z")

</div>

[Plex Media Server.log](https://forums.plex.tv/uploads/short-url/xqw9gArZnq85NiK5L330ALsnt6w.log) (97.5 KB) [Plex Media Server.1.log](https://forums.plex.tv/uploads/short-url/n7EdDkTCr58LuRw6YPpIJirWVRE.log) (688.9 KB)

These are fresh logs from a new container on a separate machine.

Seeing this in the developer console:  
`GET http://127.0.0.1:32400/media/providers?X-Plex-Product=Plex%20Web&X-Plex-Version=3.108.2&X-Plex-Client-Identifier=u6dds75ejfky58frtwtycqbk&X-Plex-Platform=Chrome&X-Plex-Platform-Version=79.0&X-Plex-Sync-Version=2&X-Plex-Features=external-media&X-Plex-Model=bundled&X-Plex-Device=Windows&X-Plex-Device-Name=Chrome&X-Plex-Device-Screen-Resolution=850x868%2C1920x1080&X-Plex-Language=en-GB net::ERR_CONNECTION_REFUSED`

Same login loop and internal error.

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 1:24pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/10 "2019-10-04T13:24:58Z")

</div>

Latest logs, I see something is req. :32400/identity on your public address?

Could you describe your setup a bit?

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 1:34pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/11 "2019-10-04T13:34:17Z")

</div>

Original server is unraid, running this docker image: `https://hub.docker.com/r/binhex/arch-plexpass`

Second fresh server is unraid again - same version, different hardware. I’ve spun up `https://hub.docker.com/r/plexinc/pms-docker` instead. Completely fresh install, nothing touched except for the friendly server name.

Both are running as host networks in docker, no port conflicts with anything else.

What else would be of import that you’d like to know? Both machines are on the same switch, same subnet. DNS is managed by a pair of Pi-Holes (all plex domains except for analytics are allowed and available), and I’m trying to manage the Plex instances from Chrome/Brave/MS Edge on a Windows 10 machine (same subnet, same switch, same DNS) and an android device (chrome and firefox), both via LTE to rule out my network config and via wireless. Same results every time. Login loop and unable to claim server unless I claim it by Claimit. The Plex instances are fully functional, but it doesn’t see me as signed in so I can’t manage anything like shared accounts, or even my account settings.

Edit: Just adding that this all worked flawlessly until the 1.18 upgrade on the morning of 03 oct, and has done for years

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 1:38pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/12 "2019-10-04T13:38:06Z")

</div>

If you look in the preferences.xml file, does it state you are online, and with the correct username?

Also, running my claimit script directly on the Plex version of the docker, what does it say?

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 1:46pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/14 "2019-10-04T13:46:47Z")

</div>

`PublishServerOnPlexOnlineKey="1" PlexOnlineToken=" *******" PlexOnlineUsername="alwaysblamedave" PlexOnlineMail="s******* @gmail.com" PlexOnlineHome="1"` is in Preferences.xml, if this is what you mean?

Claimit, I’ll have to attach a screenshot, I’m using the windows thing and can’t seem to copy the log.

![ClaimIt_2019-10-04_14-43-40](https://global.discourse-cdn.com/plex/original/3X/9/7/97c1d9e2263c3e93d1a83730c5e7d9827bcef9a6.png)

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 1:56pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/15 "2019-10-04T13:56:45Z")

</div>

I’ve seen in my logs over the course of this as well, that the PMS keeps pulling auth tokens from somewhere, and every time I modify or update something the number of tokens pulled increases.

Is it possible to invalidate all access tokens or something? I’m honestly, pretty far out of my depth here, but I feel like this some sort of cache, or DNS propagation issue somewhere in the chain.

The thing that really has me stumped is the 500 internal error - is that a Plex.tv server issue, or is that my Plex instance? This whole plex.direct thing and the api (which I know 0 about), and which part of what server is doing what, coupled with a profound lack of sleep is boggling my mind 😃

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 2:08pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/16 "2019-10-04T14:08:25Z")

</div>

According to that, your PMS did sign in with the info you provided.

Are you 100% sure, that the browser you use is also signed in with the same user?

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 2:13pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/17 "2019-10-04T14:13:52Z")

</div>

Claiming the server isn’t the problem - Claimit does exactly what it says it will 👍

After claiming the server, I get this:

 ![chrome_2019-10-04_15-10-03](https://global.discourse-cdn.com/plex/original/3X/9/3/933942a286516fecd82d070e48b96f4450e24905.jpeg)  
 ![chrome_2019-10-04_15-10-08](https://global.discourse-cdn.com/plex/original/3X/7/7/778a0d49c44e12bf57c13f05de1cfaba4e68d211.jpeg)  
 ![chrome_2019-10-04_15-10-16](https://global.discourse-cdn.com/plex/original/3X/1/2/12dfe2004608c31ad2b5974e2c6507298f9270fa.jpeg)

1st is `https://192.168.1.124/web/index.html` 2nd, I get redirected to `app.plex.tv` for auth, 3rd, I get redirected back to a blank `https://192.168.1.124/web/index.html` with a “Internal Server Error. Something went wrong on our end.”

edit:

 ![2019-10-04_15-14-57](https://global.discourse-cdn.com/plex/original/3X/a/9/a9f3255c01baf2936a42d6ad2be9caf22a33a6b8.png)

---

<div class="post-metadata">

**Author:** ![sensei321](https://avatars.discourse-cdn.com/v4/letter/s/7ea924/32.png) [@sensei321](https://forums.plex.tv/u/sensei321)\
**Post date:** [October 4, 2019, 2:14pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/18 "2019-10-04T14:14:29Z")

</div>

Could this be related to the issue I replied to here? [Can not reach PMS servers which are in docker containers](https://forums.plex.tv/t/can-not-reach-pms-servers-which-are-in-docker-containers/470647)

I am unfortunately on a weekend trip now, and I am not able to provide logs until sunday evening at the earliest.

---

<div class="post-metadata">

**Author:** ![dane22](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/dane22/32/4389_2.png) [@dane22](https://forums.plex.tv/u/dane22)\
**Post date:** [October 4, 2019, 2:27pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/19 "2019-10-04T14:27:57Z")

</div>

Could you for a small test try with another browser…

I suspect your browser might be using some kinda plugin to block needed stuff?

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 2:33pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/20 "2019-10-04T14:33:47Z")

</div>

My current session has worked with these plugins prior to the upgrade, as I’ve said.

Current (chrome) session, I’ve tried incognito - so no plugins. Have then tried a fresh install of Brave (no plugins), MS Edge, and I’ve even spun up a fresh chrome and firefox browser in docker (on yet another machine) - all to the same effect.

Dunno if it’s worth mentioning, but I can still access my original server, as I said: everything “works”. But after the successful auth, it doesn’t “sign me in” for the session:

 ![chrome_2019-10-04_15-27-19](https://global.discourse-cdn.com/plex/original/3X/e/2/e2fdfc3adcd1fd343776f211050afd4c94ab0893.jpeg)  
 ![chrome_2019-10-04_15-32-25](https://global.discourse-cdn.com/plex/original/3X/d/8/d8f46f5b30729b1b93b9c6d7a3e7cb966ed65e77.jpeg)

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 2:36pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/21 "2019-10-04T14:36:52Z")

</div>

![ApplicationFrameHost_2019-10-04_15-36-27](https://global.discourse-cdn.com/plex/original/3X/5/2/521da6e0a16d197204fc36b6bb105098413c46b8.png)

It is this, that I keep seeing over and over and over again.

---

<div class="post-metadata">

**Author:** ![alwaysblamedave](https://sea1.discourse-cdn.com/plex/user_avatar/forums.plex.tv/alwaysblamedave/32/152432_2.png) [@alwaysblamedave](https://forums.plex.tv/u/alwaysblamedave)\
**Post date:** [October 4, 2019, 3:29pm UTC](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877/22 "2019-10-04T15:29:02Z")

</div>

I don’t know what’s changed, but all of a sudden we’re up and running again \o/ fantastic.

Thanks @dane22 for your help.

[Next page](https://forums.plex.tv/t/resolved-cant-sign-in-interal-server-error-500-for-plex-tv-api/470877.md?page=2)
