[RESOLVED] No Captions or Subtitles



My TV and system info is in a previous topic:

I recorded some shows using the Silicon Dust HDHomeRun Extend. When viewing them on the Samsung TV (and our Vizio as well), the app says the files have no captions or subtitles (I realize they're not the same). When viewing the same content from my iPhone, the subtitles are present and work fine.



It depends on the format of the subtitles and how they are available to the app.
The app can play external (separate file place beside the movie file) subtitles in the format srt and ssa directly.
If the subtitles have a different format, you might need to switch the playback mode to Direct streaming so the server will embed them inside the video.


How is “Direct streaming” enabled?

And I’m using whatever format is the default for the Plex DVR.



You can reach that setting from within the preplay screen. It’s one of the icons on the left that looks like a movie frame.

Download the manual here > https://forums.plex.tv/discussion/71090/download-the-user-manual-here#latest



Amazing. A 75-page manual for a TV app. I had no idea they even made manuals for them, I thought the “User Manual” in your sig was for the devices, not the apps.

Ok, I tried every option and in every case, it did not show any subtitles. In fact the Subtitles option was un-selectable in any mode but “Direct play”, but showed “none 0/0” for subtitles.

However…the manual has a lot to say about it, and I’m working my way through it. I’ll post back here with the outcome.

Thanks for your help so far!


Update: There’s some good info in that manual. My recordings apparently use “internal subtitles”, which are problematic for the TV app. It’s clear they are in the recordings, because they show up when playing via the web or via an iOS device. The problem seems to be that they are recorded in .mkv format.

In the menu that you pointed me to, there is an option to “Use TV API, this will try to use the TVs capability to extract the internal subtitles”. That seems to have no effect at all, at least not for my recordings. The other two options involve transcoding, either BEFORE playing the content, or DURING. I had hoped to avoid using the server to transcode, because my plan was to move this to a low-power NAS.

That seems to leave me with two options (or three):

  • “In this case your only option is to extract the subtitle from the movie and use it as an external subtitle file. There are several programs available on the internet that can do this.” In the advanced options of the DVR, there’s an option to run a “post processing” script after each recording, to extract subtitles into a separate “sidecar” file format (like .srt). The manual says “here are several programs available on the internet that can do this.”
  • Post in the support forum for the Plex DVR to see if there are options to store the subtitles separately.
  • Wait and see if the TV app eventually gets upgraded to provide better support for internal subtitles. :s

Thanks again.


And another update:
I tried the first option – extract the subtitle from the movie (the .mkv file) and use it as an external subtitle file.

First, I downloaded a subtitle file in .srt format from opensubtitles.org, to verify this would work. The subtitles displayed perfectly, but they were coded for the original show, perhaps as you’d see it on DVD. But the OTA broadcast had about 2:17 of offset before the show actually started, and the subtitles started immediately. So this .srt file was over two minutes out of sync. But it worked! In looking at the raw .srt file, it would be pretty nuts to try and add the offset value to each timestamp, and the amount of offset may not be the same for every recording. That’s just nuts to even attempt.

So, next option is to extract it from the .mkv file. It turns out, there’s a handy tool for this, and it looks like it doesn’t even require re-transcoding. It’s the mkvtoolnix utility. I installed it, and examined one of the recordings:
$ mkvmerge -i Call\ the\ Midwife\ (2012)\ -\ S06E03\ -\ Episode\ 3.mkv
File ‘Call the Midwife (2012) - S06E03 - Episode 3.mkv’: container: Matroska
Track ID 0: video (MPEG-4p10/AVC/h.264)
Track ID 1: audio (AC-3/E-AC-3)
Global tags: 1 entry
Tags for track ID 0: 1 entry
Tags for track ID 1: 1 entry
There should be a third track with the tag “subtitles”, but it’s not there. At this point, I think there’s something in the Plex DVR that’s not working as I would expect it to. I’ll post my questions in the appropriate category…



If the subtitle menu shows None or 0/0 then there just are no subtitles available.
In that case you might need to add them first in the form of a sidecar .srt file.
You can check that also in Plex web.

If the video is in MKV format and it has subtitles tracks, you should be able to use my MKV fix tool to extract the subtitles from it. In that way you would be able to use Direct Play without any transcoding.


I hear you, but I’m confused. If they’re not available, how is the same .mkv file showing them in the iOS app, and via the browser?



I have no idea, auto translate maybe, but if Plex web says “None” under subtitles, we can’t show them.


The subtitles (or maybe they’re captions) are clearly in the broadcast. Either the tuner (HDHomeRun Extend) is discarding them in the transcoding step, or Plex DVR is discarding them. Maybe I should try turning off HDHomeRun’s hardware transcoding and see what happens.

Thanks for hanging in here with me.


I just recorded a snippet of a TV show, with hardware transcoding turned off. It produced a .ts file (just one file). I ran:
$ mkvmerge -i Craft\ in\ America\ (2007)\ -\ S07E01\ -\ Music.ts
File ‘Craft in America (2007) - S07E01 - Music.ts’: container: MPEG transport stream
Track ID 0: video (MPEG-4p10/AVC/h.264)
Track ID 1: audio (AC-3/E-AC-3)

We can see that there’s no “subtitles” track. So it looks like I need to boot up a Windows machine, install the HDHomeRun software, and see what configuration options there are.



The HDHomeRun software offered no options for the file format.

I changed the HomeRun Extend TRANSCODER QUALITY setting via Plex (Settings | Server | DVR (Beta) | Device Settings) to “Original format” based on a tip that I got from another post in this forum. The resulting .mkv file had one additional audio track, but no subtitles track.

I’ll see if I can get answers from the SiliconDust HDHomerun support forum.


The folks on the SiliconDust HDHomeRun forum are telling me that my program contains closed captions but not subtitles. Apparently the Plex App doesn’t support closed captions – just subtitles. It would be a nice feature.


Ok, this is weird. Closed Captions started working tonight in my 2015 Samsung Smart TV Plex app. I didn’t change any settings on the app, or on PMS. Go figure.

And I can verify that they’re not subtitles, because there’s no “subtitles” track in the .mkv file, and no accompanying .srt file.
$> mkvmerge -i Home\ Fires\ (2015)\ -\ S02E04\ -\ Episode\ 4.mkv
File ‘Home Fires (2015) - S02E04 - Episode 4.mkv’: container: Matroska
Track ID 0: video (MPEG-1/2)
Track ID 1: audio (AC-3/E-AC-3)
Track ID 2: audio (AC-3/E-AC-3)
Global tags: 1 entry
Tags for track ID 0: 1 entry
Tags for track ID 1: 1 entry
Tags for track ID 2: 1 entry

I guess it’s possible that some of the backend support packages for Emby may have enabled Plex to decode the closed captions. (?) I removed Emby and everything that was installed with it, so we’ll see if that breaks Plex.



Update: Still working fine after removal of Emby and all the dependencies that came with it.



I also have a HDHR Extend sending an unprocessed mpeg2 TS file in the new update (it didn’t work under unprocessed in the MKV either), no transcoding under Plex which does not display Closed Captions. VLC Media Player displays the closed captions with this same file and WinTV player displays the closed captions but Plex does not. You should not have to jump through hoops to display closed captions. I believe it is a pretty standard format. It is just that Plex has not done the work.


+1 I have a hdhomerun prime and the closed captions work in mythtv/vlc/kodi + the Plex iOS app however they do not work with Plex on my Nvidia Shield. I don’t have good hearing, this is something I would pay to have some focus on.


Agreed, Nvidia Shield or any Android device does get close captions with HDHomeRun APK but not on Plex. Please upgrade soon.


+1 for this. I just bought a lifetime Plex Pass for the DVR, and it’s a bummer to find my recordings have Closed Captions that Plex can’t display.

FWIW, I’m using Plex on an Apple TV 4K, and an HDHomeRun. Live TV captions display perfectly. My recordings definitely include the closed captions (they’re visible in VLC, and I can extract an SRT using CCextractor on my Windows machine). However, when I try to playback my DVR recordings they show with no subtitles available (both in the Apple TV Plex app and the Infuse app). I think in theory I could try installing the CCextractor Linux packages to my Synology and have Plex run it as a postscript, but I’m not confident in my ability to do that properly (or if it can be done).

What’s frustrating is that the Silicon Dust app handles captions perfectly regardless of playback client, live/recorded, etc. But they don’t have an app for Apple TV. On my NVIDIA Shield, the HDHomeRun app from Silicon Dust is clunky looking, but it WORKS.

I am regretting the Plex Pass upgrade and all I can do is wait for a proper Apple TV app from SD or use my Shield in the meantime. I’m hoping Plex addresses this in a future release but I am not optimistic.