Roku 2: Ongoing issue with Plex "buffering" after running fine for ~1:45



Hi All,


I hope I can get a little instruction or suggestions.


I have an ongoing issue when watching movies on my Roku 2.


The movies will play fine for about 1 hour and 45 minutes (this is an estimate, the general feel of it is that the issue happens when there about 20 minutes left in a movie)

Then Suddenly the screen will go to the please wait screen.

It will buffer at a significantly slower pace then when the movie first loaded up.(when the movie first loads, I get perfect quality right away in lest then 10 seconds)

Maybe takes 5-10 minutes for the bar to fill up and then the movie will run for another 5-10 minutes and then then go back to the please wait screen.

This behavior will repeat for the remainder of the movie.


This issue is consistent across all my MOVIES, not just a single file.


The issue does not appear to happen when watching TV SHOWS.

To my knowledge, all the TV Shows I have are between 30 minutes to 1 hour.

So perhaps because they don't reach that 1:45 threshold, they don't experience the issue.


All files, TV shows and Movies are 1080p MKV files.

My Roku and PC are hard wired to my router. (the router is not the latest and greatest by any means, but never gives me any issues with anything else)


PC is a Quad Core AMD with 8GB ram. Windows 7. 60GB SSD (for OS and Applications, PMS is installed on this drive) 2TB HDD (for plex movies) 3TB HDD (for general data storage).


Latest PMS

Latest Roku SW (5.x ?)

Latest Roku Client


I've fiddled around with various settings to try and improve performance.

The obvious one was setting the quality way down.I chose 3mbps 720p and this had no effect.

I set the transcoder temporary directory to one of the HDDs thinking that it may be using the SSD be default and somehow this may be an issue. this had no effect.

I set the Size of IPC buffer (in bytes) when streaming transcodes to 40MB. Not sure if that's overkill or would cause an issue but the issue was already present before this and this had no effect either way.


I have logging enabled but when I went to the logs url I just got:

reating URL transfer object for
Creating URL transfer object for
Creating URL transfer object for
Creating URL transfer object for
Creating URL transfer object for
This was repeated all the way down the page.
So that's my story. I'm sorry if I left anything out or missed an obvious setting on my own but this has been maddening ever since I set plex up.
I want it to work perfectly so badly.
It's really the perfect solution for my entertainment collection =)
Thanks for our help!


there are so many intelligent and helpful people in this forum - i'm surprised this hasn't been helped along in any way

... i am having virtually the same problem

... right around the 1:30 mark for me

... super long buffer - this happens with both Roku and Chromecast

... i even went and upgraded my router to a top of the line Linksys for better local play but still giving those hiccups

started to swap out larger file size movies for smaller ones... lowered the quality of the streams as well - which if i go any lower will begin to become counter productive to the whole setup.

i'm now considering spending the money on a much higher grade pc for the server.

... is there a setting i may have missed that someone can possibly suggest?

this Plex is great - i rave about it everywhere and to everyone... but i sure do get real embarrassed when this happens in fornt of someone i was talking you up to :-)




Try switching from Universal to Legacy Transcoder.  I had identical issues and that worked for me.  Others have had the same issue:


or you could drop you video output resolution on the plex settings in the roku I had the issue tonight with roku 3 dropped my output reso and it worked perfect


Some outside the box thoughts: 

Is your PMS server going into sleep mode (or the hard drives allowed to spindown in power settings)? 

Anything else (CPU intensive) happening on your server at those times?


Hi there,

I too am experiencing this issue.

I get almost 2 hours into a film then, as the OP describes above, goes back to the buffering screen and stays there.

I press back, try the film again from the last played position and it stays on the buffering screen.

I can play the same movie from the start and it will play straight away!

I can go to another movie on the same hard drive and play it from the beginning and it will load straight away and play fine.

This is on a wired network with a decent gigabit switch between my Plex server and Roku 2.

These are 1080p mkv's

Streaming settings at 20Mb/s

Transcoder set to universal (also tried on legacy, no change)

Power settings on HDD checked

I love Plex but am a little concerned that I've seen this issue on a few forum posts but no real answers from anyone as yet.

PMS Windows 7 64Bit

Roku2 5.3


I have a gigantic media library with people in several households streaming media from my server with a combined total of 7 Rokus in use both on my lan and remote ranging from v1 to the newest Roku 3. I have experienced this issue many times before and it always seems to happen with certain compression types.

In my experience... Whenever I get a text that someone is continuously "buffering", I tell them to change to force transcode mode. I don't know "technically" what is going on behind the scenes but in my head how it makes sense is: The Roku starts a media file and thinks it can direct stream the file, but maybe the bitrate or overall file size it too large for the low power CPU in the roku to handle decoding on its own so it needs to constantly stop to buffer, maybe not stop to obtain more data but stop to think and process. So, forcing it to transcode takes that problem away. 

Turn your Roku to Always Transcode mode: When you are on the media details screen so, you were watching a movie and it was buffering so you hit the back button once and you are back at the movie details screen (has the title, poster, actors, details, stars, etc...) Arrow down to PLAYBACK OPTIONS. Open TRANSCODING options and scroll down and select TRANSCODE. Hit ok, Close, and now the top option has changed to "PLAY TRANSCODED". See if that helps... This will force the media to run through Plex Transcoder on your media server and be reformatted to the proper size, bitrate, resolution, etc that will play without hesitation on your Roku. 

Also... Turn your Roku quality on 8Mbps... Seriously, I have a video editing business so I understand bitrate, resolution, compression formats and ratios yadda yadda... and for real you MAYBE will see a difference between 4Mbps to 8Mbps IF its a dark high action scene... but anything 8Mbps and above you wont even notice a quality difference so, leave it at the default 8Mbps and you will solve at least one potential problem. 

Also keep in mind... If you are on a wireless signal and most Rokus are only wireless capable and dont even feature an Ethernet port... Even Wireless N and faster has a very limited range, im talking about for streaming... You MAY be able to access your wireless router with 4 bars 1/2 mile down the street BUT... what is really important is the signal POWER, which is not calculated in the "bars" formula so the bars are really irrelevant... 100 - 150 feet at MOST with Wireless N... And im factoring in probably 3 walls and some furniture in between point to point wireless access point and device.

This transmission rate will greatly affect streaming services. If youre on a wireless mac, try it out for yourself... Hold down alt/option and click the WiFi button in the top right taskbar of your screen... you will see a "Transmit Rate" area.... Take your laptop 1 foot away from the wireless source and open that... Then, take it in your living room or, say three rooms away and open again... That number significantly reduces. Thats just how wireless is. 


Same issue. Here's my logs.


multiple people have reported this same issue and just get told to upload their logs and then nothing happens


It stopped buffering after the last update and now it's starting again.

I have the latest version of Plex

My PC has 4gb of ram and a dual core 3.06ghz x 2 processor.

My speedtest result: says I'm getting 23.6mbps

I'm only streaming to one Roku 2, which is about 12 feet from my server and wifi router. All these devices are in the same room.

I'm not sharing my library with anybody and nobody is currently sharing theirs with me.

I've run scans and analysis on my whole library.

I've tried each available transcoder setting in Plex (there's no transcoder or quality settings on Roku to change as advised above). None of them make any difference.

Logs attached again. Please advise.


Anyone? What do you think of those logs? What are they telling you?