Roku 3: Strange audio issue with files with multiple audio language with 5.1.1

roku

#1

Hello, seems my Roku Plex app updated and so when I went to resume my anime show and found it was stuck with Eng audio when setting were Japanese. Turning it to different options seem to result in only English audio being played. When I use the Android version correct audio plays on the same file. Other unplayed files was equally stuck on it but other series seem to play the correct audio as well hence the "strange" title. Could use some help please as this was working previously and through the Android version. Thanks


#2

Yeap, something updated and I lost my ability to play other audio tracks as well after the recent update.
It also looks the Roku menu that appears from the left when pressing “*” now does not allow changing audio stream either, I think it used to. But going through Plex Stream options, allows changing audio tracks, yet the english one (I assume the first) continues to play regardless.

Can someone please take a loo at this? This was working before, its a regression.


#3

Hi,
I have the same issue, PLEASE!!! help!!! Plex support please fix it.


#4

Same here. Multiple soundtracks, only English, regardless of what’s being selected. Tried different settings (Prefered language on/off) with no success.

Happened after recent plex-roku update.


#5

Also, if there is no english track available, then no sound at all :wink:


#6

Same here, since the early February update (I could tell because some UI elements changed slightly in appearance), selecting a language before playing or while playing has no effect. It will always play the English stream. HOWEVER, using the Star key * on the remote and selecting the desired audio language in the “Audio track” menu does get the correct language playing. This however resets on each episode played.

As others reported in other threads as well (some were saying no audio at all), this only happens when Direct Play is used. It appears that a bug/a different behavior was introduced in the player application. Maybe the language is selected by a different component, or the built-in language selection is now broken. I have no idea if the Star key thing worked before or if this is a new thing.

It makes sense to me that transcoding on the Plex server fixes the issue, as in this case, the Roku receives a video with a single audio stream (the stream that you selected when playing the file) and does not have to pick the correct stream. However, when using Direct Play, the Roku receives a video file with 2 audio streams and now chooses the stream differently than it did before.

Btw I am using a Roku TV if it makes any difference. I have 2 Roku TV’s and the problem started occurring on both at the same time, when the update hit.

Would like to see this fixed, as this is very annoying while watching a series with multiple languages!


#7

We are able to reproduce this issue and will have a fix in an upcoming release. You can workaround this by disabling direct play in the meantime.


#8

Workaround (disabling direct play) doesn’t work for me as I’m still getting English audio only but hopefully your fix will resolve my issue all the same. Is there a rough ETA on when the next release is happening?


#9

@djwu We plan on updating regularly, I can’t say exactly when. But I’m curious about your issue after disabling direct play.

  1. So disable direct play and play your content with Japanese audio selected.
  2. After playback starts, open Plex player settings via playback controls or long press on OK button.
  3. Navigate down to Stream Info.

You should see “Transcode” for the Playback info. What do you see here?


#10

@jzolezzi With direct play disabled, playback says “Transcode (throttled).”
edit: just in case you need more info
format: hls
video: convert (h264)
audio: copy (aac stereo)


#11

Disabling Direct Play works for me. The playback status becomes “Converting (throttled)” and the video and audio are both Direct Stream. djwu, I think jzolezzi wanted you to report the status of the video and audio as well, not just the transcode/convert status.


#12

made my edit with more info if need be.


#13

@jzolezzi any updates on the fix? It has been a month since you were able to repro the problem.

Thanks


#14

Hi @finikk, the update is available via our Plex Pass channel. We have submitted this to Roku to get our official channel updated, but expect some time for it to complete certification and then release.


#15

@jzolezzi said:
Hi @finikk, the update is available via our Plex Pass channel. We have submitted this to Roku to get our official channel updated, but expect some time for it to complete certification and then release.

This issue is back on the latest version of the plex preview channel.

I am using the Plex preview channel (Build 5) because it fixed this issue many people had with 4K videos (https://forums.plex.tv/discussion/307391/4k-hdr-video-breaking-up-since-new-plex-roku-channel-installed) however there is a different issue on this build and hopefully you can fix it before the next roku channel update. I am having this problem on multiple HEVC files. For example i have a file with the following audio tracks (1. movie audio 5.1 aac, 2. commentry #1 ac3 2.0, 3. commentry #2 ac3 2.0, 4. commentry #3 ac3 2.0). I have selected Track 1 (movie audio 5.1) but track 2 plays. No matter which track i pick on the Roku track 2 plays. If i disable direct play then the audio track works as they should. I have a lot of movies that have 2 audio tracks where Track 1 is English and Track 2 is a foreign language and the foreign language always plays no matter which language track i select on the Roku. I think with the previous build on the preview channel (Build 3) fixed the problem but now it is back.


#16

@kfarr2009 Audio selection is a bit tricky with Roku’s video player. In direct play scenarios, we set the language of the selected audio track but we can’t explicitly set the audio track index before playback. For remux and transcode cases, we have full control and will select the correct track in the stream.

Perhaps you have a stereo configuration and Roku is attempting to use the stereo audio track automatically, Track 2 in your file. In some cases, you can try * button while playing the video. Roku might offer you different audio tracks to use instead.

You can direct message me a sample of your file and we’ll take a look. https://support.plex.tv/articles/201035968-generating-sample-files-from-media/


#17

@finikk and @djwu The official channel has just now been released. It should fix the audio language stream selection issue you are seeing + 4k playback issues.


#18

@jzolezzi said:
@finikk and @djwu The official channel has just now been released. It should fix the audio language stream selection issue you are seeing + 4k playback issues.

I downloaded the latest offical channel and the problem is not fixed. It was working fine a while ago (I believe in Build 3). My audio in Roku is set to accept Dolby Digital 5.1 and my amp is capable of handling ac3/aac 5.1 fine. I have the 5.1 movie track selected on my plex server as the default but the roku still plays the wrong track. Can you take a look at build 3 as i believe thats when it was working. It very annoying because i have multiple HEVC 4k HDR movies with both an English and a Foreign audio track. The Roku plays the foreign track with the English track selected so i cant watch the movie in English. If i force transcoding to get the audio to play correctly then the HDR doesnt work because for HDR you need to direct play the file.


#19

@jzolezzi said:
@finikk and @djwu The official channel has just now been released. It should fix the audio language stream selection issue you are seeing + 4k playback issues.

I confirm that channel version 5.1.5 fixes the issue I was experiencing (always playing English track in a file that has English and French languages, even if I select French). Thanks!


#20

My kids thanked me today for being able to watch their favorite cartoons in russian again, so I guess mine was updated to the version with the fix, I will double check myself and report back if I find any issues. Thanks! What is Plex Pass channel? Should I switch to it and use it instead of the official one though? What are the benefits? @jzolezzi