Roku App Requires Multiple Attempts to Play Video From Plex Cloud Server Before It Succeeds

roku

#1

I don't know if anyone else is experiencing this problem, so I thought I'd mention it and see if it's just me or a known issue.

I have a Roku 3 (with an SDHC card) and a Plex Cloud Server linked to OneDrive. When I attempt to play a video using the PCS, it fails, and I have to try playing it about six to twenty times before it'll finally succeed. (It hits 13% and displays an error, the text of which I forget because it's a generic "Unable to play, etc." message.) When it eventually progresses from 13% to 33%, I know it's going to succeed.

I can successfully play the video on my phone at the same time the Roku is failing to play it, so I don't think it's an issue with the PCS, OD, or the video itself.

It doesn't seem related to decoding because x264 and x265 exhibit the same problem on the Roku.

Are there any other troubleshooting steps that I can perform to help narrow down the issue? Would the PCS logs be helpful?


#2

I'm seeing the same issue.

My setup uses a Roku Express as the frontend, Plex Cloud, and it's backed by Google Drive.

I haven't seen any issues through the Plex android app, or the Plex web interface.


#3

Hello I have the same issue any way to fix this?


#4

First review the thread pinned to the top of this forum called Read First: Posting Media Playback Issues on Roku.

As stated in that document, try to access the media from another Plex player app like Plex Web. If you have the same issue from Plex Web, then this is not a Plex for Roku issue, but an issue with Plex Cloud. Plex Cloud issue would need to be asked or addressed in the Plex Cloud section of the forum.

Also see the "Supported media file types" section of this link - support.roku.com/article/208754908-how-do-i-use-roku-media-player-to-play-my-video-music-photos-#! for the types of media that can be direct played on the Roku, since Plex Cloud can only direct play compatible media.


#5

@“Jester.Tucker” said:
I have to try playing it about six to twenty times before it’ll finally succeed
I can successfully play the video on my phone at the same time the Roku is failing to play it, so I don’t think it’s an issue with the PCS, OD, or the video itself.

As you can see in my original message, I tried playing the same video using Plex on my (Android) phone, and it works.

I also stated that it will eventually play on the Plex Roku app–it just takes a dozen or two attempts–so it’s not a codec issue.