Roku isn't using subtitles by default

roku

#1

I have setup in the settings for subtitles in english to be used by default. On other devices (not my Roku) this occurs. Movies/TV shows automatically use the subtitles.

This also used to be the way Roku behaved, but at a certain point they are now not played by default and I have to select them every time I play a new item.

Please respect my subtitle defaults and allow them to be played by default again.


#2

Roku INC Screwed The Pooch:
https://forums.plex.tv/discussion/266499/subtitles-not-working-after-updating-plex-channel-to-version-4-4
https://forums.plex.tv/discussion/262670/bug-plex-preview-channel-v4-3-3-and-v4-3-4-text-based-subtitles-only-respect-global-setting
The source of our pain and suffering:
https://forums.roku.com/viewtopic.php?f=28&t=100928


#3

ok, went to Roku home options > video > TURN ON CAPTIONS > subtitles > AUTOMATIC > exit
went back into roku > movie > subtitle showed up


#4

Solution here:
forums.plex.tv/discussion/296164/automatically-starting-subtitles#latest