Roku keeps buffering



Plex Remote Logging
Enabled 8-17-17 @ 21:16 pm CST
Replicating on going buffering issue between Plex Media server with latest update on Mac Mini streaming to Roku 3600x stick

Originally encountered issue with roku firmware 7.7 but was able to roll back roku firmware to 7.6 thinking that would help the issue.

Only able to stream for a couple of minutes without buffering at quality of 2 Mbps. Original quality of file 3.6 Mbps

Also tried at 1.5 Mbps for a 480p stream still buffering.

Says my transcode is throttled.

Speed at hotel via
26.91 down
31.85 up

But using Netflix speed test on Roku says 4.45 down.

Home speed
Ping 10ms
47.67 Mbps download
7.55 Mbps upload

21:22 stopped trying to watch.


Buffering issues tend to be due to limitations of your home network or issues with your Plex Media Server transcoding the media. Your Plex Media Server should be hardwired into your local network, wireless is just unreliable for the kind of connection a server needs, especially a Plex server. Also make sure you have a Plex Media Server with the CPU power necessary to support your transcoding needs. See What kind of CPU do I need for my Server?

You should also determine if the issue is a Plex App for Roku issue by performing the same task on other types of Plex players. You can always use the Plex Web app from the browser on any computer, tablet, or phone. See Opening Plex Web App. Using a device other than your Plex Media Server system and connecting to your home network with the same method (Ethernet or wireless) and from the same distance as your Roku (do not stand right next to your router if your Roku is on the other side of your home) will also show any home networking issues.

If the issue occurs on all Plex player app and is transcoding, then it is a Plex Media Server issue, not an issue with the Plex app for Roku and you should post to the section of the forum for Plex Media Server on your operating system.


I did test same files this week on the iOS app on my iPhone. I was able to get the stream to play at 1.5 Mbps without issues. Noticed some lag during 2 Mbps. The main concern is I've used the same equipment previously during trips without issue. So this is a new issue that has just shown up. My parents have the same roku and have experienced the exact same behavior at their house.


It most likely is a weak and/or noisy wireless signal.

Was the media transcoding or direct playing on each device? I ask because it could be that the media was direct playing on your iOS app but transcoding on the Roku. Transcoded media is more susceptible to noise/interference in your wireless signal.

With Roku sticks, different TVs can cause more wireless interference than other based on the HDMI ports and their location. You should get and use the free HDMI extender that Roku offers. See And many find that using the 5 GHz Wi-Fi prevents noise interference better than 2.5 GHz.

Also, the wireless performance of modem/router combos provided by ISPs are often subpar and many users find that having a dedicated/separate router improves the quality of their wireless access. I had to set up a separate router for my parents because they had one of those combo devices from the ISP and their wireless signal was so weak.


I noticed on the playback for the roku kept saying it was transcoding (throttled).
Seemed to playback fine on my iphone 6. Forgot to check if it was transcoding that file or not.

My server at the time was wireless on a 5ghz band. I have my own modem SB6183 and my own router Apple Time Capsule...didn't have issues in previous traveling a couple of months ago.


For what it is worth, I think it is the Roku Plex app. I have a fully wired Ethernet home network. An Xbox One and the Roku are on the same Ethernet switch. The Xbox App does not buffer at all. But, the Roku recommends a smaller bit rate and will buffer occasionally. The only difference I can tell is the built in Ethernet port on the Roku Premiere+ is 10/100, only. But, that should be able to stream a 30mbps Blu Ray quality feed.


tonight I had the same problem. the roku would just say it was buffering - stuck at 99% - and not play. it would play films from the start, but not from partway through. I've discovered that it's worse with the second section of a multipart film. it has just stopped playing the second part. the roku says it's up to date, so does plex. I restarted everything on my network (all wired) and still doesn't work.


My Roku Ultra buffers ocasionally now too. It's on an all gigabit network, so I know it's not that. Will buffer all of sudden once or twice in a movie that is Direct Playing or Direct Streaming (thanks to the DTS Audio sync bug).


it's most likely the dreaded 7.7 firmware bugs


I will add to this that once I defragged the HDD that stores my media (large Blu Ray rips), this issue seemed to resolve.


I saw this solution that worked for me here:

Follow these steps:

Open Start Menu, right-click on Computer and select Properties
Under Control Panel Home located on the left side of the window click on Device Manager
You will get a list of all devices on your machine. Expand Network Adapters.
Find your Network Card and double-click on it.
Select Advanced tab. You will get a list filled with different options.
Select Large Send Offload V2 (IPv4) and set the value to Disabled
Do the same for Large Send Offload V2 (IPv6) if it is available
Click OK