Roku player get stuck at 99% when trying to play

roku

#1

We have a roku TV that isn't able to play a recorded TV show. The show is recorded with plex but it is recorded using another server on my network. I am able to play the file on the web interface. I converted the file to MP4 and it played. The issue continues, is there anyone else with similar issues? The issue started on Thursday and there was a new version of the Player for roku on Wednesday.


#2

I had the same issue on some HEVC videos
Prior to the update the same files could be forced direct play, and would do so without issue.


#3

There is a bug somewhere in how the new client is interacting with the transcoding process within Plex. OTA (Plex DVR) is recorded as mpeg2 unless you have a real-time transcode being done while recording. (SiliconDust has a HDHomeRun that does this for example)

The only known work around is to transcode the files into a format that has “native” support within your Roku device. Such as h264 level 4.1

Mpeg2 is not a supported format on Roku, so until the bug is fixed, Plex will be unable to transcode it in “real time” for you.


#4

I found that it is a problem with the transcoding. I am able to force the client to direct play and it will work. I read that this was a known issue when they released the client as a stable release. A little disappointing that it will not play recordings that was recorded on the Plex DVR. I hope for a fix soon.


#5

Add me to the list of people with DVR files that won’t play. I’ve found I only have this issue with files recorded from a certain channel for the most part. Roku TV as well.

Here are the file specs:
Video: 480i—H264
Audio: English—AC3 Stereo

Files of this type work fine:
Video: 720p—H264
Audio: English—AC3 Stereo

I have the HDHomeRun Extend, and PMS is running on Windows 10. Perhaps it’s the interlace part?


#6

@AmazingRando24 said:
Add me to the list of people with DVR files that won’t play. I’ve found I only have this issue with files recorded from a certain channel for the most part. Roku TV as well.

Here are the file specs:
Video: 480i—H264
Audio: English—AC3 Stereo

Files of this type work fine:
Video: 720p—H264
Audio: English—AC3 Stereo

I have the HDHomeRun Extend, and PMS is running on Windows 10. Perhaps it’s the interlace part?

So 480i is breaking even on h264? Try forcing direct play, Roku should be able to play it. I’d suspect Plex is transcoding it to deinterlace the feed.


#7

Actually, the workaround for me was the opposite. I had to disable direct play to get it to work. I had disabled direct stream first, but that did nothing.

Odd… It’s worked since the inception of DVR until this week.