Roku Premiere+ andLG OLED65B7A TV (4K + HDR)

roku

#1

Roku Premiere+
LG OLED65B7A TV (4K + HDR)

On the netflix and amazon app, playing a 4k HDR source will show on my TV "HDR" in the top right corner when the stream begins. This is how I know HDR is active. Without it, it will still play in 4K but without HDR.

In Plex 5.1.6 on Roku Premiere+ (the exact same setup as what works flawlessly in Netflix and Amazon) - the HDR does not show. So although the 4K sources appear in 4K, AND they appear without artifacts now after a recent update (thanks!), the HDR is still not functional. I have set the source to direct play, but still nothing. Any other settings to try? Or does this require another update by the Plex team?


#2

I can’t find an official answer, but Plex + 4k + HDR from server, and depending on client, all require a special alignment of the planets. (so it seems from discussions on the forums).
It seems the 4k requirement alone is picky about what type of encoding you pass it, else it’s transcoded to 1080p.
https://support.plex.tv/articles/214577427-is-4k-content-supported-on-the-roku/

I wouldn’t hold Plex to the blade on this as much as some might like - it seems the general support of ffmpeg (which plex uses custom version) and 4k hdr are at times questionable.


#3

I tried to contact support, check out the response below. Doesn’t seem OK for customers paying for a service…

As much as we would love to talk to every single one of our users, we are simply unable to provide one-on-one support via email.

This mailbox is not monitored

For Plex Pass-related billing issues, please visit our Plex Pass Billing contact form (https://www.plex.tv/contact/?option=plex-pass-billing). Fill out the information requested there and we’ll reply as quickly as possible, usually within 24-48 hours.

The best place to start for Plex support issues is our support site (https://support.plex.tv/). This site includes extensive documentation, guides, FAQs, and troubleshooting information.

If you are still encountering difficulties, please visit our support forums (https://forums.plex.tv/) to see if your problem is already documented. You can also post details there about the issue you’re having, and our staff or friendly community should be able to help you out.

If you’re having trouble signing in to your Plex account, need a password reset, or have to unlock your account, please visit the Plex sign-in page: https://www.plex.tv/sign-in/.

Thanks for reaching out—hopefully we can get your issue sorted quickly and easily through these channels!

Plex on!


#4

You have contacted support.
The forums and the KB are it, unless you have a billing issue.


#5

Still no luck here, can I get a plex response?


#6

Nobody else has this issue, not being able to watch HDR content through Plex?


#7

Sometime in the last week or two, Plex is now playing content that isn’t even HDR, through HDR mode on my TV. This makes less sense than before basically… and playback is also quite choppy now on the Roku with the plex app, anyone else experience this too?


#8

Make sure it’s not transcoding at all. I had the same issue and it turned out it was trying to burn in subtitles so it wasn’t handling the HDR. Once I fixed that I was able to get HDR again through direct play.